LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 02-14-2009, 05:19 PM   #1
BigNate37
LQ Newbie
 
Registered: Nov 2007
Location: Canada
Distribution: Ubuntu 8.10
Posts: 25

Rep: Reputation: 15
eth0 no longer works; does not have inet address (Ubuntu 8.10)


My Unbuntu machine was working fine up until I booted it this morning. I have no connectivity to the internet and an ifconfig shows that eth0 (my NIC) has no inet address, only an inet6 address:

Code:
eth0      Link encap:Ethernet  HWaddr 00:50:bf:9b:59:11
          inet6 addr: fe80::250:bfff:fe9b:5911/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:60 (60.0 B)  TX bytes:1766 (1.7 KB)
          Interrupt:21 Base address:0xce00

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436  Metric:1
          RX packets:14 errors:0 dropped:0 overruns:0 frame:0
          TX packets:14 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:984 (984.0 B)  TX bytes:984 (984.0 B)
The first thing I tried was using the onboard NIC, which I normally keep disabled in BIOS. The situation was identical to my regular PCI NIC, so I went back to that.

Based on searching this forum, I've tried disabling inet6 by editing /etc/modprobe.d/aliases, followed by eth0 down/up, networking restart, and system restarts but this does not change the output of ifconfig. I have since reverted my changes to aliases.

The lone system configuration change I made from when it was working was moving from wine 1.13 to 1.14 via the Synaptic Package Manager. Internet was available afterward until shutdown and restart.

I am running an older D-Link DI-514 wireless router with DHCP enabled; My Unbuntu box's MAC address is not on the DHCP clients list. Pinging the router (@ IPv4 192.168.0.1) from the Ubuntu box yields "connect: Network is unreachable". I have five machines in total vying for connections from the router so usually my WinXP laptop and my Ubuntu box share one physical port on the router via an old 10Mbps hub. I tried bypassing the hub on a hunch, to no avail.

Any ideas please?
 
Old 02-14-2009, 06:21 PM   #2
{BBI}Nexus{BBI}
Senior Member
 
Registered: Jan 2005
Location: Nottingham, UK
Distribution: Mageia 4
Posts: 4,305

Rep: Reputation: 205Reputation: 205Reputation: 205
Take a look in this thread: http://www.linuxquestions.org/questi...nboard-704199/ jump down to post #13 and see if that applies to your nic.
 
Old 02-14-2009, 07:25 PM   #3
BigNate37
LQ Newbie
 
Registered: Nov 2007
Location: Canada
Distribution: Ubuntu 8.10
Posts: 25

Original Poster
Rep: Reputation: 15
Resolved, I think.

Quote:
Originally Posted by {BBI}Nexus{BBI} View Post
Take a look in this thread: http://www.linuxquestions.org/questi...nboard-704199/ jump down to post #13 and see if that applies to your nic.
I'm afraid most of that was over my head. From what I gather, the fact that I've gotten some use out of my NIC after my first post in this thread should rule that out. I'm not sure when the last time I updated my kernel was, but I'm certainly going to read which dependencies are being selected by the update manager from now on. I am using the 2.6.27-11-generic kernel right now, and I'm not sure how long I've had it.



At any rate, my situation has changed; here is an update:

I found this (http://cs130wine.blogspot.com/2009/0...u-laptops.html) cryptic post and changed /etc/network/interfaces from
Code:
auto lo
iface lo inet loopback
to
Code:
auto eth0
iface eth0 inet dhcp
auto lo
iface lo inet loopback
This resulted in the following output, and my router got so screwed up I had to reset it to factory settings with a paper clip.
Code:
n@saline:/$ sudo /etc/init.d/networking restart
 * Reconfiguring network interfaces...                                          Internet Systems Consortium DHCP Client V3.1.1
Copyright 2004-2008 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:50:bf:9b:59:11
Sending on   LPF/eth0/00:50:bf:9b:59:11
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 17
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
                                                                         [ OK ]
n@saline:/$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:50:bf:9b:59:11  
          inet6 addr: fe80::250:bfff:fe9b:5911/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:105 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:39 dropped:0 overruns:0 carrier:78
          collisions:0 txqueuelen:1000 
          RX bytes:7235 (7.2 KB)  TX bytes:0 (0.0 B)
          Interrupt:21 Base address:0xde00 

eth0:avahi Link encap:Ethernet  HWaddr 00:50:bf:9b:59:11  
          inet addr:169.254.5.89  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          Interrupt:21 Base address:0xde00 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:22 errors:0 dropped:0 overruns:0 frame:0
          TX packets:22 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1576 (1.5 KB)  TX bytes:1576 (1.5 KB)

n@saline:/$
So I changed the interfaces file again, to this
Code:
auto eth0
iface eth0 inet dhcp
which seems to be working for now, minus Firefox starting up in offline mode. Reading this thread (https://answers.launchpad.net/ubuntu...question/31925) led me to believe that the contents of the interfaces file is sort of important to more than one program. One of the fixes they suggested was to undo what I had just done to get things working again! So I just told Firefox to ignore the network manager (toolkit.networkmanager.ignore = true in about:config), which fixed that up. I realize I am playing with fire here, but if the situation stays the same, I can live with this.
 
  


Reply

Tags
network, unreachable


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 detected, no interenet on knoppix live dvd but works on ubuntu smokespliffz Linux - Networking 1 01-08-2007 03:01 PM
inet<---eth1[LinuxBox_1]eth0<---e0[LinuxBox_2] : LinuxBox_2 hv no inet connection? Andrea_44 Linux - Networking 5 10-25-2006 09:18 PM
XP internet no longer works after dual boot w/ ubuntu CamelofCamelot Linux - Networking 1 09-16-2006 04:39 AM
eth0 device defaulting to inet6 rather than inet? schurt Fedora 1 06-11-2004 08:18 AM


All times are GMT -5. The time now is 02:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration