LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-14-2008, 09:09 AM   #1
pentalive
Member
 
Registered: Jun 2005
Location: Sacramento, CA
Distribution: Many, Old and New
Posts: 124

Rep: Reputation: 15
eth0 is ignoring me when I tell it "Activate at startup"


Fedora 9 Installed from live CD.

I have set the "activate on startup" both in system-config-networks and in the network gui tool.

After any reboot eth0 is not present in ipconfig. I go into the gui tool and activate it.

This machine will be a server so it doesn't want to run the gui...
 
Old 07-14-2008, 10:26 AM   #2
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,228
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
could you post the output of..
cat /etc/sysconfig/network-scripts/ifcfg-eth0


Static IP address configuration:

Code:
    DEVICE=eth0
    BOOTPROTO=static
    TYPE=Ethernet
    HWADDR=XX:XX:XX:XX:XX:XX
    BROADCAST=XXX.XXX.XXX.255
    IPADDR=XXX.XXX.XXX.XXX
    NETMASK=255.255.255.0
    NETWORK=XXX.XXX.XXX.0
    GATEWAY=XXX.XXX.XXX.XXX
    ONBOOT=yes 

Last edited by farslayer; 07-14-2008 at 10:27 AM.
 
Old 07-14-2008, 11:22 AM   #3
pentalive
Member
 
Registered: Jun 2005
Location: Sacramento, CA
Distribution: Many, Old and New
Posts: 124

Original Poster
Rep: Reputation: 15
[QUOTE=farslayer;3214044]could you post the output of..
cat /etc/sysconfig/network-scripts/ifcfg-eth0

# Realtek Semiconductor Co., Ltd. RTL8101E PCI Express Fast Ethernet controller
DEVICE=eth0
BOOTPROTO=none
HWADDR=00:1e:90:94:0a:bc
ONBOOT=yes
DNS1=192.168.1.1
NM_CONTROLLED=yes
TYPE=Ethernet
DHCP_HOSTNAME=beehive
USERCTL=no
PEERDNS=yes
IPV6INIT=no
IPADDR=192.168.1.80
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
 
Old 07-14-2008, 11:35 AM   #4
colucix
Moderator
 
Registered: Sep 2003
Location: Bologna
Distribution: CentOS 6.5 OpenSuSE 12.3
Posts: 10,503

Rep: Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957Reputation: 1957
Try to put NM_CONTROLLED=no. There are issues on Fedora 9, with Network Manager interfering with the activation of ethernet cards at startup. The above option tells that eth0 must not be controlled by Network Manager.

If you don't need Network Manager, e.g. if the server has a static IP address and wireless (or other devices) connectivity is not required, you can disable Network Manager and re-enable the old-fashioned network service.
 
Old 07-14-2008, 12:26 PM   #5
pentalive
Member
 
Registered: Jun 2005
Location: Sacramento, CA
Distribution: Many, Old and New
Posts: 124

Original Poster
Rep: Reputation: 15
disabled network manager, no fix

Thanks - I am trying that now.

I think I turned on network manager when it wasn't working the first time.

Rebooting now....

nope - didn't work.

Should BootProto say somthing other than "none"

Last edited by pentalive; 07-14-2008 at 12:29 PM.
 
Old 07-14-2008, 01:18 PM   #6
pentalive
Member
 
Registered: Jun 2005
Location: Sacramento, CA
Distribution: Many, Old and New
Posts: 124

Original Poster
Rep: Reputation: 15
I think I found it.

/etc/rc3.d does not have an S**network link in it. Fixed that, rebooted.. lookie my server has eth0!

Now on to apache and Samba!

This seems to be fixed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help me how ti manually activate "eth0" (noob) blackfox^^ Slackware 7 03-11-2008 10:58 AM
net working eth0 eth1 wlan0 "no connection" "no LAN" "no wi-fi" Cayitano Linux - Newbie 5 12-09-2007 07:11 PM
cruise control " Warning: -configfile=/cruisecontrol.xml not understood. Ignoring." emailssent Linux - Networking 0 02-28-2005 03:11 AM
not being able to activate the "ethernet card" eth0 b0nd Linux - Newbie 8 02-09-2005 12:04 PM
ignoring the "non-portable whitespace encountered at line " warning Jake13 Linux - Software 3 08-18-2004 12:34 PM


All times are GMT -5. The time now is 01:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration