LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-28-2003, 11:49 AM   #1
filo
LQ Newbie
 
Registered: Feb 2003
Posts: 2

Rep: Reputation: 0
eth0 interrupt


Hi, I'm having trouble setting the interrupts in Slack 8.1
I use a 3com 3c509 ISA PNP card

My mouse and NIC are using conflicting IRQ's (12), i've tried changing it manually in the isapnp.conf which is fine, and it says that it sets the IRQ to 3 on boot, but then for some reason when doing an ifconfig eth0 it says the interrupt is now 5 and the problem still exists...the only way i have found to correct this problem is to uplug the mouse if i know i need to use the internet and just work from console mode...and reboot when i need to login into the X server....now obvoiusly this doesn't create a very stable system and is a HUGE pain in the ass...so if anyone has any suggestions they would be greatly appreciated...

p.s. maybe i can change the irq that the mouse works on(also i have a microsoft wheel mouse but am currently using only the ps2/aux module for the mouse not imps2), so if someone knows how to do that please let me know.

Thanks,
Tim
 
Old 02-28-2003, 12:05 PM   #2
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
Have you tried doing this in your motherboard BIOS?
In the Plug & Play settings, you can assign an irq to Legacy ISA devices.

I don't know if Linux will honour this, but worth a try...
 
Old 02-28-2003, 01:27 PM   #3
filo
LQ Newbie
 
Registered: Feb 2003
Posts: 2

Original Poster
Rep: Reputation: 0
Yeah i've tried setting it manually in bios..but all it offers for selections are whether or not to switch the irq between Legacy ISA PNP or PCI/ISA PNP so i guess that won't do much here.
 
Old 02-28-2003, 02:06 PM   #4
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 47
It will allocate an irq that won't get stomped on.

I'm just not sure if Linux will respect the assignment or change it...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 Too much work at Interrupt. IntrStatus=0x0040 frieza Linux - Networking 2 01-30-2005 01:17 AM
eth0: Too much work at interrupt, IntrStatus=0x0001 taiguer Linux - Networking 3 01-30-2005 01:17 AM
Eth0: Too much work at interrupt problem? core_sa Red Hat 1 08-27-2004 12:17 PM
eth0: tx interrupt but no status G-Fox Linux - Networking 3 11-22-2003 09:04 AM
eth0: too much work at interrupt int Linux - Networking 1 08-12-2003 02:37 PM


All times are GMT -5. The time now is 12:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration