LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 04-23-2005, 07:17 PM   #1
maybbach
Member
 
Registered: Feb 2004
Location: Cincinnati, OH
Distribution: SimplyMepis 3.3
Posts: 68

Rep: Reputation: 15
eth0 goes down with dhcp enabled


Ive just installed Mepis 3.3 from the simply mepis cd. Whenever i configure eth0 to use dhcp, the interface goes down and stays down. when i use a static one it goes up no problem. i can ping other machines locally and connect to local ftp. i need dhcp because thats how i get online. i thought it was a driver problem, but since it works ok when its configured statically i ruled that out. im somewhat new to linux, so please bear with me if i dont know how to do something.

thanks
 
Old 04-24-2005, 02:24 PM   #2
bulliver
Senior Member
 
Registered: Nov 2002
Location: Edmonton AB, Canada
Distribution: Gentoo x86; Gentoo PPC; Gentoo Sparc64; FreeBSD; OS X; Solaris
Posts: 3,731
Blog Entries: 4

Rep: Reputation: 63
Is the dhcp server set up to provide your machine with an address? I would be looking at server settings on this one.
 
Old 04-24-2005, 04:57 PM   #3
maybbach
Member
 
Registered: Feb 2004
Location: Cincinnati, OH
Distribution: SimplyMepis 3.3
Posts: 68

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by bulliver
Is the dhcp server set up to provide your machine with an address? I would be looking at server settings on this one.
its the address im getting from my isp. on the same motherboard, with windows installed i get an address no problem. ive had the same issue with both mepis and fedora 3.

edit: i setup my own dhcp server in win2k and it received an address ok part of the time (it would receive addresses out of the pool of addresses allocated). im thinking it might be a driver issue, so im gonna try to install the newest drivers for it.

plz give any suggestions

thanks

Last edited by maybbach; 04-24-2005 at 06:58 PM.
 
Old 04-04-2006, 05:49 PM   #4
vimal
Red Hat India
 
Registered: Nov 2004
Location: Kerala/Pune,india
Distribution: RedHat, Fedora
Posts: 260

Rep: Reputation: 34
Hello maybbach,

How have you configured your ethernet card to accept DHCP? You will have to edit
the eth0 conf: file manually if other ways don't work. Just add 'BOOTPROTO=dhcp'
and restart the network service. Overall your matter needs more elaboration, so please do it if the method specified above dont work.

Thanks;
 
Old 04-04-2006, 09:36 PM   #5
maybbach
Member
 
Registered: Feb 2004
Location: Cincinnati, OH
Distribution: SimplyMepis 3.3
Posts: 68

Original Poster
Rep: Reputation: 15
thanks for the prompt reply!

the problem was with my isp. i had 2 many devices on the network. when i setup my own hdcp server i had no problems.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Eth0 : Promiscuous mode enabled singhrishi Linux - Software 1 10-10-2003 01:24 PM
Eth0 : Promiscuous mode enabled singhrishi Linux - Hardware 1 10-10-2003 01:24 PM
Eth0 : Promiscuous mode enabled singhrishi Linux - Networking 0 10-10-2003 07:10 AM
Eth0 : Promiscuous mode enabled singhrishi Linux - Software 0 10-10-2003 04:23 AM
eth0 is enabled in promiscous mode saravanan1979 Linux - Networking 11 06-15-2002 09:01 AM


All times are GMT -5. The time now is 02:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration