LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-23-2007, 07:11 PM   #1
Sessel
LQ Newbie
 
Registered: Dec 2007
Distribution: Gentoo
Posts: 9

Rep: Reputation: 0
eth0 doesn't exist | using gentoo


Hello,

I have seen many other threads about this, but apparently the outs given won't work for me. I have been trying to solve the problem for a long time but I can't find a solution. That's why I'm here and I hope so could help me.

I am using gentoo 2.6.17, my ethernet card (Realtek RTL-8139) used to work but since I recompiled the kernel (menuconfig not genkernel) to use my wireless network card (Broadcom BCM4318), neither one or the other will work. I tried to load bcm43xx as a module for the wireless network, but the module couldn't be loaded. Since ethernet was a priority, I gave up on wireless and tried to make it work again. I tried to recompile without bcm43xx, with rtl-8139 built-in or as a module.

I would gladly appreciate some help, and give you more information since what's here certainly won't be enough.
Thanks a lot and happy Christmas.
 
Old 12-23-2007, 07:20 PM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,239

Rep: Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020
8139too ???
 
Old 12-23-2007, 09:11 PM   #3
FraGGod
Member
 
Registered: Jun 2007
Location: Yekaterinburg, RU
Distribution: gentoo
Posts: 59

Rep: Reputation: 16
Strange thing that you're using gentoo and have such an old kernel but I doubt that's the issue.
Module for 8139 is indeed called 8139too, and if you've compiled it and all subfeatures it has make sure you installed all the modules with "make modules_install" and boot the right kernel. "modprobe 8139too" should be invoked if you use module.
Also make sure adapter isn't showing under "ifconfig -a" since udev can call it anything it likes, not eth0.
Finally, verify that you have the right device with "lspci"... just can't think of any other issues that can be there)
 
Old 12-24-2007, 10:07 AM   #4
Sessel
LQ Newbie
 
Registered: Dec 2007
Distribution: Gentoo
Posts: 9

Original Poster
Rep: Reputation: 0
Thanks for your quick answers.

Quote:
Strange thing that you're using gentoo and have such an old kernel but I doubt that's the issue.
Actually, it was the last kernel available when my network was still working. I said it was a long time ago

Quote:
Module for 8139 is indeed called 8139too, and if you've compiled it and all subfeatures it has make sure you installed all the modules with "make modules_install" and boot the right kernel. "modprobe 8139too" should be invoked if you use module.
I indeed used make modules_install and I checked the booting kernel too. Yet, I don't remember wether I tested with modprobe when I was compiling as a module
Here's the error message it gives me:
Quote:
FATAL: Error inserting 8139too (/lib/modules/2.6.17-gentoo-r4/kernel/drivers/net/8139too.ko): Invalid module format
Quote:
Also make sure adapter isn't showing under "ifconfig -a" since udev can call it anything it likes, not eth0.
ifconfig -a only shows lo (local loopback)

Quote:
Finally, verify that you have the right device with "lspci"...
Here's exactly what lspci gives me:
Quote:
[...]
06:02.0 Network controller: Broadcom Corporation BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller (rev 02)
[...]
06:06.0 Ethernet controller: Realtek Semiconductior Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
Hope this helps. I'm completely out of ideas.
Merry Christmas.
 
Old 12-24-2007, 10:38 AM   #5
FraGGod
Member
 
Registered: Jun 2007
Location: Yekaterinburg, RU
Distribution: gentoo
Posts: 59

Rep: Reputation: 16
Now that's a weird kind of error I've never encountered, but I've never used modules much.
Looks to me either the modules were not installed, their support is not compiled or sources are inconsistent, prehaps make compiles modules against wrong kernel's headers... I'm afraid all I can suggest is getting newer sources, trying to enable everything that looks related anyhow and starting from there.
Prehaps you should also make sure you have all the flags set to right values in /etc/make.conf, like "-march=prescott" (in my case) and pentium4/amd/core2/pc-compatible arch in kernel and looking for any suspicious enviroment vars which can make your kernel install fresh modules somewhere else. Another thing that comes to mind is to try copying module by hand and running depmod to tell kernel to refresh it's info about modules.
Worst thing that comes to mind is that your compiler itself is broken, not that there's any evidence of that...

Last edited by FraGGod; 12-24-2007 at 10:39 AM.
 
Old 12-24-2007, 10:48 AM   #6
dxqcanada
Member
 
Registered: Sep 2006
Location: Canada
Distribution: Gentoo
Posts: 702

Rep: Reputation: 43
Code:
FATAL: Error inserting 8139too (/lib/modules/2.6.17-gentoo-r4/kernel/drivers/net/8139too.ko): Invalid module format
What does
Code:
uname -a
show you ?

Invalid module format messages usually occur because the module that you are attempting to load does not fit with the running kernel.
 
Old 12-24-2007, 12:32 PM   #7
Sessel
LQ Newbie
 
Registered: Dec 2007
Distribution: Gentoo
Posts: 9

Original Poster
Rep: Reputation: 0
Hello,

Here's what the uname -a command gives me:
Quote:
#uname -a
Linux IbuX 2.6.17-gentoo-r4 #1 SMP Wed Aug 2 19:30:47 CEST 2006 x86_64 AMD Turion(tm) 64 Mobile Technology ML-32 AuthenticAMD GNU/Linux
 
Old 12-24-2007, 12:48 PM   #8
crashmeister
Senior Member
 
Registered: Feb 2002
Distribution: t2 - trying to anyway
Posts: 2,541

Rep: Reputation: 47
This is just a wild guess but since your date and time is waayyy off I'd try to see what dates are on the kernel files and set some date later than that.
 
Old 12-24-2007, 01:46 PM   #9
Sessel
LQ Newbie
 
Registered: Dec 2007
Distribution: Gentoo
Posts: 9

Original Poster
Rep: Reputation: 0
Well,

I am downloading the last release and installing it tonight. If the problem is due to kernel date, this should solve the problem. I'll update the info if the problem still occur.
Thanks for your help.
 
Old 12-24-2007, 03:56 PM   #10
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,239

Rep: Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020Reputation: 1020
I'd reckon you didn't update the /usr/src/linux symlink to point to your new source tree. Check that, then rebuild.
 
  


Reply

Tags
bcm4318, kernel, modules, networking, rtl8139


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 does not exist jeffery1974 Linux - Software 1 04-18-2007 10:21 AM
eth0 doesn't exist in Gentoo Continuum Linux - Networking 8 05-10-2006 08:36 AM
Networking: eth0 does not exist (gentoo) symmet Linux - Networking 19 10-07-2005 10:54 AM
eth0 does not exist question Dahshouin Linux - Newbie 1 09-12-2005 12:48 AM
eth0 and eth1 can't co-exist satimis Linux - Hardware 1 11-12-2003 08:09 AM


All times are GMT -5. The time now is 02:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration