LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   eth0: Device eth0 has different MAC address than expected,ignoring. (http://www.linuxquestions.org/questions/linux-networking-3/eth0-device-eth0-has-different-mac-address-than-expected-ignoring-567075/)

lin1010 07-06-2007 05:29 AM

eth0: Device eth0 has different MAC address than expected,ignoring.
 
i has two netdevice eth0 eth1;it can Bringing up;and work well;
but when shutdown or reboot the system;it print error messeage like this:
shuting down interface eth0: Device eth0 has different MAC address than expected,ignoring. [FAILED]
shuting down interface eth1: Device eth0 has different MAC address than expected,ignoring. [FAILED]
#cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=static
IPADDR=192.168.100.203
MTU=1500
#cat /etc/sysconfig/network-scripts/ifcfg-eth1
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=static
IPADDR=192.168.101.210
MTU=1500
os:CentOS release 4.4 (Final) ;kernel:2.6.9-42.0.3.ELsmp
how can i resove this problem?

jschiwal 07-06-2007 07:46 AM

Look at the files in /etc/sysconfig/networking/.

Code:

# 3Com Corporation 3c905C-TX/TX-M [Tornado]
DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=00:08:74:46:D7:E5
ONBOOT=yes
DHCP_HOSTNAME=delllap.jesnet
TYPE=Ethernet

See if the HWADDR entries for each device is correct. If they are, I wonder if it could be an interrupt or device memory conflict. Maybe you could look at what the module options are, if any in /etc/modpobe.conf for eth0 and eth1.

lin1010 07-08-2007 09:34 PM

thanks for your reply.
I have add "HWADDR" filed in ifcfg-eth0 ifcfg-eth1 , but it still have error message.
ifcfg-eth0
HWADDR=00:30:48:2C:01:22
ifcfg-eth1
HWADDR=00:30:48:2C:01:23
#cat /etc/modprobe.conf
alias eth0 e1000
alias eth1 e1000
alias scsi_hostadapter ata_piix
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd
alias net-pf-10 off
alias ipv6 off

MindStalker 08-10-2010 09:45 AM

Quote:

Originally Posted by lin1010 (Post 2815741)
thanks for your reply.
I have add "HWADDR" filed in ifcfg-eth0 ifcfg-eth1 , but it still have error message.


You want to edit the files in /etc/sysconfig/networking/devices/

Not the files in /etc/sysconfig/network-scripts

Rahil Parikh 11-23-2010 11:10 PM

Quote:

Originally Posted by MindStalker (Post 4061955)
You want to edit the files in /etc/sysconfig/networking/devices/

Not the files in /etc/sysconfig/network-scripts

Hi, I have similar problem. Just the difference is instead of two cards I have only one card. And In /etc/sysconfig/networking/devices/ I have nothing. The directory is empty. Any idea about what I should do?

PS :: I use CentOS 3.9 (Final) Server

Thanks!

TB0ne 11-24-2010 07:30 AM

Quote:

Originally Posted by Rahil Parikh (Post 4169018)
Hi, I have similar problem. Just the difference is instead of two cards I have only one card. And In /etc/sysconfig/networking/devices/ I have nothing. The directory is empty. Any idea about what I should do?

PS :: I use CentOS 3.9 (Final) Server

Thanks!

Yes, you can open your own thread, for your own problem. This original thread is three years old, and the posts in this thread TELL YOU WHAT TO DO, if you read them.


All times are GMT -5. The time now is 11:18 AM.