Help answer threads with 0 replies.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 03-05-2005, 11:29 PM   #1
LQ Newbie
Registered: Sep 2004
Location: Washington, DC
Distribution: (K)ubuntu
Posts: 16

Rep: Reputation: 0
Question eth0 can't get IP with DHCP, static config. attempts can't ping

I'm using SuSE 9.1 personal and can't seem to get my wired connection to my router working. I have cable internet service, routed with a Linksys BEFW11S4 router. I have an XP box and a Mac connected wirelessly, and a Win98 box and my linux box with a wired connection. I have a Netgear NIC that SuSE recognizes. Yast wants to use the "tulip" module for this NIC.

When I boot SuSE, it requests an IP for eth0 via DHCP, but then puts the waiting process in the background.

I had been configuring eth0 through Yast, but then decided to try a command-line configuration with a static IP. My router is, and I assigned eth0 the IP with ifconfig and set the default gateway to with the route command. I also included DNS server IP's (confirmed to be working by the Win98 box) in the resolv.conf file. I was then able to ping eth0 (, had all packets dropped when trying to ping any other ip on my LAN, or the gateway, or any IP on the internet.

So... I used Yast to delete the configuration for eth0, and then went back to having Yast configure eth0 for DCHP, and that's where I am now. (In the end, I'd prefer DHCP but will accept a static IP if necessary) You'll see below that the current routing table doesn't have the defaulty gateway, but I get an error ("Network not reachable", IIRC) when I try to add it with the route command.

With the current configuration, ping attempts (to return "Network not reachable". Same response for ping attempts to local LAN IPs.

One additional tidbit, before I post the diagnostic info: With the SuSE 9.1 live CD, I had a working internet connection via DHCP once, but have been unable to duplicate it. For those concaerned about hardware issues, I tried the above (unsuccessful) DHCP process with the cable and router slot that the Win98 box uses, and had no better luck.

What am I missing? Here are the diagnostics:

eth0      Link encap:Ethernet  HWaddr 00:A0:CC:60:1E:ED  
          inet6 addr: fe80::2a0:ccff:fe60:1eed/64 Scope:Link
          RX packets:1882 errors:11 dropped:0 overruns:0 frame:0
          TX packets:426 errors:1 dropped:0 overruns:0 carrier:1
          collisions:0 txqueuelen:1000 
          RX bytes:223405 (218.1 Kb)  TX bytes:87294 (85.2 Kb)
          Interrupt:10 Base address:0xe400 

lo        Link encap:Local Loopback  
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:184 errors:0 dropped:0 overruns:0 frame:0
          TX packets:184 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:16062 (15.6 Kb)  TX bytes:16062 (15.6 Kb)
route -n:
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface       U     0      0        0 lo
/etc/hosts: (I added the router entry during the static setup)
# hosts         This file describes a number of hostname-to-address
#               mappings for the TCP/IP subsystem.  It is mostly
#               used at boot time, when no name servers are running.
#               On small systems, this file can be used instead of a
#               "named" name server.
# Syntax:
# IP-Address  Full-Qualified-Hostname  Short-Hostname
#       localhost

# special IPv6 addresses
::1             localhost ipv6-localhost ipv6-loopback

fe00::0         ipv6-localnet

ff00::0         ipv6-mcastprefix
ff02::1         ipv6-allnodes
ff02::2         ipv6-allrouters
ff02::3         ipv6-allhosts     router lemonade
resolv.conf: (I think this is leftover from the static setup)
0000:00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
0000:00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
0000:00:07.0 ISA bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
0000:00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
0000:00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
0000:00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 02)
0000:00:0e.0 Ethernet controller: Lite-On Communications Inc LNE100TX (rev 20)
0000:00:10.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 05)
0000:00:10.1 Input device controller: Creative Labs SB Live! MIDI/Game Port (rev 05)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP 1X/2X (rev 5c)
Module                  Size  Used by
nls_iso8859_1           4224  1 
nls_cp437               5888  1 
vfat                   14080  1 
fat                    43328  1 vfat
af_packet              20360  2 
nvram                   8328  0 
usbserial              28912  0 
parport_pc             35264  1 
lp                     10916  0 
parport                37704  2 parport_pc,lp
snd_seq_oss            30976  0 
snd_pcm_oss            56868  0 
snd_mixer_oss          18688  1 snd_pcm_oss
snd_seq_midi            8864  0 
snd_emu10k1_synth       8448  0 
snd_emux_synth         38528  1 snd_emu10k1_synth
snd_seq_virmidi         7552  1 snd_emux_synth
snd_seq_midi_event      7680  3 snd_seq_oss,snd_seq_midi,snd_seq_virmidi
snd_seq_midi_emul       7680  1 snd_emux_synth
snd_seq                54672  9 snd_seq_oss,snd_seq_midi,snd_emux_synth,snd_seq_virmidi,snd_seq_midi_event,snd_seq_midi_emul
processor              16040  0 
speedstep_lib           3712  0 
snd_emu10k1            86916  6 snd_emu10k1_synth
snd_rawmidi            24992  3 snd_seq_midi,snd_seq_virmidi,snd_emu10k1
snd_pcm                96776  2 snd_pcm_oss,snd_emu10k1
snd_timer              25476  2 snd_seq,snd_pcm
snd_seq_device          8328  7 snd_seq_oss,snd_seq_midi,snd_emu10k1_synth,snd_emux_synth,snd_seq,snd_emu10k1,snd_rawmidi
freq_table              4612  0 
snd_ac97_codec         60676  1 snd_emu10k1
snd_page_alloc         11012  2 snd_emu10k1,snd_pcm
snd_util_mem            4992  2 snd_emux_synth,snd_emu10k1
snd_hwdep               9732  2 snd_emux_synth,snd_emu10k1
snd                    59524  27 snd_seq_oss,snd_pcm_oss,snd_mixer_oss,snd_seq_midi,snd_emu10k1_synth,snd_emux_synth,snd_seq_virmidi,snd_seq_midi_event,snd_seq_midi_emul,snd_seq,snd_emu10k1,snd_rawmidi,snd_pcm,snd_timer,snd_seq_device,snd_ac97_codec,snd_util_mem,snd_hwdep
soundcore               8800  1 snd
edd                     9240  0 
joydev                 10176  0 
st                     38940  0 
sr_mod                 15652  0 
ipt_TCPMSS              4352  1 
ide_cd                 36484  0 
cdrom                  36508  2 sr_mod,ide_cd
ipt_TOS                 2432  9 
ipt_state               1920  51 
ipt_LOG                 5632  51 
sg                     35360  0 
sd_mod                 19840  0 
usb_storage            59584  0 
scsi_mod              107980  5 st,sr_mod,sg,sd_mod,usb_storage
usblp                  12032  0 
uhci_hcd               29584  0 
intel_agp              17052  1 
agpgart                28712  1 intel_agp
emu10k1_gp              3584  0 
gameport                4736  1 emu10k1_gp
tulip                  44576  0 
usbcore                96988  6 usbserial,usb_storage,usblp,uhci_hcd
evdev                   9600  0 
ip6t_LOG                5504  2 
ip6t_REJECT             7168  3 
ip6table_mangle         2688  0 
ipt_REJECT              6400  3 
iptable_mangle          2816  1 
iptable_filter          2816  1 
ip_nat_ftp              4720  0 
iptable_nat            21548  1 ip_nat_ftp
ip_conntrack_ftp       71856  1 ip_nat_ftp
ip_conntrack           30768  4 ipt_state,ip_nat_ftp,iptable_nat,ip_conntrack_ftp
ip_tables              17152  8 ipt_TCPMSS,ipt_TOS,ipt_state,ipt_LOG,ipt_REJECT,iptable_mangle,iptable_filter,iptable_nat
ip6table_filter         2560  1 
ip6_tables             18448  4 ip6t_LOG,ip6t_REJECT,ip6table_mangle,ip6table_filter
ipv6                  244100  15 ip6t_REJECT,ip6_tables
subfs                   7296  2 
dm_mod                 50044  0 
reiserfs              233808  1
ethtool eth0:
Settings for eth0:
No data available
Old 03-05-2005, 11:44 PM   #2
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 122Reputation: 122
Well, the tulip driver should be the right one. The LNE100TX is actually a linksys chipset, I believe. Try running mii-tool eth0 to see if it's properly recognizing the connection and achieving autonegotiation.
Old 03-06-2005, 12:24 AM   #3
LQ Newbie
Registered: Sep 2004
Location: Washington, DC
Distribution: (K)ubuntu
Posts: 16

Original Poster
Rep: Reputation: 0
"mii-tool eth0" gives:
SIOCGMIIPHY on 'eth0' failed: Operation not supported
"mii-tool" gives:
SIOCGMIIPHY on 'eth0' failed: Operation not supported
no MII interfaces found
Old 03-06-2005, 12:41 AM   #4
LQ Newbie
Registered: Sep 2004
Location: Washington, DC
Distribution: (K)ubuntu
Posts: 16

Original Poster
Rep: Reputation: 0

Got it! Of course, after a week of googling and searching here and trying new things, I find the answer 30 minutes after I post a last resort plea for help.

The trick is to boot with the option "acpi=off"

Here's where I found it:

Hope that helps someone else!
Old 03-06-2005, 11:07 AM   #5
LQ Newbie
Registered: Sep 2004
Location: Washington, DC
Distribution: (K)ubuntu
Posts: 16

Original Poster
Rep: Reputation: 0

ARGGH! Now it's not working again, with seemingly nothing changed. (still using acpi=off at boot) Any other ideas?
Old 03-06-2005, 12:54 PM   #6
Registered: Oct 2004
Posts: 42

Rep: Reputation: 15
Look at your ifconfig. It says inet6 addr! Are you using IPv6 ? I guess not so I bet the problem is here. Your DHCP provided you IPv6 address. Do not use any configuration tool because the setting may be lost after reboot, instead check the network configuration files:

1. /etc/sysconfig/network-scripts/ifcfg-eth0

It may be located in a different place. Google a little to see how this file is constructed.

2. /etc/resolf/conf - you got it done right

3. etc/hosts localhost.localdomain localhost

ad this (not obligatory) name

# ifdown eth0
# ifup eth0
to restart the networking so you dont need to reboot
Old 03-06-2005, 10:53 PM   #7
LQ Newbie
Registered: Sep 2004
Location: Washington, DC
Distribution: (K)ubuntu
Posts: 16

Original Poster
Rep: Reputation: 0
Ok, it's working again. Just for kicks, I climbed behind my desk and noticed (to my dismay) no LEDs on the NIC, and wiggled the Cat5 cable. Sure enough, I got a connection. I ran "dhcpcd eth0" and we're off and running! (posting right now from the box in question)

So the solution was the acpi=off option during boot (see post above), and everything after that was just a truly "bad connection." It's a good reminder to always double check the basics!

I'm a long-time-reader and first-time-poster so thanks everyone for the help.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0 static config for Sarge net install Peff Linux - Networking 1 07-04-2005 08:30 AM
Eth0 set up for Static, obtaining DHCP address?! IndustrialGeek Linux - Networking 2 01-03-2005 01:39 AM
FC2 Overriding static if in favor of dhcp system set for static pkraus109 Linux - Networking 8 09-21-2004 12:13 PM
howto delete existing static ip of ethernet(eth0)& reconf multiple ips on eth0 viveku Linux - Networking 2 02-02-2004 02:30 AM
howto delete static ip configured on eth0 & reconf multiple ip on one eth0(redhat8 viveku Linux - Networking 0 01-31-2004 11:40 AM

All times are GMT -5. The time now is 05:41 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration