LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 04-24-2008, 04:05 PM   #1
lrt
Member
 
Registered: Sep 2007
Location: Chattanooga, TN
Distribution: Ubuntu
Posts: 84

Rep: Reputation: 15
/etc/init.d/networking restart (ERRORS)


i have two interfaces both assigned static ip addresses. here is /etc/network/interfaces
Code:
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.1.102
netmask 255.255.255.0
network 192.168.1.0
gateway 192.168.1.1

auto eth1
iface eth1 inet static
address 192.168.2.1
netmask 255.255.255.0
network 192.168.2.0
gateway 192.168.1.102
eth1 is serving dhcp addresses. here is my subnet declaration in dhcpd.conf

Code:
subnet 192.168.2.0 netmask 255.255.255.0 {
  range 192.168.2.10 192.168.2.50;
  option routers 192.168.2.1;
}
when i try to start the network i get the following error:

Code:
root@pandion:/home/leandro# /etc/init.d/networking restart
 * Reconfiguring network interfaces...
SIOCADDRT: No such process
Failed to bring up eth1.
[ OK ]
my theory is that i don't think it likes the gateway address for eth1 (which is the ip address of eth0). if i comment the gateway line for eth1 in the interfaces file and then restart networking i get a different error:

Code:
root@pandion:/etc/default# /etc/init.d/networking restart
 * Reconfiguring network interfaces... 
RTNETLINK answers: No such process
[ OK ]
i'm also doing ip forwarding and internet connection sharing from eth1 to eth0 with syscntl.conf and some iptables rules. this works fine because all my dhcp clients can browse the web and receive leased addresses.

what i don't understand is why i am getting those errors when i restart networking????? is the gateway address wrong???
 
Old 04-24-2008, 04:07 PM   #2
andybrr
Member
 
Registered: Mar 2006
Posts: 54

Rep: Reputation: 15
Interfaces

Hi,

What happens if you try to bring the interfaces with ifconfig ethx ip_address up ?

Anderson

Quote:
Originally Posted by lrt View Post
i have two interfaces both assigned static ip addresses. here is /etc/network/interfaces
Code:
auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
address 192.168.1.102
netmask 255.255.255.0
network 192.168.1.0
gateway 192.168.1.1

auto eth1
iface eth1 inet static
address 192.168.2.1
netmask 255.255.255.0
network 192.168.2.0
gateway 192.168.1.102
eth1 is serving dhcp addresses. here is my subnet declaration in dhcpd.conf

Code:
subnet 192.168.2.0 netmask 255.255.255.0 {
  range 192.168.2.10 192.168.2.50;
  option routers 192.168.2.1;
}
when i try to start the network i get the following error:

Code:
root@pandion:/home/leandro# /etc/init.d/networking restart
 * Reconfiguring network interfaces...
SIOCADDRT: No such process
Failed to bring up eth1.
[ OK ]
my theory is that i don't think it likes the gateway address for eth1 (which is the ip address of eth0). if i comment the gateway line for eth1 in the interfaces file and then restart networking i get a different error:

Code:
root@pandion:/etc/default# /etc/init.d/networking restart
 * Reconfiguring network interfaces... 
RTNETLINK answers: No such process
[ OK ]
i'm also doing ip forwarding and internet connection sharing from eth1 to eth0 with syscntl.conf and some iptables rules. this works fine because all my dhcp clients can browse the web and receive leased addresses.

what i don't understand is why i am getting those errors when i restart networking????? is the gateway address wrong???
 
Old 04-24-2008, 05:30 PM   #3
lrt
Member
 
Registered: Sep 2007
Location: Chattanooga, TN
Distribution: Ubuntu
Posts: 84

Original Poster
Rep: Reputation: 15
haven't tried that.. however, i won't be able to try until tomorrow... i will update then.. why should that method be any different though??
 
Old 04-25-2008, 10:00 AM   #4
lrt
Member
 
Registered: Sep 2007
Location: Chattanooga, TN
Distribution: Ubuntu
Posts: 84

Original Poster
Rep: Reputation: 15
ok i tried that and the command completes without errors....

but i'm not sure how that helps me...
 
Old 04-26-2008, 03:08 AM   #5
datopdog
Member
 
Registered: Feb 2008
Location: JHB South Africa
Distribution: Centos, Kubuntu, Cross LFS, OpenSolaris
Posts: 806

Rep: Reputation: 41
your configuration for eth1 is wrong the gateway has to be on the same network. 192.168.1.102 is not on 192.168.2.0/24
 
Old 04-28-2008, 01:35 PM   #6
lrt
Member
 
Registered: Sep 2007
Location: Chattanooga, TN
Distribution: Ubuntu
Posts: 84

Original Poster
Rep: Reputation: 15
so what does the gateway address for eth1 need to be if i am assigning everything statically???
 
Old 04-28-2008, 01:51 PM   #7
datopdog
Member
 
Registered: Feb 2008
Location: JHB South Africa
Distribution: Centos, Kubuntu, Cross LFS, OpenSolaris
Posts: 806

Rep: Reputation: 41
why do u need multiple default gateways anyway ?
 
Old 04-28-2008, 02:53 PM   #8
lrt
Member
 
Registered: Sep 2007
Location: Chattanooga, TN
Distribution: Ubuntu
Posts: 84

Original Poster
Rep: Reputation: 15
Smile

this >>>post<<< (unfortunately not here) has answered my question pretty thoroughly.. apparently i don't even need a gateway address set for eth1. the only gateway address i need to assign is for eth0.. dhcp clients on the eth1 subnet will receive a gateway address of my eth1 ip address (192.168.2.1). in other words, i don't need multiple gateways (i just wasn't aware of this).

the post was specific to windows 2003 server... but it was a networking question so i assume it still applies to my problem... if anyone could confirm this solution that would be great...

HOWEVER, when i do a /etc/init.d/networking restart, i still get this error message:

Code:
RTNETLINK answers: No such process
i'm not sure what this means, but now i am pretty sure it has nothing to do with my gateway address setting since i know the setting is correct...

any thoughts on this error are welcome. please!!!
 
Old 04-29-2008, 01:15 AM   #9
datopdog
Member
 
Registered: Feb 2008
Location: JHB South Africa
Distribution: Centos, Kubuntu, Cross LFS, OpenSolaris
Posts: 806

Rep: Reputation: 41
its correct that you need one gateway most times, please look at /var/log/syslog when you restart networking to see what is causing the RTNETLINK error
 
Old 04-29-2008, 11:38 AM   #10
lsteacke
Member
 
Registered: Jul 2007
Distribution: Ubuntu
Posts: 99

Rep: Reputation: 16
Usually the error

Code:
RTNETLINK answers: No such process
Comes from the kernel trying to instantiate a route that does not exist. Please post the output of

Code:
route -n
so we can have a look.
 
Old 03-09-2009, 08:21 PM   #11
Mountain
Member
 
Registered: Nov 2007
Location: A place with no mountains
Distribution: Kubuntu, sidux, openSUSE
Posts: 214

Rep: Reputation: 33
I have the exact same error.

Here is route -n output:
Code:
myuser@myserver:$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
0.0.0.0         192.168.1.1     0.0.0.0         UG    100    0        0 eth1
0.0.0.0         192.168.1.1     0.0.0.0         UG    100    0        0 eth0
myuser@myserver:$
 
Old 03-10-2009, 10:11 AM   #12
lsteacke
Member
 
Registered: Jul 2007
Distribution: Ubuntu
Posts: 99

Rep: Reputation: 16
I think that has something to do with having 2 default routes, both the same. What is your desired configuration? What are you attempting to accomplish? Can you also please post the output of ifconfig -a
 
Old 03-10-2009, 11:43 AM   #13
Mountain
Member
 
Registered: Nov 2007
Location: A place with no mountains
Distribution: Kubuntu, sidux, openSUSE
Posts: 214

Rep: Reputation: 33
Thank you. You were right. I removed the gateway designation from the second interface, and now it works.

What is the best configuration for my file server with 2 GigE interfaces? I'd like to maximize the file server's responsiveness to clients on the LAN. The machine has minimal need to communicate with the WAN.

I'm also curious how I would set up a direct connection between this file server and another computer used for backup (say, using a crossover cable) so that when I do the initial backup, all those GB of traffic don't clog up the LAN.

And if I wanted to give one (Linux) client a priority connection (both ways) to the file server, is there an easy way to do that? The client also has 2 GigE interfaces, and one is not used currently.

Thanks.
 
Old 03-10-2009, 11:44 AM   #14
Mountain
Member
 
Registered: Nov 2007
Location: A place with no mountains
Distribution: Kubuntu, sidux, openSUSE
Posts: 214

Rep: Reputation: 33
With the resolution:
Code:
$ ifconfig -a
eth0      Link encap:Ethernet  HWaddr xxxxxxxxxxxxxxxxxxxxxxxxxxxxx  
          inet addr:192.168.1.5  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: xxxxxxxxxxxxxxxxxx/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:78914 errors:0 dropped:0 overruns:0 frame:0
          TX packets:40231 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:52699848 (52.6 MB)  TX bytes:3980091 (3.9 MB)

eth1      Link encap:Ethernet  HWaddr xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx  
          inet addr:192.168.1.6  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fxxxxxxxxxxxxxxxxxxxxxx1/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:8356 errors:0 dropped:0 overruns:0 frame:0
          TX packets:139 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:976698 (976.6 KB)  TX bytes:17645 (17.6 KB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1966 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1966 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:156568 (156.5 KB)  TX bytes:156568 (156.5 KB)

pan0      Link encap:Ethernet  HWaddr xxxxxxxxxxxxxxxxxxxxxx  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Permissions on script sudo ln -s ../init.d/start-networking S90start-networking cnolasco Ubuntu 3 04-03-2007 09:27 AM
/etc/init.d/mysql restart problem meenalborkar Debian 3 11-11-2005 08:40 AM
fluxbox init overwritten in every restart. xushi Slackware 3 07-09-2005 03:31 PM
scanlogd able to send an email or do /etc/init.d/adsl restart saavik Linux - Security 1 12-05-2003 02:34 PM
/etc/rc.d/init.d/sendmail restart ssrikant Linux - Networking 3 04-23-2003 03:27 PM


All times are GMT -5. The time now is 08:46 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration