LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Enable Wireless & USB Internet Access CentOS 6.3 (http://www.linuxquestions.org/questions/linux-networking-3/enable-wireless-and-usb-internet-access-centos-6-3-a-4175467302/)

01010011 06-25-2013 07:26 AM

Enable Wireless & USB Internet Access CentOS 6.3
 
I just finished reinstalling Windows XP on my Compaq laptop. Now, I'm in the process of dual booting XP with CentOS 6.3 using a live CD. I'm currently logged into CentOS and I'm trying to get the networking working. I'm using the Huawei MiFi for internet access (it provides internet access via a micro USB cable and wirelessly). I'm trying to get internet access working via both micro USB cable and wirelessly.

Code:

service network status
displays:

Quote:

lo
Currently active devices:
lo eth0 wlan0
Code:

service wpa_supplicant status
displayed:

Quote:

wpa_supplicant (pid 1685) is running...
Quote:

iwconfig
displays:

Quote:

lo no wireless extensions.
eth0 no wireless extensions.
wlan0 IEEE 802.11bg ESSID:off/any
Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
Retry long limit:7 RTS thr:off Fragment thr:off
Power Management:off
Code:

lspci | grep -i wlan0
displays

Quote:

Realtek Semiconductor Co. Ltd. RTL - 8139/8139C/8139C+ (rev 10)
I was reading in this answer that since i'm using a laptop, I should let NetworkManager have control and turn off both
the network and wpa_supplicant services (is this true? Why?). As a result, I completed the following commands:

Code:

service network stop
service wpa_supplicant stop
chkconfig --level 12345 network off
chkconfig --level 12345 wpa_supplicant off
chkconfig --level 2345 NetworkManager on
service NetworkManager restart

I restarted my computer.

Code:

service network status
displayed

Quote:

Configured devices:
lo
Currently active devices:
lo eth0
Code:

service wpa_supplicant status
displayed

Quote:

wpa_supplicant (pid 1673) is running...
Code:

service Networkmanager status
displayed

Quote:

NetworkManager (pid 1568) is running...
When I look at the computer icons, I noticed:

Quote:

Wired Network disconnected

Wireless Networks wireless is disabled
I don't know what to try again. How do I enable access so I can access the internet via both wireless and micro USB cable? Any assistance will be greatly appreciated. Thanks in advance.

nini09 06-26-2013 03:23 PM

For wireless connection, the status show the client doesn't associate with AP. You need check wireless configuration, such as SSID. You should turn off WPA at first to make basic wireless configuration work and then turn it on again.


All times are GMT -5. The time now is 02:09 PM.