LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-17-2002, 11:30 PM   #1
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,091

Rep: Reputation: 369Reputation: 369Reputation: 369Reputation: 369
dummy terminal


i have a yellowdog linux instalation on a mac powerbook, i'm trying to configure a dummy terminal to run as a remote consol for the computer. I have it inserted into the /etc/inittab as


S0:2345:respawn:/sbin/mingetty ttyS0 DT38400

it works, but extremely crudely, as the output is not formatted verry well. (not properly alligned mostly) and sometimes the command prompt doesn't finish appearing, is the problem at the computer end, the terminal end, or both?

the teminal is a Wyse model wy150, yes i am using a null modem adapter
 
Old 02-18-2002, 01:01 PM   #2
Malicious
Member
 
Registered: Jan 2002
Location: Galveston Island
Distribution: suse, redhat
Posts: 208

Rep: Reputation: 30
Sounds like you may be getting buffer overruns at the terminal end. Try running at a slower speed and see if that helps. Sometimes null modem cables don't carry the hardware flow control signals that would prevent this. The tty could be configured to ignore hardware flow control also.
 
Old 02-18-2002, 06:21 PM   #3
frieza
Senior Member
 
Registered: Feb 2002
Location: harvard, il
Distribution: Ubuntu 11.4,DD-WRT micro plus ssh,lfs-6.6,Fedora 15,Fedora 16
Posts: 3,091

Original Poster
Rep: Reputation: 369Reputation: 369Reputation: 369Reputation: 369
no dice on changing speed, it only made things worse, unless i did something wrong, I changed the DT38400 to both 19200 and 9600, used init q and killed the currently running getty, both times changing the dumb termina's speed, but it only came up with garbage, as for configuring the tty to ignore hardware control, i'm not sure how to do that, i may not be exactly a newbie, but i'm no expert either
 
Old 02-27-2002, 05:31 PM   #4
Malicious
Member
 
Registered: Jan 2002
Location: Galveston Island
Distribution: suse, redhat
Posts: 208

Rep: Reputation: 30
Apologies for the delay in getting back into this thread. I have one of those either/or system networks that is a VPN to work or internet. Been working to hard... Anyway, after answering your email, I had to come back to the thread to see what your original question was.

I should have noticed before, but your inittab entry shows that you are trying to use mingetty on a serial port. mingetty (man mingetty) is a stripped down version of getty for virtual consoles and does not do any tty port settings.

You should use agetty (man agetty) instead.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dummy bong.mau Programming 10 09-01-2005 12:29 PM
Dummy Network Mistake d0127810 Debian 11 05-24-2005 09:21 PM
Dummy question about Nautilius ??? burki Linux - General 12 03-12-2005 06:38 PM
Dummy interface?? wtf?? DertyolBA$HTARD Linux - Networking 1 11-14-2004 10:01 AM
real DUMMY my MOuSE dzt Linux - Newbie 5 10-15-2003 08:39 PM


All times are GMT -5. The time now is 12:51 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration