LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-24-2003, 07:31 PM   #1
cheezey
LQ Newbie
 
Registered: Aug 2003
Location: Fremont,CA
Distribution: Red Hat 9.0/8.0
Posts: 3

Rep: Reputation: 0
DSL Linux Router


I just got SBC Yahoo DSL. I previously had and still have Comcast Cable to connect to the internet. Currently my home network setup is:

Cable Modem >> RH8 Linux Router >> 4-port hub to other comps.

I have 7 computers on the network total all have worked perfectly fine. Now that I installed the DSL, the only computer that can get online is the router. I used rp-pppoe to connect and like i said the router connects fine, but the remaining computers are having a problem. I'm clueless as to how this isn't working. I figure it should be compatible either way since i'm connecting directly on the same card but apparently thats not the case. Any ideas to what i could be missing? or hints to where i should look? Thanks

Also I have all my computers set with static IPs. No DHCP server is setup on the router, if that helps any.

Last edited by cheezey; 08-24-2003 at 07:34 PM.
 
Old 08-24-2003, 09:07 PM   #2
Whitehat
Senior Member
 
Registered: Feb 2003
Location: The Cold North
Distribution: SuSE 9.1
Posts: 1,289

Rep: Reputation: 45
First of all, Welcome

Do all of your other computers have the router listed as the default gateway?

Did they all connect just fine with ComCast Cable?

Do you still have the router connected to ComCast Cable along with DSL at the same time?

Need some more info bud!

Peace
 
Old 08-28-2003, 04:02 PM   #3
cheezey
LQ Newbie
 
Registered: Aug 2003
Location: Fremont,CA
Distribution: Red Hat 9.0/8.0
Posts: 3

Original Poster
Rep: Reputation: 0
thanks for the welcome...

yes. all computers have it set as default gateway.

They all connected fine with comcast.

I switched the cable from the Cable modem to the Dsl modem. So they are not connected simultaneously. When i run rp-pppoe (adsl-start) it says its connected. The router gets online fine. Just the rest do not. I ended up getting coyote linux router...and everything seems to work fine. But when i check the configs, everythings the same. Theres no difference in the IP settings, its just Coyote works, Red Hat doesnt. Still confused. I'm happy with Coyote right now because its serving its purpose, but I would still like to know how to get Red Hat working for future knowledge. I'm also a little stuck on setting up a DHCP server on RH, maybe for another forum or something. But anybody with a quickrundown would help.


Quote:
Originally posted by Whitehat
First of all, Welcome

Do all of your other computers have the router listed as the default gateway?

Did they all connect just fine with ComCast Cable?

Do you still have the router connected to ComCast Cable along with DSL at the same time?

Need some more info bud!

Peace
 
Old 10-23-2003, 07:17 AM   #4
chris
Member
 
Registered: Nov 2001
Location: Toronto, Canada
Distribution: CentOS 4
Posts: 66

Rep: Reputation: 15
RE:DSL Routing issues

Hi,

Just wondering if you got your DSL routing issue resolved? I can tell you that I had it configured about 3 years ago fine but I then switched to cable and then routing was even easier to configure. I now have to get routing done for a friend on DSL again and I can't seem to get it working either. if you didn't get your problem resolved by now which I doubt, you definitely have to change your firewall script to reflect ppp0 as your external interface as appose to eth0. I am assuming that you are using IPchains or IPtables with portforwading and IPmasquerading right? Anyhow.. just something else to look at but if it's all up and running now I wouldn't mind a little guidance perhaps.

Thanks!

Chris
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Networking Linux to windows behind dsl router pfunk Linux - Networking 5 09-22-2004 04:48 PM
Linux Router /w 2 DSL Connections adamantium Linux - Networking 1 01-14-2004 01:20 PM
Linux as DSL router which is better workstation or server? marvc Linux - General 6 03-03-2003 02:48 PM
DSL/ Linksys DSL Router/ Linux cant see the network... Robert0380 Linux - Networking 9 04-03-2002 04:09 AM
dsl modem and linux router diveguy Linux - Networking 3 03-27-2002 11:15 PM


All times are GMT -5. The time now is 09:13 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration