LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   DSL/ Linksys DSL Router/ Linux cant see the network... (http://www.linuxquestions.org/questions/linux-networking-3/dsl-linksys-dsl-router-linux-cant-see-the-network-17573/)

Robert0380 04-02-2002 02:13 PM

DSL/ Linksys DSL Router/ Linux cant see the network...
 
THE SCENARIO

I have a DSL line going into a Linksys 4-port DSL Router. Connected to it are 4 computers. A Win 98 box (mom's), a Win 2K box (dad's), and win 2k server box (just sits there doing nothing), and my computer (runnin Win2K, XP, 98 and RedHat 7.2). The DSL line doesnt use my phone lines (straight ethernet line into the house due to fiber optic phone lines). The router holds all the info about the ISP including DNS info, mail server info and it also logs into the ISP on demand (dynamic IP, using bellsouth fast access....they drop the connection when inactive ). Basically the router is a gateway.

THE PROBLEM

When running Linux i cant get online. If I ping...let's say.. yahoo.com , it times our or says unknown host or whatever it says that lets me know im not connected to the outside world. How to i configure Linux to see the internet.

Thanks for any replies.

trickykid 04-02-2002 02:20 PM

add your DNS servers to the /etc/resolv.conf file..
and make sure you can ping the router..

-trickykid

Robert0380 04-02-2002 04:03 PM

Didnt Work
 
Well I rebooted my computer, started Linux, edited my resolv.conf file to include the ISP provided nameservers, opened up Netscape..couldn't connect to yahoo.com (my favorite test site). i then opened up the console, pinged a few computers on my network including the router itself....all were pingable...pinged yahoo.com....nothing. Went to my dads computer, tried to ping the Linux box....nothing, tried to telnet to it.....nothing. Is there a way to tell Linux to Obtain IP address and DNS info automaticaly much like the way Windows does???? That would make everything work seeing as how the router willingly supplies that information to any computer connected to it.

Distro: RedHat 7.2

Another side question....how do you get into KDE from console mode...when i type startx it defaults to gnome. I like gnome and it has KDE menus, but i'd still like to use KDE seeing as how it is taking up space on the HDD.

ascii2k 04-02-2002 04:05 PM

one other suggestion...
 
make sure your gateway is set to the internal address on the router. You can see this by doing a netstat -r or route command. Your "default" destination should be the internal address of your router. i.e. 192.168.1.1. I would also follow the suggestions from the previous post.

ascii2k 04-02-2002 04:08 PM

strange..
 
Our replies were only 2 minutes apart...anyway...so...you could ping internal machines from the linux box, but not the other way? Can you post the output from "ifconfig" and "route". Those may be helpful to see. Just from what you have said if you can ping internal machines, but not external it sounds like a gateway problem to me.

trickykid 04-02-2002 04:34 PM

how are you setting up your network from the router.. static or dhcp ?? what output are you getting with the ifconfig command ??

-trickykid

finegan 04-02-2002 07:24 PM

Re: Didnt Work
 
Quote:

Originally posted by Robert0380
Is there a way to tell Linux to Obtain IP address and DNS info automaticaly much like the way Windows does????

Absolutely, as root:

dhcpcd eth0

If the Linksys router is set to run dhcp that should set the route to the gateway in your table, overwrite /etc/resolv.conf, and give you an IP.

Cheers,

Finegan

Robert0380 04-03-2002 12:32 AM

Thanks for the help....will try
 
I have just read all the posts, I will try out the different suggestions, just wanted to say thanks in advance.

Robert0380 04-03-2002 02:13 AM

dhcpcd worked!!!!!!!!!!
 
dhcpcd worked, thanks a million....im using Linux and Netscape to do this post. My 1st online activity with Linx since installing it months ago...now on to that Web Server...thanks guys.

DavidPhillips 04-03-2002 04:09 AM

put this line in /etc/rc.d/rc.local or run it somewhere to keep your connection up


you should probably use the ip of your isp default gateway if you know it, or use an external site that's always up


ping -i 30 xxx.xxx.xxx.xxx > /dev/null &


or

ping -i 30 yahoo.com > /dev/null &


All times are GMT -5. The time now is 01:18 PM.