LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-02-2002, 04:29 AM   #1
Chooco
Member
 
Registered: May 2002
Location: Mexico
Distribution: Slackware
Posts: 118

Rep: Reputation: 15
does my D-Link ethernet card support Linux?


D-Link DFE-530TX PCI Fast Ethernet Adapter

i've tried RedHat 7.1, 7.3, Mandrake 8.0, 8.2, Slackware 8.0 and NONE of them can consistantly use this ethernet card. the only one which could get the card to work was Mandrake 8.0 but once you reboot the computer it would no longer work.

does anybody here has this etherner card?

my friend has a Netgear ethernet card and it works on all of the distros i listed above.
 
Old 06-02-2002, 04:35 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,386

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
the card support for all those distro's should be indentical. You gotta appreciate that hardware support is not implented for a certain distribution, it is implented at a given kernel release. you card *should* work under a standard rtl8139 / 8139too driver (i know the 530+ does so...). however you prefer setting up your card try telling it that it's one of them. personally i'd just add the "alias eth0 8139too" line in /etc/modules.conf..)
 
Old 06-02-2002, 04:47 AM   #3
Chooco
Member
 
Registered: May 2002
Location: Mexico
Distribution: Slackware
Posts: 118

Original Poster
Rep: Reputation: 15
can you please say in detail how i manualy set it......like i have absolutely no clue what i'm doing because i have never really used Linux before except at my friend's house. i can do basic commands in the console in KDE (KDE is up incase i don't know the command for what i'm trying to do). i don't know how to configure Linux at all though so please help me
 
Old 06-02-2002, 06:13 AM   #4
Chooco
Member
 
Registered: May 2002
Location: Mexico
Distribution: Slackware
Posts: 118

Original Poster
Rep: Reputation: 15
*posting from Konqueror on Mandrake 8.0*

ok well i got it to work again by doing the install and restall with different settings every time........now how can i ensure that it will still have internet when this computer shuts off? i can leave it on for like a month at once but i can't leave it on forever
 
Old 06-02-2002, 06:17 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,386

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
well what are you doing to configure it in the first place? ok, i'd GUESS that you've got a permanent entry in /etc/sysconfig/network-scripts/ifcfg-eth0. also you need a load line like i mentioned above. do an lsmod to show the loaded modules and find out which one is the ethernet driver. and enter that line in modules.conf. after that you *should* be able to bring the interface up and down with ifup/ifdown eth0. should be all you need to do, but obiovusly you've not really given much information.
 
Old 06-02-2002, 09:16 AM   #6
MasterC
Guru
 
Registered: Mar 2002
Location: Salt Lake City, UT - USA
Distribution: Gentoo ; LFS ; Kubuntu
Posts: 12,612

Rep: Reputation: 64
Just to kind of clarify for ya what acid is saying...

Do an lsmod means to open a console and type 'lsmod'

Then when it shows which module is being used for eth0 write it down.

Take that information (the module) and go into your /etc directory and scroll down and open up modules.conf (this would be information for X... in terminal type: kwrite /etc/modules.conf) and then enter the information that you wrote down with 'alias' in front of it.

Example:

#

lsmod gives you 'rtlkrt8139 /dev/eth0'

So you would write down 'rtlkrt8139'

Open the modules.conf file

Below all other entries type: 'alias eth0 rtlkrt8139'

#

Of course all my ' marks are just to show what should be typed, do not type the ' mark.

I hope that clarifies rather than confuses

Last edited by MasterC; 06-02-2002 at 09:17 AM.
 
Old 06-03-2002, 06:55 PM   #7
Ryan_Sutton
Member
 
Registered: May 2002
Location: California
Distribution: Fedora 9
Posts: 101

Rep: Reputation: 15
I have a question on this subject. I recently reinstalled RH and Im trying to resetup my NIC's however the first NIC is up and running but when I lsmod I dont see the module in the list, however when i ifconfig eth0 it shows it 'up' and it has all the correct information set to it. So why isn't it listed in LSMOD??????
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ethernet card on laptop: I installed my D-Link ethernet card into Redhat 9, not detec brighamr Linux - Hardware 0 05-18-2004 12:33 AM
I need help for my D-Link Ethernet Card stonesino Linux - Newbie 2 03-14-2004 08:00 PM
D-Link DE220 ethernet card -Linux 6.0 Riru Linux - Networking 0 09-24-2003 05:43 AM
D-Link ethernet card Rutnut Linux - Networking 10 08-16-2001 04:05 PM


All times are GMT -5. The time now is 09:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration