LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-19-2001, 10:32 AM   #1
oalvarado31
LQ Newbie
 
Registered: Aug 2001
Location: Texas
Distribution: Red Hat 7.0
Posts: 4

Rep: Reputation: 0
Question DNS resolv


problems, I noticed that few threads with such queries are answered but here we go - I have setup a linux box rh7.0 and have setup the DNS portion with all aliases, ftp, www, etc.
I am running a webserver on the same box (Apache). I can access the html test page via ns1.myserver.net, yet when I try the www.myserver.net - I get "This page cannot by displayed"
I have set my Apache httpd.conf servername as www.myserver.net.

can anyone please enlighten this Mexicon.

thanks,



btw - new to linux - yet, looks very promising.
 
Old 08-19-2001, 03:14 PM   #2
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
Do you have an A record for www.myserver.net in your myserver.net zone file? Did you use the $ORIGIN shortcut or did you use the whole name www.myserver.net. ? Did you forget the trailing dot?

When you start or restart named what do you see in the log files? If you see somthing like www.mydomain.net.mydomain.net then you've missed the last 'dot' in your A record.

You can also try 'dig' (man dig for more options)
Code:
dig any www.mydomain.net
dig any mydomain.net
 
Old 08-19-2001, 03:38 PM   #3
oalvarado31
LQ Newbie
 
Registered: Aug 2001
Location: Texas
Distribution: Red Hat 7.0
Posts: 4

Original Poster
Rep: Reputation: 0
I do have an A record for www.myserver.net.

I was missing some dots in my zone files, earlier. (before the posting of my thread)

I did have the $ORIGIN at the top of the zone file along with a $TTL 86400 in the first line. (do I need to have these?)

I downloaded a trial version of a DNS analyzer software which returns a:

Authorative Answer:NO

when I run a check for the SOA Record, yikes!!!

and a "lame delegation" once I run a Zone Analyzer.

Help, I believe I am drowning in ignorance.......

Once again, confused Mexicon
 
Old 08-19-2001, 07:05 PM   #4
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
Is the A record correct? (does it point to the right IP addr?)

Are there any other name servers on your network?

The zone file (for each one listed /etc/named.conf) should start out with something like
Code:
@ IN SOA ns1.mydomain.net. hostmaster.ns1.mydomain.net. <serial and ttl info...>
for the for the mydomain zone file. Note that the first line MUST start at the first position on the first line. $ORIGIN or @ will do the same thing.


have a look in the logs. To see the last 100 log entries you can use
Code:
tail -100 /var/log/messages
and look for anything suspect.
 
Old 08-19-2001, 10:18 PM   #5
oalvarado31
LQ Newbie
 
Registered: Aug 2001
Location: Texas
Distribution: Red Hat 7.0
Posts: 4

Original Poster
Rep: Reputation: 0
I have the ip addr correct;

the first line in the mydomain.net zone file is

@ IN SOA ns1.mydomain.net. hostmaster.ns1.mydomain.net. (

but, after running the code you asked me to for the last 100 lines of log everything looks okay, except for this line

No Default TTL set using SOA minimum instead

I know I am close but, just not there.

btw - thanks for you help.
 
Old 08-20-2001, 01:49 AM   #6
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
Quote:
No Default TTL set using SOA minimum instead
Aw that's no real problem. It's just telling you that the time-to-live values were not implicitly declared in your zone files. I forget what the defualt is, but if that's your only problem then your named appears to funtioning properly. You should still verify that your logs generate output something like this
Code:
 <date> <time> <hostname> named <pid>:starting.  named 8.2.3-T5B Wed Sep 20 18:10:28 GMT 2000
<date> <time> <hostname> named <pid>: master zone "mydomain.net" (IN) loaded (serial 2001060101)
<date> <time> <hostname> named <pid>:master zone "101.10.10.in-addr.arpa" (IN) loaded (serial 1)
So if I get this straight, your named.conf is config'd proper, your zone files all contain the proper name to IP mappings. Are your reverse lookups (IP -> name lookups)

Now for the clients. How do they know where the name server is? DHCP? Manual setup? Are they using the name server you have just setup or a different name server?

After cheking that, you need to go through your /etc/httpd/httpd.conf file and see that all is happy there.

Last edited by mcleodnine; 08-20-2001 at 02:07 AM.
 
Old 08-20-2001, 10:08 AM   #7
oalvarado31
LQ Newbie
 
Registered: Aug 2001
Location: Texas
Distribution: Red Hat 7.0
Posts: 4

Original Poster
Rep: Reputation: 0
The log file returned the information that you described, except for the on comment, which I mentioned before.

I believe my named.conf file is correct. I have zones for

zone "."
zone "localhost"
zone "mydomain.net"
zone "0.0.127" reverse localhost
zone "10.168.192" reverse mydomain.net

I will check my httpd.conf file - the correct setting for my server is
www.cielp.net, right?

thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora DNS resolv.conf issue waelaltaqi Linux - Networking 16 07-05-2006 03:23 AM
resolv.conf dns issues billbob Linux - Software 3 09-30-2005 12:20 PM
dns server and /etc/resolv.conf freeosfreesoul Linux - Laptop and Netbook 2 09-02-2005 06:45 PM
dns n ot able to resolv jkmartha Linux - Software 1 07-28-2005 08:03 PM
DNS & resolv.conf robeb Linux - Networking 1 06-25-2002 09:15 PM


All times are GMT -5. The time now is 08:57 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration