LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-16-2005, 07:00 PM   #1
helfire
LQ Newbie
 
Registered: Jun 2005
Posts: 7

Rep: Reputation: 0
DNS doesnt work in any distro


Ok, i've tried knoppix, ubuntu, gentoo, mepis and none are able to do DNS lookups. I have a 700m dell laptop, the builtin wireless works sorda on most but doesnt lookup dns, built in doesnt work most of the time and doesnt find DNS, i got a PCMCIA card that is detected, but it wont do dns.

Funny thing is it wont do it on my work network either, except the PCMCIA card did for a while, but now i'm back home and nothing. I can ping my dns servers, i see them in /etc/resolv.conf, what else does it need? every other machine on my network has no trouble with DNS.

I can point it to my NAT router (192.168.1.1) and it resolves but very very slowly (minutes)

I'm so lost because it happens in all linux distros, got gentoo 1/2 installed but cant because i cant emerge anymore

only reason i got this 700m was for linux, help me not use windows...
 
Old 06-16-2005, 07:08 PM   #2
rkettle
Member
 
Registered: Jun 2005
Posts: 204

Rep: Reputation: 30
you have a router... so I assume you are running as a dhcp client?

Regards
Richard
 
Old 06-16-2005, 07:11 PM   #3
helfire
LQ Newbie
 
Registered: Jun 2005
Posts: 7

Original Poster
Rep: Reputation: 0
yes, and it gets all the right info too, dns, ip, gw, subnet... thats why it's so confusing to me.
 
Old 06-16-2005, 07:11 PM   #4
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33
first thing i would do is confirm that your firewall allows outbound udp packets on port 53. if that's open, then i would run tcpdump in a terminal while you try connecting to a webpage or whatever, and see what's happening to the packets.
 
Old 06-16-2005, 07:14 PM   #5
rkettle
Member
 
Registered: Jun 2005
Posts: 204

Rep: Reputation: 30
what does ifconfig say and what does your router say?

run

#tail -f /var/log/messages

and see what is happening

Regards
Richard
 
Old 06-16-2005, 07:28 PM   #6
helfire
LQ Newbie
 
Registered: Jun 2005
Posts: 7

Original Poster
Rep: Reputation: 0
Its asking all my name servers for the IP

IP 192.168.1.50.domain > 66.133.170.2.domain: 25252+ A? slashdot.org.frontiernet.net. (46)

now i dont see why it's adding my isp's domain to the end.

it was my search domain but I took it out of my resolv.conf and it didnt change. I guess both my wirless and wired are working poperly, i can ping inside and out via IP (i'm in knoppix 3.9 right now)

edit:
i'll ssh in so i can copy/paste
my /var/logmessages hasnt shown anything yet

ifconfig:
knoppix@3[~]$ ifconfig
eth1 Link encap:Ethernet HWaddr 00:12:F0:7F:6D:2A
inet addr:192.168.1.50 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::212:f0ff:fe7f:6d2a/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:542 errors:0 dropped:0 overruns:0 frame:0
TX packets:556 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:64743 (63.2 KiB) TX bytes:50548 (49.3 KiB)
Interrupt:10 Base address:0xc000 Memory:e0206000-e0206fff



Last edited by helfire; 06-16-2005 at 07:34 PM.
 
Old 06-16-2005, 07:36 PM   #7
helfire
LQ Newbie
 
Registered: Jun 2005
Posts: 7

Original Poster
Rep: Reputation: 0
ummmm ok now for not apparent reason it's resolving domains... no idea why.

going to put knoppix on my hd and reboot, see what happens.
 
Old 06-16-2005, 07:37 PM   #8
mcd
Member
 
Registered: Aug 2003
Location: Boulder, CO
Distribution: Slackware, RHEL, CentOS
Posts: 825

Rep: Reputation: 33
grats! at least it's working, hehe.
 
Old 06-16-2005, 07:37 PM   #9
rkettle
Member
 
Registered: Jun 2005
Posts: 204

Rep: Reputation: 30
if you are using dhcp from your firewall then it should be no prob.

seems to me that your dns is all messed up.

traceroute to a site and grab the dns on the way and use route to add it.

Give yourself a static internal address with a gateway and dns.

Regards
Richard
 
Old 06-16-2005, 07:47 PM   #10
helfire
LQ Newbie
 
Registered: Jun 2005
Posts: 7

Original Poster
Rep: Reputation: 0
mcd: ya, for how long

rkettle:" traceroute to a site and grab the dns on the way and use route to add it."

little confused on what you mean.

here's a traceroute to www.yahoo.com (took a long time...)
knoppix@3[~]$ traceroute www.yahoo.com
traceroute to www.yahoo.com (68.142.226.53), 30 hops max, 38 byte packets
1 192.168.1.1 (192.168.1.1) 116.469 ms 116.011 ms 2.880 ms
2 70.97.0.1 (70.97.0.1) 119.160 ms 49.167 ms 47.364 ms
3 209.210.223.253 (209.210.223.253) 38.284 ms 43.776 ms 59.768 ms
4 ds-1-1-3--9--1--0.gw01.chcg.eli.net (209.210.88.33) 67.628 ms 57.860 ms 101.021 ms
5 ge-3-1-0--0.cr01.chcg.eli.net (207.173.114.97) 47.480 ms ge-3-1-0--0.cr02.chcg.eli.net (207.173.114.237) 50.296 ms 60.193 ms
6 ge-1-0-0--0.er01.chcg.eli.net (207.173.115.138) 62.734 ms ge-2-0-0--0.er01.chcg.eli.net (207.173.115.142) 117.356 ms ge-1-0-0--0.er01.chcg.eli.net (207.173.115.138) 49.775 ms
7 interconnect-eng.chicago1.level3.net (209.0.225.61) 62.818 ms 56.696 ms 49.448 ms
8 * so-2-1-0.bbr2.chicago1.level3.net (209.244.8.13) 195.588 ms 116.228 ms
9 4.68.128.201 (4.68.128.201) 119.421 ms as-2-0.bbr2.washington1.level3.net (209.247.10.130) 118.797 ms 4.68.128.201 (4.68.128.201) 118.787 ms
10 ge-3-0-0-51.gar1.washington1.level3.net (4.68.121.2) 132.520 ms ge-4-0-0-54.gar1.washington1.level3.net (4.68.121.98) 124.570 ms ge-4-0-0-56.gar1.washington1.level3.net (4.68.121.162) 230.385 ms
11 63.210.29.230 (63.210.29.230) 112.110 ms 127.267 ms 124.596 ms
12 t-3-1.bas2.re2.yahoo.com (206.190.33.95) 118.638 ms t-3-1.bas1.re2.yahoo.com (206.190.33.91) 125.342 ms t-3-1.bas2.re2.yahoo.com (206.190.33.95) 89.889 ms
13 p22.www.re2.yahoo.com (68.142.226.53) 68.998 ms 94.108 ms 122.086 ms
 
Old 06-16-2005, 07:52 PM   #11
rkettle
Member
 
Registered: Jun 2005
Posts: 204

Rep: Reputation: 30
this is your dns server

209.210.223.253
 
Old 06-16-2005, 08:16 PM   #12
helfire
LQ Newbie
 
Registered: Jun 2005
Posts: 7

Original Poster
Rep: Reputation: 0
20:12:06.712350 IP 192.168.1.50.32834 > 192.168.1.1.domain: 2488+ A? www.linuxquestions.org. (40)
20:12:07.713113 IP 192.168.1.50.32835 > 209.210.223.253.domain: 2488+ A? www.linuxquestions.org. (40)
20:12:08.714945 IP 192.168.1.50.32836 > resolve01.roc.ny.frontiernet.net.domain: 2488+ A? www.linuxquestions.org. (40)
20:12:09.716576 IP 192.168.1.50.32837 > resolve01.mdl.ny.frontiernet.net.domain: 2488+ A? www.linuxquestions.org. (40)
20:12:14.717778 IP 192.168.1.50.32834 > 192.168.1.1.domain: 2488+ A? www.linuxquestions.org. (40)
20:12:15.719625 IP 192.168.1.50.32835 > 209.210.223.253.domain: 2488+ A? www.linuxquestions.org. (40)
20:12:16.721652 IP 192.168.1.50.32836 > resolve01.roc.ny.frontiernet.net.domain: 2488+ A? www.linuxquestions.org. (40)
20:12:17.723518 IP 192.168.1.50.32837 > resolve01.mdl.ny.frontiernet.net.domain: 2488+ A? www.linuxquestions.org. (40)

tcpdump when i do host www.linuxquestions.org, doesnt give me back the ip.
 
Old 06-16-2005, 08:53 PM   #13
helfire
LQ Newbie
 
Registered: Jun 2005
Posts: 7

Original Poster
Rep: Reputation: 0
ok, i swaped out routers (i have 2 extra (me and my bro are home from college)) and it works fine... stupid router i'm gonna go smash it!

Thanx for your help, now if i could install gnoppix from the cd hehe
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS, Linux doesnt resolve domain names for me ikk Linux - Networking 6 08-28-2005 03:35 PM
DNS, Linux doesnt resolve domain names for me ikk Linux - Newbie 6 08-28-2005 03:29 PM
Why doesnt my USB mouse doesnt work? barkha Linux - Hardware 2 08-16-2005 11:31 AM
The DNS-resolver doesn't work in my live-distro maxxflow Linux - Networking 9 05-23-2005 01:35 AM
Knoppix Doesnt Boot? Distro help Johnsernickle Linux - Laptop and Netbook 2 02-06-2005 05:24 PM


All times are GMT -5. The time now is 02:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration