LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-30-2004, 11:52 AM   #1
AltecLansingMan
LQ Newbie
 
Registered: Mar 2004
Posts: 1

Rep: Reputation: 0
Angry Disabling ARP probes after receiving an ARP request


Hi:
I'm trying to get an old display device to boot from a Linux server.
At the start of the boot process, the device sends an ARP request to get the Linux server's MAC address. The Linux server replies and also stores the IP and MAC address of the requesting device into its ARP table.
I had to change the value of delay_first_probe_time in /proc/sys/net/ipv4/neigh/*/* to a value much greater than 5 for the following reason:
After 5 seconds (value stored in delay_first_probe_time) of having received the initial ARP request, the Linux server wants to verify that the ARP entry it has in its ARP table is still valid, so it sends out an ARP request to the device. The problem I was having is that this device is too old, so it wasn't responding at all to the ARP requests from the Linux box. So, after a while, the boot process would fail because the Linux server would decide the ARP entry was no longer valid, so would stop sending data.
If I change the value of delay_first_probe_time to something like 500, it boots without a problem.
However, during execution of my process, there will still be communication between the old device and my Linux server, and I'm afraid that after 500 seconds the Linux box will send an ARP request again, and then the device won't answer and my program execution will fail.
My question:
Is there a way of disabling the ARP probe, so that if the Linux box receives an ARP request, it stores the IP and MAC address of the requesting device into its ARP table and *doesn't * do a probe after delay_first_probe_time seconds?
I tried setting delay_first_probe_time to 0 and to -1, but that doesn't seem to work.
Any help would be greatly appreciated!
Thanks,
 
Old 03-30-2004, 01:25 PM   #2
ugge
Senior Member
 
Registered: Dec 2000
Location: Gothenburg, SWEDEN
Distribution: OpenSUSE 10.3
Posts: 1,028

Rep: Reputation: 45
The only thing I can come up with is to set the arp cache manually, which will make it permanent.
I read the man page for arp but couldn't find anything to stop this behaviour.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange ARP behavior : A linux server responds to all ARP requests Hdvd21 Linux - Networking 4 10-24-2013 05:02 AM
sending an arp request jagman Programming 2 02-27-2006 02:59 PM
ARP request davidho3 Linux - Networking 1 11-06-2004 09:48 AM
ARP request davidho3 Linux - Networking 2 11-05-2004 10:01 AM
How to create an proxyarp entry in arp table by using arp command? himalayas Linux - Networking 0 06-04-2003 04:14 AM


All times are GMT -5. The time now is 02:29 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration