LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-11-2006, 09:25 PM   #1
deepaklukose
LQ Newbie
 
Registered: Sep 2005
Posts: 15

Rep: Reputation: 0
Disable startkde and gnome-session over ssh


Hai
I would like to know how to disable gnome-session,startkde,twm (window managers) etc over ssh.Only few selected users/group must be able to use these commands.Other users must be allowed to use tools like kate,kwrite etc.
I am using Redhat Enterprise 4 Linux.

Deepak Lukose
 
Old 01-12-2006, 09:04 PM   #2
samel_tvom
Member
 
Registered: Aug 2004
Posts: 133

Rep: Reputation: 15
Hope this is the "right" way to do it, but why not do

chown root:specialgroup /path/to/program
on all those programs (gnome-sessions etc.) and do appropriate chmod on those programs so that users in the specialgroup group has permission to run the programs and "others" (in the chmod command) don't have the right to run the programs.

Those users who should be able to run the programs should then be a part of the specialgroup group.

Hope it helped
 
Old 01-16-2006, 08:32 PM   #3
deepaklukose
LQ Newbie
 
Registered: Sep 2005
Posts: 15

Original Poster
Rep: Reputation: 0
I was expecting a more robust method like one using PAM.I believe,the solution by changing file permission can be overriden by getting a copy of startkde/gnome-session etc from another machine with same OS.
 
Old 01-17-2006, 05:51 PM   #4
samel_tvom
Member
 
Registered: Aug 2004
Posts: 133

Rep: Reputation: 15
Well, maybe try to do it with other programs then, like X or xinit.
 
Old 01-17-2006, 08:43 PM   #5
deepaklukose
LQ Newbie
 
Registered: Sep 2005
Posts: 15

Original Poster
Rep: Reputation: 0
xinit and X servers are stopped using PAM,but people are bypassing this by using startkde etc in an ssh session.Ssh is needed for them to login and for programming.so there is no question of disabling ssh.the only option that remains is disabling these commands using PAM.BTW thank you,for ur fast replies.
 
Old 01-18-2006, 05:07 PM   #6
samel_tvom
Member
 
Registered: Aug 2004
Posts: 133

Rep: Reputation: 15
No worries, hope it works out for you =)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome panel keeps crashing when starting gnome-session elluva Linux - Software 3 01-24-2006 04:26 PM
Changing environment variable for gnome session from gnome-terminal pymehta Linux - Software 1 10-11-2005 05:19 PM
xwindows in ssh session ravneetsoin Linux - Software 2 08-12-2004 04:59 PM
How to disable auto session restore in KDE? mwettach Linux - Software 2 07-28-2004 03:00 PM
How do you disable gnome themes on other apps?/Emacs distorted over ssh ShyGuy91284 Linux - General 0 03-31-2004 05:09 PM


All times are GMT -5. The time now is 10:32 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration