LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
LinkBack Search this Thread
Old 11-28-2013, 08:36 AM   #1
Lieta
LQ Newbie
 
Registered: Nov 2013
Posts: 2

Rep: Reputation: Disabled
Disable ARP response on one of IPs


Hi.
I have assigned 2 IP addresses to one network interface. For example:
192.168.1.100 and
10.2.2.1
Is it possible to disable ARP response on a particular IP address? I.e. respond only to request of 192.168.1.100, but not respond on 10.2.2.1.
 
Old 11-28-2013, 09:39 AM   #2
tva
Member
 
Registered: Jul 2010
Location: Finland
Distribution: Open SUSE 11.x
Posts: 70

Rep: Reputation: 6
I have no experience on this but with google I found this, I hope it helps.
 
1 members found this post helpful.
Old 11-29-2013, 12:19 AM   #3
psycroptic
Member
 
Registered: Aug 2011
Location: USA
Distribution: ArchLinux - 3.0 kernel
Posts: 230

Rep: Reputation: Disabled
well, i know if you disable ARP, then each system on the network needs to have every other system's MAC address and corresponding IP entered into its ARP tables manually. If you are prepared to do this (which, if you have a small network, is quite doable), you can run

Code:
arp -s xx:xx:xx:xx:xx:xx 1.2.3.4
where xx:xx:xx:xx:xx:xx is the remote machines MAC and 1.2.3.4 is its IP address. Remember that the system on the other end will need the same kind of config but pointing back to your 10.2.2.1, and if it's ssome sort of embedded device it may not give you access to such a low level kind of interface, in which this won't be possible.

You could also use the "ip" utility to disable ARP on the interface (ifconfig would show NOARP for it), but the same kind of ARP commands would still need to be run.
 
Old 11-29-2013, 06:06 AM   #4
Lieta
LQ Newbie
 
Registered: Nov 2013
Posts: 2

Original Poster
Rep: Reputation: Disabled
Thanks tva, it works. I had to enable Netfilter Xtables support in kernel and add a rule to drop all ARP requests, except the one destined to primary IP if an interface:
Code:
arptables -A INPUT ! -d 192.168.1.100 -j DROP
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
same MAC address for different IP addresses in ARP response VinodVandkar Linux - Networking 5 01-25-2013 04:32 PM
how can I disable arp on sles10 ab588588 Linux - Server 0 06-20-2007 06:44 AM
response req ASAP- how to disable broadcast of beacons from access point? swapna_gg83 Linux - Wireless Networking 0 05-03-2006 12:50 PM
Disable dynamic arp silvereye Linux - Networking 3 08-28-2004 09:19 AM
IP aliases (Virtual IPs) and arp not playing well together rmanoc Linux - Networking 5 08-20-2004 09:32 AM


All times are GMT -5. The time now is 01:55 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration