LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   dig output shows NOERROR but no IP and privoxy claims NXDOMAIN ( privoxy OFF) (http://www.linuxquestions.org/questions/linux-networking-3/dig-output-shows-noerror-but-no-ip-and-privoxy-claims-nxdomain-privoxy-off-877511/)

linuxStudent11 04-27-2011 10:45 PM

dig output shows NOERROR but no IP and privoxy claims NXDOMAIN ( privoxy OFF)
 
Why no answer section???

dig @127.0.0.1 www.crh.noaa.gov

; <<>> DiG 9.7.1-P2 <<>> @127.0.0.1 www.crh.noaa.gov
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 7475
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;www.crh.noaa.gov. IN A

;; Query time: 152 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Apr 27 22:54:42 2011
;; MSG SIZE rcvd: 34

Wierdest thing. This only seems to happen with NOAA weather websites.
pdnsd chains thru to DNSMASQ running on a cheap wifi box under DD-WRT (nvram only, v24-sp2). The DNS there is Google DNS 8.8.8.8 and 8.8.4.4

And, further wierdness, if I take pdnsd out of the proxy chain, dnsmasq finds it fine:
dig www.crh.noaa.gov

; <<>> DiG 9.7.1-P2 <<>> www.crh.noaa.gov
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 19841
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;www.crh.noaa.gov. IN A

;; ANSWER SECTION:
www.crh.noaa.gov. 43835 IN A 204.227.127.200

;; Query time: 0 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Wed Apr 27 23:01:16 2011
;; MSG SIZE rcvd: 50

192.168.1.1 is the DD-WRT box.

HOWCUM I get NOERROR but no answer with pdnsd???
Every (all of em) other web address I've tried is just fine?!!????
e.g. dig adds.aviationweather.gov works great...but not any NOAA. What could be special about noaa.gov's?
Something not recursing???



Here's my pdnsd.conf:
global {
perm_cache=1024;
cache_dir="/var/cache/pdnsd";
run_as="pdnsd";
server_ip = 127.0.0.1; // Use eth0 here if you want to allow other
// machines on your network to query pdnsd.
status_ctl = on;
paranoid=on;
// query_method=tcp_udp; // pdnsd must be compiled with tcp
// query support for this to work.
min_ttl=15m; // Retain cached entries at least 15 minutes.
max_ttl=1w; // One week.
timeout=10; // Global timeout option (10 seconds).

// Don't enable if you don't recurse yourself, can lead to problems
// delegation_only="com","net";
}
server {
label="resolvconf";
}
source {
owner=localhost;
// serve_aliases=on;
file="/etc/hosts";
}

rr {
name=localhost;
reverse=on;
a=127.0.0.1;
owner=localhost;
soa=localhost,root.localhost,42,86400,900,86400,86400;
}
confession: I mistakenly chose root install and hand editted back to a manual local install.


All times are GMT -5. The time now is 07:22 AM.