LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-20-2005, 01:09 PM   #1
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Rep: Reputation: 30
Dialing to wvdial and message 'no carrier'


After a complete fresh install with Fedora Core 3, I have edited the wvdial.conf as follows
Code:
[Modem0]
Modem=/dev/ttyS1
Baud=115200
SetVolume=0
Dial Command-ATDT
init1=ATZ
init2=AT+CRM=1
Flow Control=Hardware (CRTSCTS)
[Dialer reliance]
Username=username
Password=password
Phone=#777
Stupid Mode=1
Inherits=Modem0
but if I dial
Code:
wvdial reliance
then I am getting a message that 'no carrier detected'. I am able to connect from windows. I used this setting in Fedora Core 3 before also.
What is the problem?
Regards
 
Old 03-20-2005, 03:44 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,476

Rep: Reputation: 156Reputation: 156
"init1=ATZ
init2=AT+CRM=1
then I am getting a message that 'no carrier detected'."

Probably your Init2 command is incorrect. Try:
Init2 = ATM0L0

----------------------------
Steve Stites
 
Old 03-20-2005, 11:18 PM   #3
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Original Poster
Rep: Reputation: 30
Thank you Guru for your reply. My init2 command as I typed 'AT+CRM=1' was running in FC3 before this install. It is running from Windows also. However, I am trying according to your suggestion and telling you the result.
Regards
anindyanuri
 
Old 03-20-2005, 11:41 PM   #4
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Original Poster
Rep: Reputation: 30
Nope, not worked.
I have tried with ATM0L0 (treating as zero) and even with ATMOLO (treating as M=>N=>'O') but in both the case it did not worked and I received the same response that carrier not detected.
From Win I have found that in the Advanced Connections Settings window => Extra Settings text box, there is the entry as follows,
AT+CRM=1; $LGPKT=3

Waiting for your suggestion.
Regards
anindyanuri
 
Old 03-21-2005, 02:48 AM   #5
2damncommon
Senior Member
 
Registered: Feb 2003
Location: Calif, USA
Distribution: Debian Wheezy
Posts: 2,838

Rep: Reputation: 48
FWIW...
AT&F1 used to work for me with a USR modem.
 
Old 03-21-2005, 03:50 AM   #6
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Original Poster
Rep: Reputation: 30
Strange !!!
Just now I am connected from FC3 with the contents in the /etc/wvdial.conf exactly same as I have mentioned in the first message.

But I know (I experienced in case of last install of FC3) if I terminate this connection and reboot the system, I cannot connect anymore from FC3.
Please help me how to be stay stable with this parameters and connection.
Regards
anindyanuri
 
Old 03-27-2005, 10:15 PM   #7
mesocool
LQ Newbie
 
Registered: Mar 2005
Location: Seattle
Distribution: Ubnutu
Posts: 9

Rep: Reputation: 0
can you tell me how to modify this file "wvdial.conf". When I tried to open it, it is forbidden..
 
Old 03-28-2005, 06:59 AM   #8
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by mesocool
can you tell me how to modify this file "wvdial.conf". When I tried to open it, it is forbidden..
You can modify this file by any ascii text editor like vi, kedit, gedit or anything you like. The file 'wvdial.conf' file resides in the '/etc' directory. So, for an example, if you take vi editor to edit the file you can type :
Code:
vi /etc/wvdial.conf
Regards
anindyanuri
 
Old 03-28-2005, 07:34 AM   #9
prasanta
Member
 
Registered: Mar 2005
Location: India
Distribution: Debian
Posts: 368

Rep: Reputation: 37
Try adding another init line in the wvdial.conf
Init3=ATX3
Carrier Check=no

which says not to wait for carrier detection.
It works fine with my MTNL connection.

-Prasanta
 
Old 03-28-2005, 12:48 PM   #10
mesocool
LQ Newbie
 
Registered: Mar 2005
Location: Seattle
Distribution: Ubnutu
Posts: 9

Rep: Reputation: 0
Thank you guys so much.. It rocks.. But another problem is coming up after the modem works. The sound is not working.. I think I read an ariticle online saying that the sound driver might be conflicting the modem driver. Now it does.. Any cure?
 
Old 03-28-2005, 07:19 PM   #11
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by mesocool
Thank you guys so much.. It rocks.. But another problem is coming up after the modem works. The sound is not working.. I think I read an ariticle online saying that the sound driver might be conflicting the modem driver. Now it does.. Any cure?
Good Mesocool,
Nice to know that your problem is over. For sound you should check your sound card detection. Start -->System Settings--> Soundcard Detection
Regards
anindyanuri
 
Old 03-28-2005, 07:30 PM   #12
mesocool
LQ Newbie
 
Registered: Mar 2005
Location: Seattle
Distribution: Ubnutu
Posts: 9

Rep: Reputation: 0
Quote:
Originally posted by anindyanuri
Good Mesocool,
Nice to know that your problem is over. For sound you should check your sound card detection. Start -->System Settings--> Soundcard Detection
Regards
anindyanuri
Maybe we use different version of Linux, I don't have Start...... menu in mine and I cannot find the soundcard detection in it.. I am using Ubuntu...
 
Old 03-29-2005, 01:39 AM   #13
prasanta
Member
 
Registered: Mar 2005
Location: India
Distribution: Debian
Posts: 368

Rep: Reputation: 37
Why don't you use
#soundcardconfig

-Prasanta
 
Old 03-29-2005, 10:03 AM   #14
anindyanuri
Member
 
Registered: Jan 2005
Location: India
Distribution: Kubuntu Gutsy
Posts: 449

Original Poster
Rep: Reputation: 30
Quote:
Originally posted by mesocool
Maybe we use different version of Linux, I don't have Start...... menu in mine and I cannot find the soundcard detection in it.. I am using Ubuntu...
Very sorry mesocool, I should have careful enough before posting my previous post. I should have thought that you might use any other distro. However, according to my post, you will find it similar to Red Hat and Fedora Core in GNOME and again sorry that I do not have any idea about Ubuntu, though I am interested to use it in future if I get it.

Regards
anindyanuri

A request : you please edit the particulars of you (what distro u use, your location, etc etc.).
 
Old 03-29-2005, 10:37 AM   #15
mesocool
LQ Newbie
 
Registered: Mar 2005
Location: Seattle
Distribution: Ubnutu
Posts: 9

Rep: Reputation: 0
Quote:
Originally posted by prasanta
Why don't you use
#soundcardconfig

-Prasanta
There is no such a file..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wvdial connects then disconnects - message log has no errors shlape Linux - Networking 1 04-16-2005 05:28 PM
No Carrier message PortOS Linux - Networking 3 03-27-2005 08:03 PM
No Carrier return when dialing up Aradorn Linux - Newbie 3 03-30-2004 04:37 PM
wvdial error..Carrier not detected sofh Linux - Networking 0 10-04-2003 01:49 PM
dialing out with wvdial nbc Linux - Newbie 3 08-15-2001 06:24 PM


All times are GMT -5. The time now is 01:23 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration