Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 06-13-2006, 12:45 AM   #1
LQ Newbie
Registered: Jun 2006
Posts: 3

Rep: Reputation: 0

Now DHCPDISCOVER try to reconnect only 5 times:

dhclient: DHCPDISCOVER on eth0 to port 67 interval 7
dhclient: DHCPDISCOVER on eth0 to port 67 interval 8
dhclient: DHCPDISCOVER on eth0 to port 67 interval 20
dhclient: DHCPDISCOVER on eth0 to port 67 interval 11
dhclient: DHCPDISCOVER on eth0 to port 67 interval 11

..and then:

dhclient: No DHCPOFFERS received.
dhclient: No working leases in persistent database.
dhclient: Exiting.

So how can I increase DHCPDISCOVER times to 9999 for example?
Old 06-13-2006, 01:23 AM   #2
Senior Member
Registered: Jan 2005
Location: Canada
Distribution: ubuntu
Posts: 2,539

Rep: Reputation: 59
check the /etc/dhclient.conf file, is there a setting in this file for it?
Old 06-13-2006, 05:21 AM   #3
LQ Newbie
Registered: Jun 2006
Posts: 3

Original Poster
Rep: Reputation: 0
i can`t find this option in dhclient.conf:

#send host-name "";
#send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;
#send dhcp-lease-time 3600;
#supersede domain-name "";
#prepend domain-name-servers;
#request subnet-mask, broadcast-address, time-offset, routers,
# domain-name, domain-name-servers, host-name;
#require subnet-mask, domain-name-servers;
#timeout 60;
#retry 60;
#reboot 10;
#select-timeout 5;
#initial-interval 2;
#script "/etc/dhclient-script";
#media "-link0 -link1 -link2", "link0 link1";

#alias {
# interface "eth0";
# fixed-address;
# option subnet-mask;

#lease {
# interface "eth0";
# fixed-address;
# medium "link0 link1";
# option host-name "";
# option subnet-mask;
# option broadcast-address;
# option routers;
# option domain-name-servers;
# renew 2 2000/1/12 00:00:01;
# rebind 2 2000/1/12 00:00:01;
# expire 2 2000/1/12 00:00:01;
Old 06-13-2006, 01:29 PM   #4
Registered: May 2004
Distribution: redhat, trustix, debian
Posts: 103

Rep: Reputation: 15
Are you getting any DHCP offers ?
Old 06-13-2006, 02:08 PM   #5
Red Hat India
Registered: Nov 2004
Location: Kerala/Pune,india
Distribution: RedHat, Fedora
Posts: 260

Rep: Reputation: 34
Hello go_joe,

From the messages, one can find out that no DHCPOFFER packets are sent from the DHCP server. The client is sending out DHCPDISCOVER packets, but the server is not responding fine. Have you configured the server correctly? Try configuring the server properly and check again.

To edit the timeout you can use the directive 'timeout' in '/etc/dhclient.conf' file. The default timeout is 60 seconds.
Hope you got the answer....

Contact in case of any need...


Last edited by vimal; 06-13-2006 at 02:17 PM.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Limiting DHCPDISCOVER on boot 1madstork Debian 7 03-01-2005 02:37 PM
Changing DHCPDISCOVER on bootup?? halo14 Debian 4 09-01-2004 05:00 PM

All times are GMT -5. The time now is 12:44 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration