LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 10-20-2007, 06:21 PM   #1
swiezy
LQ Newbie
 
Registered: Oct 2007
Posts: 6

Rep: Reputation: 0
DHCP not working


Hello there,
recently I installed Slackware 12 and since then I can't get my internet connection operational The details:
I am using Toshiba Tecra m2 with intel Pro/100 ethernet card.
Slackware is loading eepro100 driver for my ethernet card.
My Lan looks like that: DSL modem <-> router with cloned mac adress of my NIC <-> my laptop.
I haven't change anytihng in the kernel.
Though lspci shows that there is mentioned before ethernet card, ifconfig doesn't show it. I can get my eth0 interface up by:
Code:
ifconfig eth0 up
but it doesn't solve anything. There is still no net.
Please help!
 
Old 10-20-2007, 07:20 PM   #2
d2490n
Member
 
Registered: Jul 2005
Location: San Diego, CA
Distribution: RHEL, Debian, Gentoo when I'm brave.
Posts: 47

Rep: Reputation: 15
have you tried #dhcpcd eth0?


edit: eth0 not eth1

Last edited by d2490n; 10-20-2007 at 07:30 PM.
 
Old 10-21-2007, 06:54 AM   #3
swiezy
LQ Newbie
 
Registered: Oct 2007
Posts: 6

Original Poster
Rep: Reputation: 0
Yes I did, after I put
Code:
dhcpcd eth0
screen becomes still and after about 2 minutes prompt line is returned. But still no net.

I tried it with different combinations like
Code:
ifconfig eht0 up 192.168.2.1
or with IP that I should be using that is 192.168.2.100, but net is still unreachable.
Though when I've used
Code:
ifconfig eth0 up 192.168.2.100
I could log into my router through links and I was able to ping it.
ping:
Code:
PING 192.168.2.1 (192.168.2.1) 56(84) bytes of data.
64 bytes from 192.168.2.1: icmp_seq=1 ttl=64 time=0.022 ms
64 bytes from 192.168.2.1: icmp_seq=2 ttl=64 time=0.008 ms
64 bytes from 192.168.2.1: icmp_seq=3 ttl=64 time=0.005 ms
64 bytes from 192.168.2.1: icmp_seq=4 ttl=64 time=0.005 ms
64 bytes from 192.168.2.1: icmp_seq=5 ttl=64 time=0.006 ms
64 bytes from 192.168.2.1: icmp_seq=6 ttl=64 time=0.005 ms
64 bytes from 192.168.2.1: icmp_seq=7 ttl=64 time=0.006 ms
64 bytes from 192.168.2.1: icmp_seq=8 ttl=64 time=0.005 ms

--- 192.168.2.1 ping statistics ---
8 packets transmitted, 8 received, 0% packet loss, time 6996ms
rtt min/avg/max/mdev = 0.005/0.007/0.022/0.006 ms
I wasn't able to ping it though when I get eth0 up with 192.168.2.1 (my router).
I am confused mostly because I really don't know much about lan and networking...

One more thing, I have checked syslog and there is this:
Code:
Oct 21 12:36:49 aster dhcpcd[2626]: timed out waiting for a valid DHCP server response 
Oct 21 12:37:20 aster dhcpcd[2659]: timed out waiting for a valid DHCP server response
I have browsed google for it, but haven't found anything usefull.

Last edited by swiezy; 10-21-2007 at 07:00 AM. Reason: One more thing
 
Old 10-21-2007, 07:51 AM   #4
d2490n
Member
 
Registered: Jul 2005
Location: San Diego, CA
Distribution: RHEL, Debian, Gentoo when I'm brave.
Posts: 47

Rep: Reputation: 15
ok, im not very experienced in this area either but are you shore that dhcp is turned on in your router? have you tested it with another computer or os? sorry i cant be more helpful.
 
Old 10-21-2007, 08:21 AM   #5
swiezy
LQ Newbie
 
Registered: Oct 2007
Posts: 6

Original Poster
Rep: Reputation: 0
yeah, i dual boot on my lap, in win xp everthing is just fine. I thought that there was somekind of issue with the NIC driver but it is loaded properly. Even when i remove it
Code:
modprobe -r eepro100
and than load it again nothing is changing.
Thanks for your interest
 
Old 10-21-2007, 08:39 PM   #6
smuggly
LQ Newbie
 
Registered: Jul 2004
Location: Reno Nevada
Distribution: Ubuntu Ultimate 1.5
Posts: 24

Rep: Reputation: 15
Red face

I Know Its Obvious But Have U Dbl Checked The Nameserver Aspect,Make Sure All Your Names /domains Are In Order?I Had The Prob.
Tom
 
Old 10-22-2007, 09:47 AM   #7
swiezy
LQ Newbie
 
Registered: Oct 2007
Posts: 6

Original Poster
Rep: Reputation: 0
I think that when I use DHCP I don't have to put ip or domain name. But I'll check everything in windows and will give it a try in slack. I will also try to connect without router.
Wish me luck !

Last edited by swiezy; 10-22-2007 at 10:59 AM.
 
Old 10-22-2007, 02:59 PM   #8
teabag_46
Member
 
Registered: Aug 2007
Posts: 35

Rep: Reputation: 15
I have the same problem. Dual booting XP/Slack 12. Last week, my 'little darlings' managed to mess up my network. Finally managed to get the XP back online, but even after doing a complete re-install on my Slack, it won't connect.
 
Old 10-22-2007, 04:06 PM   #9
swiezy
LQ Newbie
 
Registered: Oct 2007
Posts: 6

Original Poster
Rep: Reputation: 0
I am glad that there is someone else with the same problem, that means that I am not crazy (yet).
I have tried to set STATIC IP by 'netconfig' but it didn't work. I also downgraded to Slack 11, but I have the same problems as with 12.
I am getting sad sad sad... Tommorow I might try another distro, just to check it out. Or maybe I will search for my slack 10.2 cd-roms... I would just like to have slack back.. is it to much...?
 
Old 10-22-2007, 06:57 PM   #10
larkl
Member
 
Registered: Sep 2007
Distribution: Puppy 5.2.8
Posts: 69

Rep: Reputation: 15
Can you clarify, the router has a static IP address and is it 192.168.2.1 or 192.168.2.100? Can you ping 127.0.0.1 on the PC (nternal loopback) and see if it responds? THen I would assign a static IP (the one that isn't assigned to the router) to the PC NIC and then ping that from the PC. THen try to ping the router from the PC. YOu don't have an embedded motherboard NIC and an add-on NIC (don't laugh - it trips me up everytime on my Dell with a failed motherboard NIC).
 
Old 10-23-2007, 04:38 AM   #11
swiezy
LQ Newbie
 
Registered: Oct 2007
Posts: 6

Original Poster
Rep: Reputation: 0
Case solved
Guys from forum.slackware.pl solved the case.
If you got similar problem then:
Set your IP to static ip with net config. In my option it looked like that:
My ip: 192.168.2.100
netmask: 255.255.255.0
Gateway ip: 192.168.2.1
And the thing i didn't set before... dns ip. You can put it in /etc/resolv.conf, i had to put my router (gateway) ip, it goes like this: nameserver 192.168.2.1
And everything works

Last edited by swiezy; 10-23-2007 at 04:40 AM.
 
  


Reply

Tags
dhcp, dhcpcd, slackware12


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DHCP not working :-( erpe Slackware 12 03-24-2006 07:51 PM
dhcp AGAIN... not working... ploptor1 Linux - Networking 1 03-09-2006 06:46 AM
DHCP just isn't working! GhostOfYoda Linux - Networking 1 08-01-2003 05:32 AM
DHCP is working but still nothing im_not_jose Linux - Networking 12 07-26-2003 07:51 AM
DHCP isn't working. 95se Linux - Networking 5 05-16-2002 06:40 PM


All times are GMT -5. The time now is 01:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration