LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   DHCP lease time anomaly (http://www.linuxquestions.org/questions/linux-networking-3/dhcp-lease-time-anomaly-813376/)

LQParsons 06-10-2010 11:29 AM

DHCP lease time anomaly
 
Hi.
SuSE 11.1 dhcpd -- server (eth0)
SuSE 11.2 dhclient -- client (eth0)
Setting up, testing, set default lease, maximum lease to 240 seconds when testing, change to default outside of test mode.

It seems to be working, but looking at
/var/lib/dhcp/db/dhcpd.leases #on the server
/var/lib/dhcp/dhcp.leases #on the client

the hour of the lease if off by four hours in the future, the minutes seem OK.
(Being East Coast, I always suspect hidden California time stuff, but that would be three hours in the PAST <.grin>)

$date
on server and client give the correct EDT time (I'm just north of Boston)

The server uses a NTP-server for its time-setting, the client has nothing (one of the experiments is to set that when I set the DHCP-address. But in any event, they both are the same time.

Do I have a problem ?
Which I fix by ... ?

Thanks.

Doug

dafydd2277 06-11-2010 03:42 PM

Are the timstamps in the leases files stampted for GMT/UTC?

jefro 06-11-2010 04:07 PM

Set hardware clock to realtime clock if dafydd2277's suggestion isn't the fix.??? I think he is right though.

LQParsons 06-17-2010 08:19 PM

UTC, date -u
 
The problem is/was there was no marks, EDT or GMT or UTC.
The hardware time and the system time were OK, and within seconds of each other on both machines.

It should have been obvious but I was having a brain-fart.
Thank you for the responses, which lead me to what I should have done
man dhcpd.leases
which explained in detail the line in the file, explained that dating format used and told me about
$ date -u
so as to verify my 'current time' and the one just entered in the lease table were indeed the same.

(I'm trying to evoke ddns, and then ddhcp, and I read that if the time difference was greater than 5 minutes the zone file would not update with that data. I'm not updating, so I suspected this my culprit -- it's obviously not, so I'll look elsewhere. I've probably got a setting or two in error that is my nemesis.)

Anyhow, thanks for your help.

(Am I suppose to click a check-box or radio-button to say thanks to all and/or case-closed ?)

Enjoy.
-doug


All times are GMT -5. The time now is 08:57 AM.