LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   DHCP failed on ubuntu-8.04 (http://www.linuxquestions.org/questions/linux-networking-3/dhcp-failed-on-ubuntu-8-04-a-651000/)

cheesewizz 06-23-2008 04:36 AM

DHCP failed on ubuntu-8.04
 
Hello there

installation of ubuntu on my desktop was fine.
my purpose of this is to UP the firestarter as my internet sharing with a basic firewall...

the requirements are:

Two Lan Card

eth0 - for ISP IP
eth1 - for internatl ip which is start tom192.168.1.1

1. firestarter - installed
2. DHCP3-Server - Installed
3. webmin for my web administration - installed


but when i try to restart the dhcp3 it gives me an error

Failed to start dhcpd:
Starting DHCP server dhcpd3----fail!


My config file:

ddns-update-style interim;
ignore client updates;

subnet 192.168.1.0 netmask 255.255.255.0 {
option routers 192.168.1.1;
option subnet-mask 255.255.255.0;
openton domain-name-servers localhost, localhost2;
option ip-forwarding off;
range dynamic-bootp 192.168.1.2 192.168.1.254;
default-lease-time 21600;
max-lease-time 43200;
}


please anyone can help me...

Swagata Paul 06-23-2008 05:10 AM

send me last 10 lines of /var/log/messages , just after restarting the DHCP service.

cheesewizz 06-23-2008 09:08 PM

Quote:

Originally Posted by Swagata Paul (Post 3192418)
send me last 10 lines of /var/log/messages , just after restarting the DHCP service.


hello

here is the command i used for to restart the DHCP
rsumook@rsumook-desktop:~$ sudo /etc/init.d/dhcp3-server restart
* Stopping DHCP server dhcpd3 [fail]
* Starting DHCP server dhcpd3 [fail]


and for the last 10 lines on the messages

Jun 24 08:45:03 rsumook-desktop kernel: [ 47.473946] ACPI: PCI Interrupt 0000:01:00.0[A] -> GSI 16 (level, low) -> IRQ 20
Jun 24 08:45:03 rsumook-desktop kernel: [ 47.475670] [drm] Initialized savage 2.4.1 20050313 on minor 0
Jun 24 08:45:03 rsumook-desktop kernel: [ 47.477107] mtrr: base(0xd2000000) is not aligned on a size(0x5000000) boundary
Jun 24 08:45:03 rsumook-desktop kernel: [ 47.477686] agpgart: Found an AGP 2.0 compliant device at 0000:00:00.0.
Jun 24 08:45:03 rsumook-desktop kernel: [ 47.477715] agpgart: Putting AGP V2 device at 0000:00:00.0 into 0x mode
Jun 24 08:45:03 rsumook-desktop kernel: [ 47.477785] agpgart: Putting AGP V2 device at 0000:01:00.0 into 0x mode
Jun 24 08:45:30 rsumook-desktop pulseaudio[5424]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Jun 24 08:45:30 rsumook-desktop pulseaudio[5424]: alsa-util.c: Device front:0 doesn't support 44100 Hz, changed to 48000 Hz.
Jun 24 08:49:50 rsumook-desktop kernel: [ 335.001831] eth0: setting full-duplex.
Jun 24 08:49:51 rsumook-desktop kernel: [ 335.123360] eth1: link up, 100Mbps, full-duplex, lpa 0x45E1
Jun 24 08:52:13 rsumook-desktop kernel: [ 479.041995] eth0: setting full-duplex.
Jun 24 08:52:13 rsumook-desktop kernel: [ 479.147260] eth1: link up, 100Mbps, full-duplex, lpa 0x45E1
Jun 24 09:04:54 rsumook-desktop
-- MARK --





thanks

Swagata Paul 06-24-2008 02:05 AM

see the line
openton domain-name-servers localhost, localhost2;
in your dhcp configuration file.

cheesewizz 06-25-2008 04:03 AM

Quote:

Originally Posted by Swagata Paul (Post 3193310)
see the line
openton domain-name-servers localhost, localhost2;
in your dhcp configuration file.


hello

yes i input wrong data but i already changed it.
same problem DHCP failed...once i start or restart...



please help...


All times are GMT -5. The time now is 05:36 PM.