LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-21-2003, 06:06 PM   #1
harmen
LQ Newbie
 
Registered: Jan 2003
Posts: 2

Rep: Reputation: 0
DHCP client redhat 8.0 does not register hostname in network


Hi all,

I have just installed RH 8.0. It gets an IP address from the DHCP server correctly and i am able to ping the client from the server with it's IP address. The only problem is that i can not ping it by it's hostname.

The dhcp client i'm using is de default installed one: dhclient and all the configuration is done via the Network Configuration Administrator.

In the log on the server i see:
if IN TXT "00ae718f604ef26687601e22c601d28573" rrset exists and IN A 192.168.0.52 rrset exists delete IN A 192.168.0.52: timed out.

And it should be something like this (with a hostname! in it):

if IN TXT <hostname> "00ae718f604ef26687601e22c601d28573" rrset exists and IN A <hostname> 192.168.0.52 rrset exists delete IN A <hostname> 192.168.0.52: timed out.

So I guess the client is not added to the DNS server as it is supposed to. Any tips on configuring this correctly?

Thanks,
Harmen
 
Old 01-21-2003, 06:24 PM   #2
dorian33
Member
 
Registered: Jan 2003
Location: Poland, Warsaw
Distribution: LFS, Gentoo
Posts: 582

Rep: Reputation: 32
I suppose (but I am not sure!) the correct line in dhcpd.conf should be:
host your_host_name {
hardware ethernet 00:40:F4:2F:6F:BE;
fixed-address 192.168.0.52;
}
the "fixed-address ... " line is not obligatory - it makes your IP will be always the same
but the line "hardware ..." allws the serwer to establish connection between your eth and your host name
 
Old 01-22-2003, 02:43 AM   #3
harmen
LQ Newbie
 
Registered: Jan 2003
Posts: 2

Original Poster
Rep: Reputation: 0
But I don't want to enumerate the MAC addresses of all the network adapters in my network. Besides it doen't seem necessary. My windows clients do not have the problem. Somehow they do sent the correct info to the DHCP server and my linux (RH8) client with the dhclient program does not.
 
Old 01-22-2003, 02:50 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,373

Rep: Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962
well your error up there is (pretty sure) from Bind, and not dhcpd. You've just got the findamental issue of making bind and dhcpd communicate, which i've not managed after months of trying-for-an-hour-and-getting-pissed-off you're half way there, i managed to get a little further and can update the zone file dynamically with nsupdate i think that app is called. but for what you're actually asking, i.e. how to make the hostname get sent then you should have a parameter called DHCP_HOSTNAME (if i rmember right) in /etc/sysconfig/network or maybe /etc/sysconfig/network-scripts/ifcfg-eth0 this should then definitely show up in the logs for dhcpd. and once that's a sure thing you're onto the nasty bit. make sure you're using bind 3 bind 2 defienitely can't do dynamic zone updates, but 3 *alledgedly* can.....
 
Old 01-22-2003, 02:55 AM   #5
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,373

Rep: Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962Reputation: 1962
oh.. well maybe it was just the little issue after all now i actaully read the post again. so hey hey if it does work could i borrow your config files?
 
Old 01-22-2003, 03:29 AM   #6
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
In Slackware I can get a DHCP client to send a hostname, it's in one of my startup config files and the resulting command looks like this:

/sbin/dhcpcd -t 10 -h hostname -d eth0

In Redhat I'm pretty sure you don't have a well documented rc.inet1 that you can open up and edit to add a hostname but the dhcp client can send a hostname with the dhcp request so its just a matter of figuring out where in the gui or which config file you can put it in at. Any Redhat gurus know the answer to that one?
 
Old 03-23-2009, 06:01 PM   #7
duane.mckinney
LQ Newbie
 
Registered: Mar 2008
Posts: 3

Rep: Reputation: 0
Fedora DHCP Register Hostname

I pulled this off of a CENTOS site, but it is the same with Fedora. I was having the same issue.
http://www.computechgroup.com/?p=390

edit
/etc/sysconfig/network

You need to add the hostname and the dhcp_hostname. No clue why it doesn't default to hostname if not specified.
HOSTNAME=gumby
DHCP_HOSTNAME=gumby

It helps if you are having trouble with Fedora to also try searching and substitute Red Hat or CENTOS, they are all the same lineage. And 9 times our of 10 (99/100 it seems) a solution for one works for the other 2.

HTH
Duane
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DHCP hostname not set with a linux client tnine9 Linux - Networking 0 08-09-2005 08:48 AM
FreeBSD 5.3 - Network Problem - DHCP Client KGodwin *BSD 6 03-30-2005 05:55 AM
DHCP client on Redhat 7.3 malfunctioning query987 Linux - Networking 10 08-20-2003 06:12 PM
XP Pro Build 2600/sp1 v.1105 DHCP Client to Redhat 8.0 DHCP Server - Problems atomant Linux - Networking 5 06-28-2003 11:24 AM
DHCP client problems - network config RedHat123 Linux - Networking 1 12-16-2001 12:52 PM


All times are GMT -5. The time now is 10:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration