LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   dhcp client not getting IP from dhcp server (http://www.linuxquestions.org/questions/linux-networking-3/dhcp-client-not-getting-ip-from-dhcp-server-334526/)

jkmartha 06-17-2005 08:17 AM

dhcp client not getting IP from dhcp server
 
fedora-2.
configured dhcp server.

# cat /etc/dhcpd.conf
ddns-update-style interim;
ignore client-updates;

subnet 192.168.1.0 netmask 255.255.255.0 {

# --- default gateway
option routers 192.168.1.5;
option subnet-mask 255.255.255.0;

# option nis-domain "domain.org";
# option domain-name "domain.org";
# option domain-name-servers 192.168.1.5;

option time-offset -18000; # Eastern Standard Time
# option ntp-servers 192.168.1.1;
# option netbios-name-servers 192.168.1.1;
# --- Selects point-to-point node (default is hybrid). Don't change this unless
# -- you understand Netbios very well
# option netbios-node-type 2;

range 192.168.1.128 192.168.1.254;
default-lease-time 21600;
max-lease-time 43200;
}


clinet is also fedora -2 . i used # netconfig to configure dhcp client options . when i use # ifconfig , i donot get a ip from the dhcp server. i get the same old static IP which was earlier configured. why is it so ? how can i get a ip from the dhcp server on the client ? in windows , .....ipconfig /flushdns or ipconfig /renew or is used.

lukebeales 06-17-2005 08:56 AM

I don't know if this is the only way, but I always use dhcpcd which goes off and finds the dhcp server, and sets the ip and routes by itself without you having to use ifconfig. You would know better than I do where that is in fedora but give dhcpcd a try.

cowanrl 06-17-2005 09:12 AM

Do you get an IP via DHCP when the client is rebooted?

After you make the changes with netconfing, try executing:

ifconfig eth0 down
ifconfig eth0 up

to take the interface down, then back up and get an IP address.

You should get an IP address via DHCP when the machine is started up.


All times are GMT -5. The time now is 02:09 AM.