LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-16-2008, 03:20 PM   #1
philwynk
Member
 
Registered: Sep 2007
Posts: 84

Rep: Reputation: 15
dhclient seg fault; eth0 DEAD. Help!


Kinda nube, kinda not, running Fedora Core 7, the i386 modules on an Athlon 64 box.

This afternoon, my package manager alerted me to some updates, and as is my habit, I went ahead and applied them, and then rebooted as instructed.

When I came up, eth0 failed on bootup. The error message indicated a segmentation fault at line 297 of /etc/sysconfig/network-scripts/ifup-eth, which pointed me to an execution of dhclient, vis:

/sbin/dhclient ${DHCLIENTARGS} ${DEVICE}

Fiddling with the command line, I determined at first that it was upset because the args included a .pid file with an expired PID, so I manually executed the command line without the -pf flag, and eth0 started. Cool.

So then, I modified the ifup-eth script so it wouldn't issue the -pf flag, and restarted the machine.

And now, I can't do ANYTHING to get eth0 up. dhclient seg faults no matter what I do. I even undid all (two of) my changes and tried again. Nothing. Eth0 will not come up. My web site is a boat anchor.

HELP!

Any ideas?

Oh, ps: I do take backups, but only of /var and /etc. So restoring these won't restore /sbin. If the problem is dhclient itself, do I have any recourse other than reinstalling Fedora core 7 from scratch, and then restoring my backup? And once I do that, how do I keep the damned package manager from munging my dhclient again?


Phil W.
 
Old 01-16-2008, 06:08 PM   #2
philwynk
Member
 
Registered: Sep 2007
Posts: 84

Original Poster
Rep: Reputation: 15
Never mind

I'm just reinstalling Fedora from scratch, and I guess I'll upgrade to core 8.

What a friggin' disaster. I think I'll turn updates off so this doesn't happen again.

I'm not impressed with the stability of the environment.
 
  


Reply

Tags
dhclient, startup, update


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
seg fault vm_devadas Linux - Enterprise 1 12-05-2006 02:28 PM
firefox has seg fault lilili Linux - Software 6 04-05-2006 10:55 PM
RH 7.2 crash...getting seg fault when using ls sakima Red Hat 1 10-11-2004 09:14 AM
C seg fault drigz Programming 5 10-01-2004 03:35 PM
gnome_app_create_menus seg fault in RH 7.3 Castro Programming 0 05-30-2003 08:46 PM


All times are GMT -5. The time now is 12:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration