LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   "...Device eth0 has different MAC address than expected,.." (http://www.linuxquestions.org/questions/linux-networking-3/device-eth0-has-different-mac-address-than-expected-516793/)

lothario 01-05-2007 10:51 PM

"...Device eth0 has different MAC address than expected,.."
 
I had to setup 3 identical Fedora Core 4 systems for a custom application training session.
All 3 machines have identical hardware.

So I got the first machine configured as per the requirements.
Then I used "Ghost for Linux" to make an image of this PC on a ftp server.
I used the "Ghost for Linux" boot CD to put the same image on the 2nd machine.

Machines 1 and 2 are DHCP clients and they are working pretty much as expected.

But ONLY on the 2nd machine, I keep getting this warning (on the console) when I reboot:
Quote:

"Shutting down interface eth0: Device eth0 has different MAC address than expected, ignoring."
Ok, yes the mac address of the 1st machine was inherited by the 2nd machine via the ghost imaging.
And it is being ignored. But I would like to fix this warning.

How do I fix eth0 on the 2nd machine so that the inherited MAC address goes away
and therefore the above warning goes away?

jonwatson 01-06-2007 12:40 AM

On a Debian machine I would investigate the /etc/iftab file. I'm not sure if this is the same file on a FC machine, but it might point you in the right direction.

lothario 01-06-2007 06:16 AM

Thanks for the tip.
It helped me find the right file to edit:

/etc/sysconfig/network-scripts/ifcfg-eth0

Just updated the HWADDR value and rebooted the system.
Problem solved.

jonwatson 01-06-2007 12:14 PM

Good to know, thanks!

IonutIonescu 02-25-2010 03:55 PM

thanks, just the ticket
 
had similar problem with RedHat RHEL5.4 on and old Toshiba laptop.
Edited the file and it worked.

montego 03-18-2013 06:06 PM

I have the same problem.
When I try to change MAC with the following commands:

ifconfig eth0 down
ifconfig eth0 hw ether aa:bb:cc:dd:ee
ifconfig eth0 up


after service network restart it gives me the error: Device eth0 has different MAC address than expected, ignoring.

I also tried to update /etc/sysconfig/network-scripts/ifcfg-eth0, but after the restart nothing happens, the new MAC has no effect.

Is there another way to do it?

P.S. I am using Centos 6.4.

abdulhameedom 05-13-2014 06:59 AM

Quote:

Originally Posted by lothario (Post 2573886)
Thanks for the tip.
It helped me find the right file to edit:

/etc/sysconfig/network-scripts/ifcfg-eth0

Just updated the HWADDR value and rebooted the system.
Problem solved.


Kindly advice me what is HWADDR value,, i found 00:0C:29:53:7A:AE . now what i have to update ,, you mean a new value ?? what it might be.. pls i am new one for linux pls help me to understand :confused:

Regards

TenTenths 05-13-2014 08:43 AM

Quote:

Originally Posted by abdulhameedom (Post 5169874)
Kindly advice me what is HWADDR value,, i found 00:0C:29:53:7A:AE . now what i have to update ,, you mean a new value ?? what it might be.. pls i am new one for linux pls help me to understand :confused:

Regards

The value will depend on the actual MAC that's coded on to the network card. If you only have one network card on a system you can usually delete the HWADDR line as your only network card will be eth0.

If you have multiple NICs in your server then the HWADDR line is essential so that networking has a physical to "logical" mapping.

You could also try
Code:

ifconfig -a
to show the HWaddr of the various NICs in your system.

abdulhameedom 05-13-2014 02:18 PM

Quote:

Originally Posted by TenTenths (Post 5169933)
The value will depend on the actual MAC that's coded on to the network card. If you only have one network card on a system you can usually delete the HWADDR line as your only network card will be eth0.

If you have multiple NICs in your server then the HWADDR line is essential so that networking has a physical to "logical" mapping.

You could also try
Code:

ifconfig -a
to show the HWaddr of the various NICs in your system.

Dear Sir TenTenths..

because of this below problem i am searching many blogs,, finally i found this page,, as per your advice only one network card i am using in my linux box, still not able to connect this server using putty.. pls have a look on my issue in detail which i posted in another page as a Question,, still no one answered this.. kindly help me

==================================================================================================== ================================

I am trying to transfer files from my Windows 7 machine into my VMware OEL 5 .

But i am not able to connect the Filezillah and not even able to login with Putty also.

About my System
1. My network is a normal one not having any domain and all, just a normal broadband modem so my IP is not a static IP [192.168.1.4]

2. My VM is a Fresh installed and it obtain the IP automatically [192.168.1.22]

3. In VM ware BRIDGE is enabled from the begging.

4. LINUX and WINDOWS can able to ping vice verse

5. Both Firewalls are Disabled


Kindly advice me what are the other options i have to check to connect my Putty to Linux Server and how do i transfer files to my linux box via filezilla..

jefro 05-13-2014 04:19 PM

Kind of a old post to add to.

abdulhameedom 05-14-2014 04:02 AM

Quote:

Originally Posted by jefro (Post 5170241)
Kind of a old post to add to.

Sir,, this may be a old post,, but i am facing this issue now,, how can i come from this stage,,
Kindly help me sir,,

i am totally fed up,, actually i planed to start learning Oracle Apps R12.. for that i need this linux box as the first platform where i start my installation,, for last 3 days i am struggling with this issue,,

Hope you can help me..

jerrybk108 08-05-2014 10:24 PM

I fixed the error, Thanks!
I followed these steps:
1. type ifconfig -a to get Mac Address.
2. vi /etc/sys.../ifcfg-eth0 and replace HWADDR by the Mac Address I get by above step.


All times are GMT -5. The time now is 04:11 PM.