LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   cups/samba print w/o passwd in printers.conf? (http://www.linuxquestions.org/questions/linux-networking-3/cups-samba-print-w-o-passwd-in-printers-conf-260653/)

jshaffer 11-29-2004 04:45 PM

cups/samba print w/o passwd in printers.conf?
 
I've been struggling with getting printing set up with CUPS and Samba
and have made it to the point where I can print from my linux box to a
printer that is on the Windows side of our network. Unfortunately, the
only reliable solution (so far)requires that my password be placed in clear
text in the /etc/cups/printers.conf file in the line

DeviceURI smb://myname:mypasswd@mei_nt1/zeppo/myprintername

If I change that line to remove my password, nothing will print. For
example, if lpq tells me that job 73 is in the queue for my printer, then
the tail of my /var/log/cups/error_log says

Started backend /usr/lib/cups/backend smb (PID10780) for job 73.
[Job 73] Connection failed with error NT_STATUS_ACCESS_DENIED
[Job 73] Unable to connect to SAMBA host, will retry in 60 seconds...

If I change it back and restart CUPS, then anything in the print
queue will immediately go to the printer and start printing. What can
I change in my authorizations or configurations so that I don't need to
put my password in that file?

I am using RedHat Enterprise 3 WS.

sdrycroft 03-29-2010 06:26 AM

I had the exact opposite problem to the original poster - I wanted to disable the asking for the username and password, and wanted my password to be in the file (which I've now done, thanks to the obvious way shown). I can also answer the question, in case anyone else is looking. You need to add:

Code:

AuthInfoRequired username,password


All times are GMT -5. The time now is 08:45 PM.