LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   CUPS not working between Slackware and Mint (http://www.linuxquestions.org/questions/linux-networking-3/cups-not-working-between-slackware-and-mint-4175459361/)

dchmelik 04-23-2013 09:42 PM

CUPS not working between Slackware and Mint
 
I have used Slackware since 1997 but never set up network printing before. So, I went to the KDE system settings in KDE Mint, and enabled a CUPS printer on my family members' PC. Then I went to my TDE system settings on my Slackware PC, searched for a CUPS printer, and it says it is not found. What do I do?

Andy Alkaline 04-27-2013 03:01 AM

Check your firewall (CUPS uses port 631), and check your logs ( /var/log/cups/ )

Are you trying to sharing the printer from Mint?

Another way to check some settings is: in your web browser, go to http://localhost:631

That's your web-based CUPS admin interface. There's an option "Share printers connected to this system"

dchmelik 04-27-2013 04:21 AM

Quote:

Originally Posted by Andy Alkaline (Post 4939778)
Check your firewall (CUPS uses port 631), and check your logs ( /var/log/cups/ )

Router firewall? PC firewall? I am not running one on Slackware and do not know much about Mint (the PC with it is not my computer, but I am basically its administrator.)
Quote:

Are you trying to sharing the printer from Mint?
I first said I tried to enable it in Mint, so basically I have said yes. Actually, I tried sharing it on my OpenBSD server next to the Mint PC, which failed and has an unanswered thread.
Quote:

Another way to check some settings is: in your web browser, go to http://localhost:631

That's your web-based CUPS admin interface. There's an option "Share printers connected to this system"
I am aware of that. I already got into the KDE system hardware admin menu on the Mint computer the printer is connected to, and the printer seems enabled in CUPS there. If I recall, I could maybe not access CUPS in a web browser on port 631 on Mint. Of course, I can on Slackware, but TDE (a KDE3 fork) has a similar system hardware admin menu. I have a working /etc/hosts with the Mint PC included, but on Slackware, it does not even find the printer, though I have used my PC on LANS for years (not with printers yet.) Actually, I have not done ssh to the Mint PC either but want to avoid running SSHD on it.

Andy Alkaline 04-27-2013 12:03 PM

If you can't access CUPS on Mint through the browser, I'd first check at the command line to make sure it's running (if you haven't already done so):

pgrep -l cupsd

and second, make sure it's listening:

debian64:~$ netstat -utnl | grep :631

should produce output similar to:
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN
tcp6 0 0 ::1:631 :::* LISTEN
udp 0 0 0.0.0.0:631 0.0.0.0:*

dchmelik 04-27-2013 11:18 PM

Quote:

Originally Posted by Andy Alkaline (Post 4940081)
If you can't access CUPS on Mint through the browser, I'd first check at the command line to make sure it's running (if you haven't already done so): [...]

It is running.
Quote:

and second, make sure it's listening: [...] should produce output similar to:
tcp 0 0 127.0.0.1:631 0.0.0.0:* LISTEN
tcp6 0 0 ::1:631 :::* LISTEN
udp 0 0 0.0.0.0:631 0.0.0.0:*
I got output that had two lines starting with tcp, ending with LISTEN, then a udp line... I do not reacll if it was exactly the same, but it was similar.

Andy Alkaline 04-28-2013 04:10 AM

Okay.

I forgot to check your firewall. You can use nmap from your Slackware box to scan the open ports on Mint.

debian64:~# nmap -p 631 localhost

Starting Nmap 6.00 ( http://nmap.org ) at 2013-04-28 03:06 CDT
Nmap scan report for localhost (127.0.0.1)
Host is up (0.00013s latency).
PORT STATE SERVICE
631/tcp open ipp

Or as root, run 'iptables -nL' on Mint. Or use some GUI firewall app; I don't know what Mint has to offer.

Anything in /var/log/cups/error_log or access_log that might give a clue?

dchmelik 05-01-2013 07:10 PM

I found out what the problem was. I actually saw the printer listed in TDE, but it was listed at one higher LAN IP address number than I expected. It seems, when I was reconfiguring my LAN before replacing a router, I disconnected my PC, then the Mint one got too high of an IP address instead of the one in /etc/hosts, so I have to restart the Mint on. That will probably do it (well, I could even connect the printer right now, but I want the LAN numbers to not have gaps from the first to last.)


All times are GMT -5. The time now is 02:23 AM.