LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-13-2007, 04:45 AM   #1
indyszeto
LQ Newbie
 
Registered: Jan 2007
Posts: 2

Rep: Reputation: 0
Unhappy Couldn't connect to internet after installed Fedora 6


Hi,

I had installed Fedora in my PC which previously worked well with Windows XP and could browse internet. The motherboard has built in LAN port but I used external LAN card to browse internet in XP era.

With Fedora, I couldn't use firefox to browse internet. I checked my network setting in Fedora.

At device tab, I found that eth0 & eth1 were in non-operational state. Information at Hosts tab, the fields' content were: IP=::1, Name=localhost.localdomain, Aliases=localhost

I opened a shell window (bash). I typed ping 127.0.0.1, it got response so Fedora should recognize my LAN card working. However, as I typed arp then ifconfig commands, shell responsed command not found. The same response returned regardless it's bash, csh or ksh.

I would like to ask what could I do to solve this problem ?

PS: I connect to internet via vDSL modem provided by ISP, no extra login via ISP web page needed to go internet. I could just plug in the modem to PC LAN cable then open IE to browse internet in XP days.
 
Old 01-13-2007, 05:12 AM   #2
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
(GUI method) Using the network device control, you can configure the nic and then activate it.

From terminal "system-config-network".

To use ifconfig, you have to be root.

It has struck me: many windows users expect to start a browser, then find something starts their connections for them. (i.e. IE will start a dialer automatically for dail-up connections.) This sort of thing won't happen in linux. You have to start the connection for a browser to work.

In your case, once the nic is configured and activated you should be fine. Exit with "save settings" and you won't have to reconnect each time you reboot.

Last edited by Simon Bridge; 01-13-2007 at 05:15 AM.
 
Old 01-13-2007, 07:12 AM   #3
baltika_no_9
LQ Newbie
 
Registered: Jan 2007
Posts: 7

Rep: Reputation: 0
Quote:
Originally Posted by indyszeto
Hi,

I had installed Fedora in my PC which previously worked well with Windows XP and could browse internet. The motherboard has built in LAN port but I used external LAN card to browse internet in XP era.

With Fedora, I couldn't use firefox to browse internet. I checked my network setting in Fedora.

At device tab, I found that eth0 & eth1 were in non-operational state. Information at Hosts tab, the fields' content were: IP=::1, Name=localhost.localdomain, Aliases=localhost

I opened a shell window (bash). I typed ping 127.0.0.1, it got response so Fedora should recognize my LAN card working. However, as I typed arp then ifconfig commands, shell responsed command not found. The same response returned regardless it's bash, csh or ksh.

I would like to ask what could I do to solve this problem ?

PS: I connect to internet via vDSL modem provided by ISP, no extra login via ISP web page needed to go internet. I could just plug in the modem to PC LAN cable then open IE to browse internet in XP days.
Can you post the config file for the ethernet NIC you're using to connect to the modem as that shoud show something. Interestingly the hosts file you show the contents of is the typical FC6 one which assumes you've enable IPV6. It's not a problem i this case but I'd recommend you disable it unless you really need it as it does lead to confusion.

I've built a few FC6 systems and would like to help.

Cheers
 
Old 01-22-2007, 02:11 PM   #4
indyszeto
LQ Newbie
 
Registered: Jan 2007
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Simon Bridge
(GUI method) Using the network device control, you can configure the nic and then activate it.

From terminal "system-config-network".

To use ifconfig, you have to be root.

It has struck me: many windows users expect to start a browser, then find something starts their connections for them. (i.e. IE will start a dialer automatically for dail-up connections.) This sort of thing won't happen in linux. You have to start the connection for a browser to work.

In your case, once the nic is configured and activated you should be fine. Exit with "save settings" and you won't have to reconnect each time you reboot.
Sorry for LATE LATE REPLY because password LOST previously.

Let me update status, I had done below things :

Login using root account
/sbin/ifconfig -a showed no ip address assigned
service network restart successfully caused ip address assigned

Then browsing using firefox succeeded

But how could I enable fedora to always enable network service ?

Also, I checked from service setting background service tab that many services were not activated (tick not appeared in corresponding check box), where could I get description details of these services and how could I enable those not still disabled but needed services ?

Tks!
 
Old 01-25-2007, 04:52 AM   #5
Simon Bridge
Guru
 
Registered: Oct 2003
Location: Waiheke NZ
Distribution: Ubuntu
Posts: 9,211

Rep: Reputation: 197Reputation: 197
Quote:
But how could I enable fedora to always enable network service ?
Network Device Control
Quote:
where could I get description details of these services and how could I enable those not still disabled but needed services ?
You could google the service names (how do you know they are needed if you don't know what they are? Never mind...) or you could take a look at the FC6 installation notes at www.mjmwired.net - Mauriat has a list of the services with a breif discription.

For that matter, a breif discription is available in the services panel you are looking at. To activate them: see what happens when you click the check box?
 
Old 04-21-2007, 06:19 PM   #6
UhhMaybe
Member
 
Registered: Jul 2004
Location: Salt Lake City, Utah
Distribution: Absolute 12.0 Studio 64 1.3.0
Posts: 470

Rep: Reputation: 30
Cool

Enable the processes YOU want to start at Boot UP. Disable the processes that YOU do not require at Boot Up. Three choices. A) Network Device Control B) System Processes C)Text Editor.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to wireless connect to internet. Just installed Ubuntu 6.10v fgrijalva Ubuntu 7 11-09-2006 10:37 PM
Suse 10.1 Just Installed; Can't Connect to Internet BrunoBB Linux - Networking 4 08-23-2006 11:43 AM
Fedora Core 3 installed, cant connect to internet!~ spartanM19SSM Linux - Networking 5 12-13-2004 11:19 AM
Installed mandrake 10 on compaq presario 5011CL and can't connect to the internet zeshan_b Linux - Newbie 6 09-14-2004 04:41 AM
installed redhat 9, can't figure out how to connect to internet. nate2000 Linux - Newbie 1 11-11-2003 08:29 PM


All times are GMT -5. The time now is 02:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration