LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-29-2006, 12:37 PM   #1
nshewmaker
LQ Newbie
 
Registered: Jul 2006
Distribution: Ubuntu
Posts: 9

Rep: Reputation: 0
Question continued slow dns lookups on Fedora Core 5


My problem(s) with slow Internet speeds appeared suddenly on this box when it ran Ubuntu. Since something in the network just seemed to give, I first tried removing the router from the network, replacing the NIC, replacing the cable modem, and replacing the network cable. None of that has helped. Furthermore, my Windows XP machine--which has a processor speed of roughly 1/5 my Linux box--actually browses faster (once the browser is loaded) than my Linux box. So, I replaced Ubuntu with FC5 to see if that would help. My Internet speeds are still intolerable, but I have narrowed the problem down to the DNS lookups.

After the network "break", lookups could take 30+ seconds. The problem was not just with Firefox. I could launch gaim, which connects to 5 accounts simultaneously, and wait a minute or so for the connections to complete (if they didn't time out). It's possible this break was a result of changes made by my ISP to its cable network, perhaps making some IPv6-affecting changes that Windows ignores.

After much searching, I found the most popular solution to "slow dns lookup" to be disabling IPv6. I did so in Firefox by browsing to about:config and setting
Code:
network.dns.disableIPv6=true
Since the problem was not isolated to that program, I also added
Code:
alias net-pf-10 off
alias ipv6 off
to the top of /etc/modprobe.conf ("alias net-pf-10 off" alone did not seem to help, but it was at the end of the file at first). After making that change, I rebooted.

I checked out Firefox again. Lookups were now better for some (really obscure) sites, but still 10+s for others (like Google). This really confuses me, because I would have thought it would be an all-or-nothing fix. I found another solution, and added
Code:
NETWORKING_IPV6=no
to /etc/sysconfig/network, then restarted networking. This may have helped, but the results seem inconsistent. I just had a 23s lookup for Google, after a fairly quick load of gaim. Things are better, but not what I would consider "good".

Other than a Linux system setting, the only other point-of-failure I can figure is my router, which is back in my network. It is a Linksys WRT54GL running dd-wrt v23. The address for both my machines are hard-coded, as are the DNS servers on my Linux box. I know dd-wrt has several DNS features (such as caching), but I really just want my lookups to pass right through the router to my ISP's DNS servers. Though, again, Windows isn't having these problems, which seem to make the only possible cause the Linux OS. (Of course, I know there are several nuances Windows is too stupid to understand or Linux is too smart to ignore.)

I hope I haven't bored you to tears yet, but I'm hoping to have brought all the various ideas about slow lookups into this one thread. Then, I'm hoping that someone will have some brilliant solution (or will at least have had as inconsistent success as I have). Some insight into the inner workings of the Internet and why, for example, Google takes longer than other sites (It has multiple addresses, I know, but you'd think if anyone supported IPv6 lookups, it would be Google.) might also be a plus.

I suppose the next step might be for someone to suggest a publicly-available, quick, and reliable DNS server that I might try instead of those on my ISP.

Any and all help is greatly appreciated.

Last edited by nshewmaker; 07-29-2006 at 12:45 PM.
 
Old 07-29-2006, 03:35 PM   #2
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
You can try adding the statement:

option timeout:1

To your /etc/resolv.conf, and restarting networking. That way, if one of the DNS is experiencing problems, you will timeout rapidly and move on to the next DNS server. You can also try adding:

nameserver 208.67.222.222
nameserver 208.67.220.220

to the top of your /etc/resolv.conf. They are public DNS and very fast.
 
Old 07-29-2006, 10:21 PM   #3
nshewmaker
LQ Newbie
 
Registered: Jul 2006
Distribution: Ubuntu
Posts: 9

Original Poster
Rep: Reputation: 0
I added the timeout option, restarted networking, and still had to wait 17s for a dns lookup for Flickr.

However, the new DNS servers seem to have fixed the problem. (I'd like to give it a few days before I officially close the case, but things are certainly moving faster right now.) Many thanks, macemoneta.

So, before I give my ISP hell about this, why was the Windows machine still faster even after I'd done everything to disable the finicky IPv6 demands of Linux?
 
Old 07-30-2006, 12:52 AM   #4
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
Without a time stamped network trace, preferably from both your end and your ISP on the network segments with the DNS servers, I would be speculating about the cause.

It's not the first time I've heard about DNS servers that work fine with Windows, but can cause problems for Linux. You do the math.
 
Old 08-01-2006, 08:32 PM   #5
beatupbilly
Member
 
Registered: Jan 2004
Location: Pinr Lake, GA
Distribution: Slackware, LinuxMint, FreeBSD, Xandros, CentOS, Fedora Core, RedHat, Chakra, etc etc
Posts: 215

Rep: Reputation: 30
this thread

must apply to U5? I cannot find etc/sysconf/ under etc. Or anywhere else for that matter in U6.06. Any ideas?
 
Old 08-01-2006, 08:55 PM   #6
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
Create a file in /etc/modprobe.d called blacklist-ipv6

The file should contain:

# Disable IPv6
blacklist ipv6

Reboot, and IPv6 will no longer be enabled on the system. You can confirm with:

/sbin/ifconfig -a

You won't see any ipv6 entries.
 
Old 08-03-2006, 03:47 PM   #7
pdeman2
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: OpenSUSE, Gentoo, Fedora, Ubuntu, Mandriva, others
Posts: 413

Rep: Reputation: 30
I'm having a similar problem with my Fedora server. This server used to connect to the internet through a D-Link router and it worked fine. Now it is the router for my network. I managed to fix the name lookup issue with macemoneta's suggestions, but I'm still having terrible bandwidth. I have a T3 rated connection and I'm getting speeds slower than some dial-up connections. I've been working on the issue for quite a while, but I'm stumped.

Any suggestions?
 
Old 08-03-2006, 03:59 PM   #8
macemoneta
Senior Member
 
Registered: Jan 2005
Location: Manalapan, NJ
Distribution: Fedora x86 and x86_64, Debian PPC and ARM, Android
Posts: 4,593
Blog Entries: 2

Rep: Reputation: 328Reputation: 328Reputation: 328Reputation: 328
A "T3 rated connection"? Is that a full T3, or ATM-T3/Frame Relay T3? If the latter, you probably don't have full bandwidth for your network (that is, you are probably not paying for a 45Mb committed/minimum information rate).

Also, how are you measuring bandwidth? A single connection to a single server? That's not valid... Start 5-10 file transfers to unique diverse servers. Check route diversity with traceroute, and minimize the overlap. Each destination server must have adequate bandwidth (45Mb+), otherwise, you have to start more transfers. Ideally, the only network activity should be between you and the T3, otherwise you are dealing with internal network contention.

Last edited by macemoneta; 08-03-2006 at 04:01 PM.
 
Old 08-04-2006, 01:29 PM   #9
pdeman2
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: OpenSUSE, Gentoo, Fedora, Ubuntu, Mandriva, others
Posts: 413

Rep: Reputation: 30
True, technically it's not T3, it has some sort of quota preventing me from getting much more than 4 or 5MB/S, but my ISP tells me it's T3 rated, so whatever.

I have just made an interesting discovery though. I just replaced the old router (so the server connects through the D-Link router) and all the networking is fine except the server is still terribly slow. I was about to connect to the server so I could test it's connection. It seems like I can't be SSHed into the server for more than a minute or so and the connection sort of bogs down. I then tried to connect to it's web server but that was also incredibly slow.

I've never had this issue before until now. It's as if using it as the gateway server did something to it's external interface.
 
Old 08-06-2006, 03:08 PM   #10
pdeman2
Member
 
Registered: Jul 2005
Location: Maine, USA
Distribution: OpenSUSE, Gentoo, Fedora, Ubuntu, Mandriva, others
Posts: 413

Rep: Reputation: 30
Bump......
 
Old 08-12-2006, 08:20 PM   #11
Muiro
LQ Newbie
 
Registered: Nov 2003
Distribution: Arch Linux
Posts: 15

Rep: Reputation: 0
Bumping this because this finally fixed my lookup speed problem. My isp's lookups worked fine for windows but were slow on FC5. The solution involving ipv6 never worked but this has. The timeout helps but I think it was mostly the public dns.

Mayhap Adelphia's DNS doesn't like linux.
 
Old 08-27-2006, 12:21 AM   #12
rearviewmirror
LQ Newbie
 
Registered: Aug 2006
Posts: 3

Rep: Reputation: 0
I've dealt this FC3 and now FC5, the DNS is SLOW SLOW SLOW! The windows computers in the house have no problem with DNS. The ISP is RoadRunner, and I've even tried switching to OpenDNS to no avail. When switching to OpenDNS the Window's computers continued to work fine, but Linux (fedora) still continued to take forever to resolve names. Also, the OpenBSD firewall has zero problems resolving names instantly. Any other ideas?
 
Old 08-27-2006, 12:40 AM   #13
rearviewmirror
LQ Newbie
 
Registered: Aug 2006
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by rearviewmirror
I've dealt this FC3 and now FC5, the DNS is SLOW SLOW SLOW! The windows computers in the house have no problem with DNS. The ISP is RoadRunner, and I've even tried switching to OpenDNS to no avail. When switching to OpenDNS the Window's computers continued to work fine, but Linux (fedora) still continued to take forever to resolve names. Also, the OpenBSD firewall has zero problems resolving names instantly. Any other ideas?
I removed IPV6 and rebooted as mentioned above, now the system resolves names as it should! Thanks!!!!
 
Old 12-19-2006, 04:45 PM   #14
Muiro
LQ Newbie
 
Registered: Nov 2003
Distribution: Arch Linux
Posts: 15

Rep: Reputation: 0
RESOLUTION:
--------------------------------------------------------------------------------------------------------------
It appears as if for some, especially those with roadrunner/adelphia cable internet, changeing to openDNS solves the problems. However, for some the disabling the ipv6 through various methods works instead. I have had a number of linux systems on my home network have slow lookup speed until I change the dns information, fedora and otherwise. The windows systems on my network don't seem to have a problem with the default dns paths.

I've found that disable ipv6 makes no difference on any system I have been on. I would suggest that you change your dns information if you are having slow lookups with fedora. You can do this through the command line by running "ipconfig" or through the gui tools. However, make sure that in your DHCP settings you set it to -not- automatically obtain dns information.
-----------------------------------------------------------------------------------------------------------------

I made this final post because on many threads, new poeple will try to find a post neer the bottom to sum everything up. Here you go.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Browser, probably DNS lookup, Core 5 rdnelson Fedora 2 06-20-2006 12:43 PM
slow DNS lookups using Novatel V620 gpetme Linux - Wireless Networking 4 05-06-2006 11:55 AM
DNS Lookups Slow kwiksand Linux - Networking 0 11-15-2004 05:52 AM
Sendail and DNS lookups Hessian Rider Linux - Networking 3 11-05-2002 08:03 AM
Allow DNS lookups through ipchains? ifm Linux - Security 4 08-09-2002 09:17 AM


All times are GMT -5. The time now is 11:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration