LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 12-16-2009, 05:51 PM   #1
lmu9@yahoo.com
LQ Newbie
 
Registered: Dec 2009
Posts: 2

Rep: Reputation: 0
Connection refused after 15 to 30 minutes, sometimes an hour


I have 4 Linux OEL 5.3 boxes. 2 production, 2 test. I connect to them through VPN. The programs I access the servers from are a cygwin xterm window - ssh or sftp or Oracle Applications EBusiness.

I can connect to any of the servers with out issue as many times as I want within the first 15 to 30 minutes after connecting to the VPN. After 15 to 30 minutes, sometimes an hour, but rarely that long, I can still connect fine to my test instances, but I get a connection refused message trying to open a new connection to Production. This also causes my Oracle Applications session to end. I do not have a problem with the xterm windows I have connected at the start of my session. I can also ssh to one or any of the servers from one of my open connections, but I cannot get a new one.

The network engineers say that it must be a setting on my servers. There is no reason it would let me on one box as opposed to the others.

To get any type of new session to production I have to disconnect my VPN connection and establish a new one. This really only affects my Web session on Apps. I have learned to live with the other.

Is there a Linux setting that would send something randomly to the VPN to tell it to cut me off? What can I possibly look at? The boxes are configured exactly the same except a couple of settings.

The following settings are commented on the Prod boxes but not on the Test boxes.

/etc/security/limits.conf
* hard nofile 65535
* soft nofile 4096
* hard nproc 16384
* soft nproc 2047

The following settings are on production, but not on test:

/etc/resolv.conf
options attempts:5
options timeout:15

I see the following message in the messages log on the production boxes if I add portmapper:ALL to the /etc/hosts.deny file, but not on the test boxes. The # are actual numbers but masked for this thread.

connect from ##.#.###.### to callit(ypserv): request from unauthorized host

This is so frustrating. Aside from asking their network admin to put my test boxes on the same subnet as the prod boxes to see if it exibits the same behavior, I'm at a loss.

Oh, yea, one weekend a few weeks ago my connection stayed open all weekend and I thought the issue was resolved. Come Monday morning I was back to connection refused after an hour. It appears lately it's back down to 15 minutes.

This all appeared to happen after the VPN asked me to download a new client. At that time I not only could not establish a new connection, but the connections I had were disconnected. It's better now, as I no longer lose the session I have established, but still a mystery why I cannot establish a new session from my desktop after 30 minutes. (yes, the time varies and is not consistent, it was 12 minutes a few minutes ago, and over an hour a few minutes before that).
The VPN is a a webpage vpn called Aventail version 10.0.2.38

Last edited by lmu9@yahoo.com; 12-16-2009 at 06:00 PM. Reason: additional details.
 
Old 12-17-2009, 11:13 AM   #2
affinity
Member
 
Registered: Nov 2009
Distribution: Slackware64
Posts: 132

Rep: Reputation: 20
If this started happening after you updated the VPN software I would try downgrading to the last version that was working for you, if the problem still happens then you know its the new software update. Before downgrading the software you may want to have a look at this post on the Citrix forums, it covers an issue Aventail has with disconnecting due to timeouts.
 
  


Reply

Tags
connection, limits, refused, vpn


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
convert total no of seconds in the format hour minutes and seconds suchi_s Programming 15 03-15-2011 12:34 PM
Socket Connection Failed: 111 Connection Refused degraffenried13 Linux - General 3 05-31-2009 02:17 AM
scp connection resets after about 1 hour lothario Linux - Networking 6 04-15-2008 11:21 AM
External connection fails after exactly 1 hour Baruch Debian 7 03-06-2005 09:05 AM
Computer locks up linux, after 10 minutes, hour, 2 days. 2 and half max! RHLinuxGUY Linux - Hardware 26 10-19-2004 08:03 PM


All times are GMT -5. The time now is 01:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration