LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Connecting XP to Samba domain contoller (http://www.linuxquestions.org/questions/linux-networking-3/connecting-xp-to-samba-domain-contoller-478885/)

linuxpng2 08-30-2006 04:31 PM

Connecting XP to Samba domain contoller
 
I know this has been asked a million times, so I'm sorry for bringing it up again, but I've tried everything I've read to get this to work. I've got a RHLE4 server set up as a domain controller (will post my smb.conf below). I can map a drive from XP and copy data to/from with no problems. When I try to add the domain, it prompts me for ID/PW (which tells me it's at least *seeing the domain*) but when I enter my Samba ID/PW, I get "Access is Denied".

Now I've tried changing my registry on XP. I've tried adding my machine itself (which I may not have done correctly). Any ideas why it's not working?

Again, sorry for bringing it up again, but I'm a newb trying to learn. :(


#======================= Global Settings =====================================
[global]

# workgroup = NT-Domain-Name or Workgroup-Name
workgroup = DMBACKUP

# server string is the equivalent of the NT Description field
server string = Samba Server

# This option is important for security. It allows you to restrict
# connections to machines which are on your local network. The
# following example restricts access to two C class networks and
# the "loopback" interface. For more examples of the syntax see
# the smb.conf man page
; hosts allow = 192.168.1. 192.168.2. 127.

# if you want to automatically load your printer list rather
# than setting them up individually then you'll need this
printcap name = /etc/printcap
load printers = yes

# It should not be necessary to spell out the print system type unless
# yours is non-standard. Currently supported print systems include:
# bsd, sysv, plp, lprng, aix, hpux, qnx
; printing = cups

# This option tells cups that the data has already been rasterized
cups options = raw

# Uncomment this if you want a guest account, you must add this to /etc/passwd
# otherwise the user "nobody" is used
; guest account = pcguest

# this tells Samba to use a separate log file for each machine
# that connects
log file = /var/log/samba/%m.log
# all log information in one file
# log file = /var/log/samba/smbd.log

# Put a capping on the size of the log files (in Kb).
max log size = 50

# Security mode. Most people will want user level security. See
# security_level.txt for details.
security = user
# Use password server option only with security = server
; password server = <NT-Server-Name>

# Password Level allows matching of _n_ characters of the password for
# all combinations of upper and lower case.
; password level = 8
; username level = 8

# You may wish to use password encryption. Please read
# ENCRYPTION.txt, Win95.txt and WinNT.txt in the Samba documentation.
# Do not enable this option unless you have read those documents
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd

# The following are needed to allow password changing from Windows to
# update the Linux system password also.
# NOTE: Use these with 'encrypt passwords' and 'smb passwd file' above.
# NOTE2: You do NOT need these to allow workstations to change only
# the encrypted SMB passwords. They allow the Unix password
# to be kept in sync with the SMB password.
unix password sync = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*UNIX*password* %n\n *ReType*new*UNIX*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*

# Unix users can map to different SMB User names
; username map = /etc/samba/smbusers

# Using the following line enables you to customise your configuration
# on a per machine basis. The %m gets replaced with the netbios name
# of the machine that is connecting
; include = /etc/samba/smb.conf.%m

# Most people will find that this option gives better performance.
# See speed.txt and the manual pages for details
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

# Configure Samba to use multiple interfaces
# If you have multiple network interfaces then you must list them
# here. See the man page for details.
; interfaces = 192.168.12.2/24 192.168.13.2/24

# Configure remote browse list synchronisation here
# request announcement to, or browse list sync from:
# a specific host or from / to a whole subnet (see below)
; remote browse sync = 192.168.3.25 192.168.5.255
# Cause this host to announce itself to local subnets here
; remote announce = 192.168.1.255 192.168.2.44

# Browser Control Options:
# set local master to no if you don't want Samba to become a master
# browser on your network. Otherwise the normal election rules apply
local master = yes

# OS Level determines the precedence of this server in master browser
# elections. The default value should be reasonable
os level = 65

# Domain Master specifies Samba to be the Domain Master Browser. This
# allows Samba to collate browse lists between subnets. Don't use this
# if you already have a Windows NT domain controller doing this job
domain master = yes

# Preferred Master causes Samba to force a local browser election on startup
# and gives it a slightly higher chance of winning the election
preferred master = yes

# Enable this if you want Samba to be a domain logon server for
# Windows95 workstations.
domain logons = yes

# if you enable domain logons then you may want a per-machine or
# per user logon script
# run a specific logon batch file per workstation (machine)
logon script = %m.bat
# run a specific logon batch file per username
logon script = %U.bat

# Where to store roving profiles (only for Win95 and WinNT)
# %L substitutes for this servers netbios name, %U is username
# You must uncomment the [Profiles] share below
; logon path = \\%L\Profiles\%U

# All NetBIOS names must be resolved to IP Addresses
# 'Name Resolve Order' allows the named resolution mechanism to be specified
# the default order is "host lmhosts wins bcast". "host" means use the unix
# system gethostbyname() function call that will use either /etc/hosts OR
# DNS or NIS depending on the settings of /etc/host.config, /etc/nsswitch.conf
# and the /etc/resolv.conf file. "host" therefore is system configuration
# dependant. This parameter is most often of use to prevent DNS lookups
# in order to resolve NetBIOS names to IP Addresses. Use with care!
# The example below excludes use of name resolution for machines that are NOT
# on the local network segment
# - OR - are not deliberately to be known via lmhosts or via WINS.
; name resolve order = wins lmhosts bcast

# Windows Internet Name Serving Support Section:
# WINS Support - Tells the NMBD component of Samba to enable it's WINS Server
wins support = yes

# WINS Server - Tells the NMBD components of Samba to be a WINS Client
# Note: Samba can be either a WINS Server, or a WINS Client, but NOT both
; wins server = w.x.y.z

# WINS Proxy - Tells Samba to answer name resolution queries on
# behalf of a non WINS capable client, for this to work there must be
# at least one WINS Server on the network. The default is NO.
; wins proxy = yes

# DNS Proxy - tells Samba whether or not to try to resolve NetBIOS names
# via DNS nslookups. The built-in default for versions 1.9.17 is yes,
# this has been changed in version 1.9.18 to no.
dns proxy = no

# Case Preservation can be handy - system default is _no_
# NOTE: These can be set on a per share basis
; preserve case = no
; short preserve case = no
# Default case is normally upper case for all DOS files
; default case = lower
# Be very careful with case sensitivity - it can break things!
; case sensitive = no

# add machine script = /usr/sbin/useradd -g machines -c Machine -d /dev/null -s /bin/false %u

#============================ Share Definitions ==============================
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
template shell = /bin/false
winbind use default domain = no
[homes]
comment = Home Directories
browseable = no
writable = yes

# Un-comment the following and create the netlogon directory for Domain Logons
[netlogon]
comment = Network Logon Service
path = /home/netlogon
writable = no
public = no


# Un-comment the following to provide a specific roving profile share
# the default is to use the user's home directory
;[Profiles]
; path = /home/profiles
; browseable = no
; guest ok = yes


# NOTE: If you have a BSD-style print system there is no need to
# specifically define each individual printer
[printers]
comment = All Printers
path = /var/spool/samba
browseable = no
# Set public = yes to allow user 'guest account' to print
guest ok = no
writable = no
printable = yes

# This one is useful for people to share files
;[tmp]
; comment = Temporary file space
; path = /tmp
; read only = no
; public = yes

# A publicly accessible directory, but read only, except for people in
# the "staff" group
;[public]
; comment = Public Stuff
; path = /home/samba
; public = yes
; read only = yes
; write list = @staff

New2Linux2 08-30-2006 06:03 PM

Same here
 
I'm having the exact same problem, except on the latest stable Debian (Sarge). I have even gone into my WinXP machine and disabled "Use simple file sharing" because of another error I was getting. After I rebooted, I'm back to "Access Denied". When prompted for UID/PWD to join the domain, I am entering "domainname\username" for the user. Here is my smb.conf:
Code:

# Global parameters
[global]
        workgroup = <DomainName>
        server string = %h (Samba %v)
        obey pam restrictions = Yes
        passdb backend = tdbsam
        pam password change = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
        username map = /etc/samba/smbusers
        unix password sync = Yes
        log level = 1
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        smb ports = 139
        name resolve order = host wins bcast
        time server = Yes
        add user script = /usr/sbin/useradd -m '%u'
        delete user script = /usr/sbin/userdel -r '%u'
        add group script = /usr/sbin/groupadd '%g'
        delete group script = /usr/sbin/groupdel '%g'
        add user to group script = /usr/sbin/usermod -G '%g' '%u'
        add machine script = /usr/sbin/useradd -s /bin/false -d /tmp '%u'
        shutdown script = /var/lib/samba/scripts/shutdown.sh
        abort shutdown script = /sbin/shutdown -c
        logon path = \\%L\profiles\%U
        logon drive = U:
        logon home = \\%L\%U
        domain logons = Yes
        preferred master = Yes
        wins support = Yes
        utmp = Yes
        panic action = /usr/share/samba/panic-action %d
        invalid users = root
        map acl inherit = Yes
        veto files = /*.eml/*.nws/*.{*}/
        veto oplock files = /*.doc/*.xls/*.mdb

[homes]
        comment = Home Directories
        username = %S
        read only = No
        create mask = 0700
        directory mask = 0700
        browseable = No

[netlogon]
        comment = Network Logon Service
        path = /var/lib/samba/netlogon
        guest ok = Yes
        locking = No
        share modes = No

[profiles]
        comment = Profile Share
        path = /var/lib/samba/profiles
        username = %S
        read only = No
        profile acls = Yes

# A couple of shared directories copied from previous file servers
# that are no longer in service
[Z]
        path = /fileserv
        username = %S
        read only = No

[X]
        path = /X
        username = %S
        read only = No


gv_rajasekhar 08-31-2006 01:40 AM

first try to locate the problem
eck /etc/log/samba/nmbd.log file
this give allthe details

most frequent problem is with wins.you need to allow the host."host allow=192.16.1."

if the problem persist try with option the wins support=no

linuxpng2 08-31-2006 10:00 AM

Quote:

Originally Posted by gv_rajasekhar
first try to locate the problem
eck /etc/log/samba/nmbd.log file
this give allthe details

Dunno if this helps, but I did a service smb restart this morning and this is what's in my nmbd.log file:
Code:

[2006/08/31 09:50:13, 0] nmbd/nmbd.c:terminate(56)
  Got SIGTERM: going down...
[2006/08/31 09:50:14, 0] nmbd/nmbd.c:main(669)
  Netbios nameserver version 3.0.10-1.4E.9 started.
  Copyright Andrew Tridgell and the Samba Team 1994-2004
[2006/08/31 09:50:14, 0] nmbd/nmbd_logonnames.c:add_logon_names(163)
  add_domain_logon_names:
  Attempting to become logon server for workgroup DMBACKUP on subnet 9.44.131.11
[2006/08/31 09:50:14, 0] nmbd/nmbd_logonnames.c:add_logon_names(163)
  add_domain_logon_names:
  Attempting to become logon server for workgroup DMBACKUP on subnet UNICAST_SUBNET
[2006/08/31 09:50:14, 0] nmbd/nmbd_become_dmb.c:become_domain_master_browser_wins(327)
  become_domain_master_browser_wins:
  Attempting to become domain master browser on workgroup DMBACKUP, subnet UNICAST_SUBNET.
[2006/08/31 09:50:14, 0] nmbd/nmbd_become_dmb.c:become_domain_master_browser_wins(341)
  become_domain_master_browser_wins: querying WINS server from IP 9.44.131.11 for domain master browser name DMBACKUP<1b> on workgroup DMBACKUP
[2006/08/31 09:50:14, 0] nmbd/nmbd_nameregister.c:register_name_response(130)
  register_name_response: WINS server at IP 9.44.131.11 rejected our name registration of DMBACKUP<00> IP 9.44.131.11 with error code 5.
[2006/08/31 09:50:14, 0] nmbd/nmbd_workgroupdb.c:fail_register(228)
  fail_register: Failed to register name DMBACKUP<00> on subnet UNICAST_SUBNET.
[2006/08/31 09:50:14, 0] nmbd/nmbd_namelistdb.c:standard_fail_register(283)
  standard_fail_register: Failed to register/refresh name DMBACKUP<00> on subnet UNICAST_SUBNET
[2006/08/31 09:50:14, 0] nmbd/nmbd_logonnames.c:become_logon_server_success(124)
  become_logon_server_success: Samba is now a logon server for workgroup DMBACKUP on subnet UNICAST_SUBNET
[2006/08/31 09:50:14, 0] nmbd/nmbd_become_dmb.c:become_domain_master_stage2(113)
  *****

  Samba server DMBACKUP is now a domain master browser for workgroup DMBACKUP on subnet UNICAST_SUBNET

  *****
[2006/08/31 09:50:14, 0] nmbd/nmbd_become_dmb.c:become_domain_master_browser_bcast(282)
  become_domain_master_browser_bcast:
  Attempting to become domain master browser on workgroup DMBACKUP on subnet 9.44.131.11
[2006/08/31 09:50:14, 0] nmbd/nmbd_become_dmb.c:become_domain_master_browser_bcast(295)
  become_domain_master_browser_bcast: querying subnet 9.44.131.11 for domain master browser on workgroup DMBACKUP

I tried disabling wins, still get 'access is denied'. And tried the host allow option... same error. :(

gv_rajasekhar 08-31-2006 12:41 PM

along with the nmbd log file, check the system log file which you r checking.make sure root has a samba password.i had similar problem with that .i will try to post smb.conf file. linux has great advantage of log files.use these things any application

blackraider 08-31-2006 01:43 PM

First off : Had you tried to add some users to Samba with smbpasswd?

Second : Had you opened Samba ports in your firewall/iptables (137-139 and 445)?

Trird : Had you allowed the Ip's of your network to connect in your firewall/iptables and configured NAT and masquerading (for extranet access)?

In my little experience the steps I'd follow to get a Samba domain running and up was:

* Install and configure Samba
* Add users to Samba with smbpasswd and machines and users with useradd
(users must exist in both Linux and Samba for properly running)
* Open Samba ports in my firewall
* Add IP's of my networked machines to my firewall
* Create user's home directories
* Create and config the shares


Well, that's all. I hope this helps.

linuxpng2 08-31-2006 04:51 PM

well, i turned off wins support and i'm now able to connect to the domain when logging in as root (again, this is after i've done the 'registry hack' that people have posted about). I've read on some sites that once you've logged in as root, it has 'authenicated' your machine and you should be able to log in with any other valid samba id.. first question, how do you 'log out' of root? i mean, i've already connected to the domain, rebootedm have the option of logging back into my machine using that domain.. does that mean i should be able to log into windows itself with any valid samba id? if so, i can log into windows with my personal samba id, but.. second question, now obviously my entire windows desktop is different (i assume, because it's like i'm logging in with a different id). is there something i can disable so it will still load my normal windows workspace? or, would this not happen if my windows id and my samba id were the same (because they are currently different).

thanks for all the help so far :)

New2Linux2 09-01-2006 06:46 PM

Quote:

Originally Posted by gv_rajasekhar
first try to locate the problem
eck /etc/log/samba/nmbd.log file
this give allthe details

most frequent problem is with wins.you need to allow the host."host allow=192.16.1."

if the problem persist try with option the wins support=no

I am still unable to join my domain. Sarge's nmbd.log (/var/log/samba/log.nmbd) has no errors in it. Nothing failed to load and it shows that the server is running as Master browser, Domain Master and WINS server without issue. Just to be on the safe side, I went ahead and disabled WINS, just to see. Unfortunately, that had no effect. Syslog (/var/log/syslog) also is devoid of errors/failures. The same goes for my smbd logfile (/var/log/samba/log.smbd).

When I tried the "host allow=..." option, and then ran testparm, I got "Unknown parameter encountered: 'host allow' Ignoring unknown parameter 'host allow'" so I have removed it. I have added a root password to samba with "smbpasswd -a root" along with several other usernames and machine accounts. All accounts were first created using useradd, and then added to Samba.

The server is inside our network and behind our firewall/router. I wouldn't think that I would need to open the Samba ports in my firewall simply because I do not want any samba traffic passing through the firewall. Am I mistaken in that?

All user's shares and home directories have been created with permissions assigned. Of course, I'm unable to test that fully because I'm unable to have a single system join the domain still. If it helps any, my smb.conf was created using the "How To" available on Samba.org's site (Chapter 3: Secure Office Networking). The initial smb.conf was renamed to smb.conf.master and all modifications that take place are made to that file. When I'm done, testparm tells me whether or not I misspelled anything. I then use "testparm /etc/samba/smb.conf.master > /etc/samba/smb.conf" to create the main config file. If I make any changes, I then follow up with "smbd restart" and "nmbd restart". What am I missing?

New2Linux2 09-01-2006 07:15 PM

Quote:

Originally Posted by linuxpng2
well, i turned off wins support and i'm now able to connect to the domain when logging in as root (again, this is after i've done the 'registry hack' that people have posted about).

Good for you. I hope to say the same soon.
Quote:

I've read on some sites that once you've logged in as root, it has 'authenicated' your machine and you should be able to log in with any other valid samba id..
This is technical inaccurate. You aren't really logging in as root. You are logged into your local machine as "localmachine\userA" when you ask to join the domain. Because the domain controller has a seperate list of users (domainuser\userA is a different user than localmachine\userA) it needs to know whether or not your machine has permission to become part of its domain. That is why you "Authenticate" to it with the domain admin (or root) username and password. Once it verifies that info, your machine becomes part of the domain and is given access to a new list of users: Domain Users.
Quote:

first question, how do you 'log out' of root? i mean, i've already connected to the domain, rebootedm have the option of logging back into my machine using that domain.. does that mean i should be able to log into windows itself with any valid samba id?
Rebooting logs you out automatically. When it comes time to log in to windows again, you can now login with any valid samba id (Domain User).
Quote:

if so, i can log into windows with my personal samba id, but.. second question, now obviously my entire windows desktop is different (i assume, because it's like i'm logging in with a different id).
CORRECT!!! You are logging in with a different id, one that your local computer has no history of.
Quote:

is there something i can disable so it will still load my normal windows workspace? or, would this not happen if my windows id and my samba id were the same (because they are currently different).

thanks for all the help so far :)
No. Even if your old windows (aka: localmachine) id and your new samba id were the same username, they would still be different because of the reasons outlined above. One is a domain member and the other is not. If you now browse the hard drive of your Windows computer to the Documents and Settings folder, you will see a folder for your old localmachine account and a folder for your new samba domain user account. This is just another indication that Windows sees both users as seperate entities. One thing you can do is export all of your old settings from your localmachine account to your new domain user account using the "Files and Settings Transfer Wizard" - <Start> -> All Programs -> Accessories -> System Tools -> Files and Settings Transfer Wizard. Let me know if you need help using that tool. It should be fairly self-explanatory.

Hopefully, one day I'll have some *nix answers too (other than RTFM).;)

New2Linux2 09-06-2006 05:00 PM

Update: Still unable to join domain
 
I added the "hosts allow = 127.0.0.1 10.1.1.0/24" line to my smb.conf and got a different error: "parameter incorrect". I modified that line to be "hosts allow = 127.0.0.1 10.1.1" and got the same error. I rebooted the server and now am getting "The network path was not found."

I really am lost here, so any help at all would be much appreciated. My log.nmbd is still showing that the server is running as the domain master browser and the local master browser. :confused:

zhizaki 09-06-2006 08:51 PM

If I remember correctly, you are supposed to have the machine accounts added too. Like a machine account for each workstation connecting to the server.

fotoguy 09-06-2006 09:22 PM

Quote:

Originally Posted by zhizaki
If I remember correctly, you are supposed to have the machine accounts added too. Like a machine account for each workstation connecting to the server.

You can add these machines accounts on the fly in your smb.conf files, It has been over a year now since I had a domain controller up and runing. Here is my old smb.conf so you can have a look at it.

Also make sure you don't have a firewall running at the time of testing your connection. Also check your /etc/hosts.deny file if it has an entry of ALL:ALL then you will need to place and entry in your /etc/hosts.allow file to allow your network to connect.

Code:

###########################################################################################################
#        Standard samba configuration
#
###########################################################################################################
[global]

        netbios name = mysamba
        workgroup = samba.ent

        server string = Samba Server

        encrypt passwords = yes
        unix password sync = yes
        #obey pam restrictions = yes

        time server = yes

        smb passwd file = /etc/samba/smbpasswd
        passwd chat = *New*password* %n\n *Please*retype*new*password* %n\n *password*successfully*updated*
        passwd program = /usr/bin/passwd %u

        socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=8192 SO_SNDBUF=8192
       
        allow hosts = 192.168.1., 127., samba.ent
        hosts deny = ALL
        security = user
        max log size = 50
        hide unreadable = yes
        #veto files = /*mail/*news/*pcnfs/*pop/*rwho/*samba/*uucp/*uucppublic/
        map to guest = bad user
        invalid users = root @wheel
        dns proxy = no
        printcap name = lpstat
        load printers = yes
        printing = cups
        printer admin = @adm       
        remote announce = 192.168.1.255
        lpq command = lpq -P %p
        lprm command = cancel %p-%j
        name resolve order = lmhosts host bcast
        write cache size = 262144

###########################################################################################################
#        Domain controller global setup configuration
#
###########################################################################################################

        local master = yes
        preferred master = yes
        domain master = yes
        domain logons = yes
        os level = 65

        logon path = \\%L\profiles\%U
        logon drive = H:
        logon script = netlogon.bat
        logon home = \\%L\%U

        add machine script = /usr/sbin/useradd -d /dev/null -g 205 /bin/false -M %u
        add user script = /usr/sbin/useradd -m %u
        delete user script = /usr/sbin/userdel -r %u
        add group script = /usr/sbin/groupadd %g
        delete group script = /usr/sbin/groupdel %g
        add user to group script = /usr/sbin/usermod -G %g %u


        #add user script = /usr/local/sbin/smb-add-user %u
        #add group script = /usr/local/sbin/smb-add-group %g
        #add machine script = /usr/local/sbin/smb-add-machine %u
        #add user to group script = /usr/local/sbin/smb-add-user-group %u %g
        #delete user script = /usr/local/sbin/smb-rm-user %u
        #delete user from group script = /usr/local/sbin/smb-rm-user-group %u %g
        #delete group script = /usr/local/sbin/smb-rm-group %g
       

        #domain admin group = root @wheel
        #domain guest group = nobody @guest

        log file = /var/log/samba/log.%m

###########################################################################################################
##==========Share Configuration=====================##

[netlogon]
        comment = Netlogon Directory
        path = /home/netlogon
        browseable = no
        writeable = no
        guest ok = yes
       
[profiles]
        comment = Users Profiles
        path = /home/profiles
        writeable = yes
        browseable = no

[homes]
          comment = Users Home Directories
          browseable = no
          writable = yes
       
[share]
        comment = Public Share Folder
        browseable = yes
        writeable = yes
        public = yes
        guest ok = yes
        #guest account = nobody
        guest only = no       
        force create mask = 0766
        path = /home/share
        force directory mode = 0755       
                                                               
[printers]
          comment = All Printers
          browseable = no
          path = /var/spool/samba
          printable = yes
          public = yes
          writable = no
          #create mode = 0750
        use client driver = yes
        guest ok = yes

[print$]
        path = /home/printers
        browseable = yes
        read only = yes
        write list = @adm root

[pdf-gen]
        path = /var/tmp
        guest ok = No
        printable = Yes
        comment = PDF Generator (only valid users)
        #print command = /usr/share/samba/scripts/print-pdf file path win_path recipient IP &
        print command = /usr/share/samba/scripts/print-pdf %s ~%u \\\\\\\\%L\\\\%u %m %I &


New2Linux2 09-12-2006 01:31 PM

I have those lines in my smb.conf (posted above) for creating machine accounts on the fly when the machine tries to join the domain. Just for GP's I went ahead and created an account in samba for a machine, but I'm still getting errors. In XP, when I try to join the domain, I get the pop up asking for credentials, then (about 30 seconds later) I get the error "The network path was not found" regardless of what I enter for credentials. This is even more confusing for me. If I try to join a non-existant domain (foobar.org) I don't even get the chance to authenticate. This tells me that XP is seeing the domain controller and is being asked to authenticate, inidicating two-way communiation between them. It's just not authenticating. What would cause this?

Once again, here is my info:
  • All user accounts have been created in Debian (one for each domain user)
  • Matching user accounts were then created in Samba (one for each domain user)
  • Domain groups were created and users sorted into their groups
  • Domain shares have been created with permissions assigned by group
  • User shares have been created with permissions assigned by user
  • Machine accounts are supposed to be created "on the fly" when the machine joins the domain
  • I have edited the registry and security settings in XP from suggestions in other posts here on LQ concerning this problem
  • Every change I make is followed by a restart of both smbd and nmbd
smb.conf
Code:

# Global parameters
[global]
        workgroup = XCOR.COM
        server string = %h (Samba %v)
        passdb backend = tdbsam
        pam password change = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\sUNIX\spassword:* %n\n *Retype\snew\sUNIX\spassword:* %n\n .
        username map = /etc/samba/smbusers
        unix password sync = Yes
        log level = 1
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 1000
        smb ports = 139
        name resolve order = host wins bcast
        time server = Yes
        add user script = /usr/sbin/useradd -m '%u'
        delete user script = /usr/sbin/userdel -r '%u'
        add group script = /usr/sbin/groupadd '%g'
        delete group script = /usr/sbin/groupdel '%g'
        add user to group script = /usr/sbin/usermod -G '%g' '%u'
        add machine script = /usr/sbin/useradd -s /bin/false -d /tmp '%u'
        shutdown script = /var/lib/samba/scripts/shutdown.sh
        abort shutdown script = /sbin/shutdown -c
        logon path = \\%L\profiles\%U
        logon drive = U:
        logon home = \\%L\%U
        domain logons = Yes
        os level = 65
        preferred master = Yes
        wins support = Yes
        utmp = Yes
        panic action = /usr/share/samba/panic-action %d
        invalid users = root
        hosts allow = 127.0.0.1, 10.1.1
        map acl inherit = Yes
        veto files = /*.eml/*.nws/*.{*}/
        veto oplock files = /*.doc/*.xls/*.mdb
        security = user
        smb passwd file = /etc/samba/smbasswd

[homes]
        comment = Home Directories
        username = %S
        read only = No
        create mask = 0700
        directory mask = 0700
        browseable = No

[netlogon]
        comment = Network Logon Service
        path = /var/lib/samba/netlogon
        guest ok = Yes
        locking = No
        share modes = No

[profiles]
        comment = Profile Share
        path = /var/lib/samba/profiles
        username = %S
        read only = No
        profile acls = Yes

[Z]
        path = /fileserv
        username = %S
        read only = No

[X]
        path = /X
        username = %S
        read only = No

FYI: I copied fotoguy's smb.conf into mine, changed the domain name and path information to match my setup and restarted samba. Same problems.

fotoguy 09-12-2006 06:43 PM

Quote:

Originally Posted by New2Linux2
"The network path was not found"

OK I think I remember getting the same or similar error once before when I was trying to get a XP machine to join samba. If I remember correctly on the XP machine try changing the dns settings, set dns1 to the address of the samba server before trying to add it to the samba domain controller, I think you may need to restart the XP machine first before trying to add it.

New2Linux2 09-12-2006 08:02 PM

Quote:

Originally Posted by fotoguy
If I remember correctly on the XP machine try changing the dns settings, set dns1 to the address of the samba server before trying to add it to the samba domain controller, I think you may need to restart the XP machine first before trying to add it.

That makes sense. Unfortunately, no effect. I rebooted XP, changed dns1 to my DC's IP (running bind9 for DNS), rebooted again and still got the "network path not found" error.


All times are GMT -5. The time now is 04:28 AM.