LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 05-10-2013, 10:52 AM   #1
zyxuvius
LQ Newbie
 
Registered: Jul 2009
Posts: 3

Rep: Reputation: 0
Connecting to wireless network in Slackware 14


Hello all,

I am super excited to be using Slackware. I have been using Ubuntu for the past five years or so, but became tired of Unity and some of the other clutter that has been cropping up in the past few months, so I decided to try some other things.

I have installed Linux Mint and Slackware on my system. So far, everything in Mint is working just fine. I can connect to wired connections and to my university's WPA2 system just fine.

However, I have no such luck in Slackware. The wired connection seems to work ok (not sure if it worked out of the box, or if I had to do a little troubleshooting). However, I cannot seem to get Slackware to connect to a wireless network to save the life of me.

Here is what I have accomplished so far:

I have messed around a bit with wpa_supplicant

I have *tried* installing wicd, however, I can't seem to get the dependencies to work out. python setup.py install always gives me the error that it cannot find pybabel, even though I have run easy_install Babel, and that has worked out fine. (Note, locate pybabel returns nothing).

When I open up KDE using startx, I can click on the networking widget at the bottom-right. It successfully scans and finds the familiar networks that Mint locates out of the box. However, when I supply my credentials for the WPA2 Leap dialogue, it opens up KDE Wallet Services and asks for my password. I happily give it the password, and it churns away saying that it is "configuring interface" and then prompts me several seconds/minutes later for the password again.

Discouraged with a GUI approach, I returned back to the terminal and attempted to run ~/Downloads/wicd-1.7.2.4/scripts/wicd-client (and all of the other scripts in that directory). After cp all of the *.py files to where they need to go, I consistently get the same error:

Traceback (most recent calls last):
File "/usr/share/wicd/gtk/wicd-cleint.py", line 61 in <module>
from wicd import wpath
ImportError: No module named wicd

I have no clue how to install wicd. Any python package I have tried to install using easy_install or python setup.py install has seemed to install well, but afterwards locate (even after updatedb) has not been able to find these python files on the system. This is especially frustrating because I think wicd needs pybabel in order to install correctly.

What has worked for other users? I feel that I need someone to explain why I have trouble with wicd.
 
Old 05-10-2013, 11:15 AM   #2
JWJones
Member
 
Registered: Jun 2009
Location: Cascadia
Distribution: Slackware, LinuxBBQ, OpenBSD, Mac OSX
Posts: 723

Rep: Reputation: 187Reputation: 187
Quote:
Originally Posted by zyxuvius View Post
When I open up KDE using startx, I can click on the networking widget at the bottom-right. It successfully scans and finds the familiar networks that Mint locates out of the box. However, when I supply my credentials for the WPA2 Leap dialogue, it opens up KDE Wallet Services and asks for my password. I happily give it the password, and it churns away saying that it is "configuring interface" and then prompts me several seconds/minutes later for the password again.
Just to be clear, is the networking widget at the bottom right NetworkManager, or wicd? You should be able to find out by right-clicking on it, and choosing "About" or such. Either one will work, but you need to know which one is already installed, to configure properly.

Also, the KDEWallet password is different than your WPA password. It can be whatever you want, but it's not asking you for your wireless network password, here.

If NetworkManager is installed, configure the GUI/applet to start up at login by:

Code:
# chmod +x /etc/rc.d/rc.networkmanager
If wicd is installed:

Code:
# chmod +x /etc/rc.d/rc.wicd
 
Old 05-15-2013, 03:37 AM   #3
mrapathy
Member
 
Registered: Nov 2005
Distribution: debian/slackware
Posts: 90

Rep: Reputation: 17
I went with networkmanager and got things running for myself. I didnt use KDEWallet when it opened up.
networkmanager in kde has a setting to allow other users than root configure network connection.
 
Old 05-24-2013, 03:33 PM   #4
zyxuvius
LQ Newbie
 
Registered: Jul 2009
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks guys for your responses.

Unfortunately, my bootloader crashed and I was unable to recover the previous partitions.

I probably won't get back into Slackware for another couple months.

I'll probably post any progress I make in a few months time in this thread.

Sorry for the long time in between responses.
 
Old 05-27-2013, 08:30 AM   #5
eklavya
Member
 
Registered: Mar 2013
Posts: 590

Rep: Reputation: 131Reputation: 131
Now I think you will need this.
http://www.fprimex.com/linux/slackware/install.html
 
  


Reply

Tags
wicd, wireless, wpa2, wpa_supplicant


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Ubuntu 11.10 Network Manager issues connecting to wireless network after restart depam Linux - Software 2 01-22-2012 09:39 PM
connecting to wireless network veeravicky Linux - Networking 1 03-19-2010 11:08 AM
Connecting PC to Wireless Network cochetopa Linux - Newbie 3 12-28-2008 11:37 AM
Slackware: Connecting to wireless network flintmecha Linux - Wireless Networking 2 06-30-2008 12:10 AM
connecting to wireless network gibney Linux - Newbie 1 06-18-2007 05:00 AM


All times are GMT -5. The time now is 12:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration