LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Connecting to wireless network in Slackware 14 (http://www.linuxquestions.org/questions/linux-networking-3/connecting-to-wireless-network-in-slackware-14-a-4175461439/)

zyxuvius 05-10-2013 09:52 AM

Connecting to wireless network in Slackware 14
 
Hello all,

I am super excited to be using Slackware. I have been using Ubuntu for the past five years or so, but became tired of Unity and some of the other clutter that has been cropping up in the past few months, so I decided to try some other things.

I have installed Linux Mint and Slackware on my system. So far, everything in Mint is working just fine. I can connect to wired connections and to my university's WPA2 system just fine.

However, I have no such luck in Slackware. The wired connection seems to work ok (not sure if it worked out of the box, or if I had to do a little troubleshooting). However, I cannot seem to get Slackware to connect to a wireless network to save the life of me.

Here is what I have accomplished so far:

I have messed around a bit with wpa_supplicant

I have *tried* installing wicd, however, I can't seem to get the dependencies to work out. python setup.py install always gives me the error that it cannot find pybabel, even though I have run easy_install Babel, and that has worked out fine. (Note, locate pybabel returns nothing).

When I open up KDE using startx, I can click on the networking widget at the bottom-right. It successfully scans and finds the familiar networks that Mint locates out of the box. However, when I supply my credentials for the WPA2 Leap dialogue, it opens up KDE Wallet Services and asks for my password. I happily give it the password, and it churns away saying that it is "configuring interface" and then prompts me several seconds/minutes later for the password again.

Discouraged with a GUI approach, I returned back to the terminal and attempted to run ~/Downloads/wicd-1.7.2.4/scripts/wicd-client (and all of the other scripts in that directory). After cp all of the *.py files to where they need to go, I consistently get the same error:

Traceback (most recent calls last):
File "/usr/share/wicd/gtk/wicd-cleint.py", line 61 in <module>
from wicd import wpath
ImportError: No module named wicd

I have no clue how to install wicd. Any python package I have tried to install using easy_install or python setup.py install has seemed to install well, but afterwards locate (even after updatedb) has not been able to find these python files on the system. This is especially frustrating because I think wicd needs pybabel in order to install correctly.

What has worked for other users? I feel that I need someone to explain why I have trouble with wicd.

JWJones 05-10-2013 10:15 AM

Quote:

Originally Posted by zyxuvius (Post 4948575)
When I open up KDE using startx, I can click on the networking widget at the bottom-right. It successfully scans and finds the familiar networks that Mint locates out of the box. However, when I supply my credentials for the WPA2 Leap dialogue, it opens up KDE Wallet Services and asks for my password. I happily give it the password, and it churns away saying that it is "configuring interface" and then prompts me several seconds/minutes later for the password again.

Just to be clear, is the networking widget at the bottom right NetworkManager, or wicd? You should be able to find out by right-clicking on it, and choosing "About" or such. Either one will work, but you need to know which one is already installed, to configure properly.

Also, the KDEWallet password is different than your WPA password. It can be whatever you want, but it's not asking you for your wireless network password, here.

If NetworkManager is installed, configure the GUI/applet to start up at login by:

Code:

# chmod +x /etc/rc.d/rc.networkmanager
If wicd is installed:

Code:

# chmod +x /etc/rc.d/rc.wicd

mrapathy 05-15-2013 02:37 AM

I went with networkmanager and got things running for myself. I didnt use KDEWallet when it opened up.
networkmanager in kde has a setting to allow other users than root configure network connection.

zyxuvius 05-24-2013 02:33 PM

Thanks guys for your responses.

Unfortunately, my bootloader crashed and I was unable to recover the previous partitions.

I probably won't get back into Slackware for another couple months.

I'll probably post any progress I make in a few months time in this thread.

Sorry for the long time in between responses.

eklavya 05-27-2013 07:30 AM

Now I think you will need this.
http://www.fprimex.com/linux/slackware/install.html


All times are GMT -5. The time now is 09:38 AM.