LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-22-2006, 01:32 PM   #1
Cheechi
Member
 
Registered: Jun 2004
Location: Azeroth
Distribution: SuSE since 7.0
Posts: 73

Rep: Reputation: 15
connecting to Samba with Windows XP


I wish to share /home/cheechi/folder to my network. i have configured Samba and SuSEFirewall as well as i can; i use a hardware firewall on my router (a little standalone one, you know the kind) so i have pretty much every service allowed for my SuSE box on the internal network - i like to play with stuff internally before i decide if it's ready for the web. Samba is an allowed service - double checked. windows XP has no firewall running, they're on the same router so there's nothing to come between them. when i try to map /folder as a network drive it looks like this

\\192.168.2.3\cheechi\folder
user
pass

when i try to connect, an error comes up telling me that my password is incorrect. this is the same for the one user on the SuSE box as well as for root. i have a wireless router that is a client of the first, and an iBook that comes up with the same error. all computers are in WORKGROUP. are there any special rules i don't know about when mounting a smb drive? i can share windows folders to my linux box without a problem - the setup for seeing a network share works great in linux.


any help would be greatly appreciated, i hate having to VNC into my linux box to transfer stuff to and from it.
 
Old 01-22-2006, 02:30 PM   #2
snowtigger
Member
 
Registered: Mar 2005
Location: england
Distribution: slackware, win2k
Posts: 364

Rep: Reputation: 34
Did you setup the users and password for samba.
With linux (and any *nix) you have the file 'passwd' in '/etc' this is where the system stores its user and password info. But there is also a file for samba (can't remember where it is) which is where samba stores it's info on users and passwords. You have already setup the account in the linux file, but by the sounds of things not in the samba file. Go to http://us2.samba.org/samba/ and read the documents there to find out how to do it.

 
Old 01-23-2006, 01:38 PM   #3
Dmjmusser
Member
 
Registered: Nov 2005
Location: Detroit, Michigan -- USA
Distribution: Fedora Core
Posts: 90

Rep: Reputation: 15
The default file (on FC4, anyways), for storing Samba passwords is /etc/samba/smbpasswd. This file stores Samba usernames and passwords, and is written to using the smbpasswd command.

The docs provide more specific help regarding what syntax and option to use with that command. Check 'em out and post here if you need more help.

Note also that you'll probably need to add the Samba user to the
valid users = entry for that share. Creating Samba usernames and passwords does not automatically grant a user access to your share(s).

~Myles
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Connecting Windows XP client to Samba server srini2001 Linux - Networking 5 03-15-2006 09:25 AM
Samba connecting to windows share gfem Linux - Software 4 12-09-2005 12:16 PM
SAMBA problem - connecting to linux from windows jdklein1975 Linux - Newbie 13 05-23-2003 12:02 AM
Connecting to Samba Server from Windows explorer Linux - Networking 7 03-16-2003 05:26 PM
connecting to windows workgroup using samba? linoob Linux - Newbie 7 10-23-2002 08:17 PM


All times are GMT -5. The time now is 01:00 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration