LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 03-19-2004, 01:38 PM   #1
vasanthraghavan
Member
 
Registered: Mar 2004
Location: USA
Distribution: Redhat Linux 9
Posts: 98

Rep: Reputation: 15
connecting to internet via dlink router


Hi,
My computer runs Redhat Linux 9. it is connected to D-link router DI-614+, which in turn is connected to a cable modem.
Could someone in this forum please explain the steps needed for me to connect to the internet?
(Other computers connected to the router are able to get internet connections. But these run Microsoft Operating systems.)
Thank you.
 
Old 03-19-2004, 03:17 PM   #2
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
type 'redhat-config-network'

and select DCHP/BOOTP.

also type 'setup' go to firewall configuration, select no firewall.
reboot.

If this doesnt help, then its your router that is blocking requests/transfers .

Sorry that Linux isnt an unsecure point and click client OS.
 
Old 03-19-2004, 04:41 PM   #3
vasanthraghavan
Member
 
Registered: Mar 2004
Location: USA
Distribution: Redhat Linux 9
Posts: 98

Original Poster
Rep: Reputation: 15
Thank you, but this did not seem to work.
 
Old 03-19-2004, 06:58 PM   #4
Iridesce
Member
 
Registered: Jun 2003
Location: Olympia, WA
Distribution: Mepis 3.3 Rocks / Mandrake 10.0 Official / Windows 98SE / Windows XP
Posts: 48

Rep: Reputation: 15
Greetings,

Are other computers set up as static or dchp ???

Check your router ( 192.168.0.1 ) first and see if there are any access control issues.

My initial guess is that you need to set up the linux box to a static address
Run ' ifconfig ' in a terminal to see the address you are using, then enable that address in the router

Whenever you ask for help here, be sure to specify the Linux distribution you are using, the type of hardware you have ( for networking - motherboard type, network card, type of internet connection { cable, DSL, dial-up }, static or DHCP connection, etc ) so that the responder can have some idea where to begin with your system

At any rate, do post your system info and people will be a little more apt to help

Enjoy ...
 
Old 03-20-2004, 06:44 AM   #5
vasanthraghavan
Member
 
Registered: Mar 2004
Location: USA
Distribution: Redhat Linux 9
Posts: 98

Original Poster
Rep: Reputation: 15
Hi,
Thank you for the information. Here are my inputs:
The other computers are set up as DHCPs.
The type of internet connection is cable modem.(as mentioned in the body of my first post)
The type of Linux distribution is Redhat Linux 9.(also mentioned in my first post)

Your question:
"Check your router ( 192.168.0.1 ) first and see if there are any access control issues."

in 192.168.0.1 page, after logging into the router, how can this be checked ?

Kindly let me know, if more details are needed, as my experience here is as a newbie only.
Thank you.
 
Old 03-21-2004, 01:29 AM   #6
Iridesce
Member
 
Registered: Jun 2003
Location: Olympia, WA
Distribution: Mepis 3.3 Rocks / Mandrake 10.0 Official / Windows 98SE / Windows XP
Posts: 48

Rep: Reputation: 15
Only have a couple of minutes

Next step is to understand the router

Start here http://support.dlink.com/support and enter your model number - it will take you to a page that has the manual on it. Read the manual to find out how to access the browser based control center.
 
Old 03-21-2004, 03:10 AM   #7
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
There should be only one special step to using that router. When you setup the NIC card you should make the router IP your default gateway. You can select static or dhcp IP, the router most likely supports both. Check in the router because normally they will reserve a block of IP's for dhcp.

Post the output of these two commands:
ifconfig
route
 
Old 03-21-2004, 09:35 AM   #8
vasanthraghavan
Member
 
Registered: Mar 2004
Location: USA
Distribution: Redhat Linux 9
Posts: 98

Original Poster
Rep: Reputation: 15
Here is the output of my "ifconfig" command:

lo Link encap:Local loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:393 errors:0 dropped:0 overruns:0 frame:0
TX packets:393 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:29366 (25.7 kb) tx bytes:26366 (25.7 kb)


Here is the output of my "route" command:
kernel IP routing table:
Destination Gateway Genmask flags Metric Ref Use Iface
169.254.0.0 * 255.255.0.0 U 0 0 0 lo
127.0.0.0 * 255.0.0.0 U 0 0 0 l o

As these two lines had problems in tabbing, here is the same info in a different format:

firat line:
Destination
169.254.0.0

Gateway
*

Genmask
255.255.0.0

flags
U

Metric
0

Ref
0

Use
0

Iface
lo

second line:

Destination
127.0.0.0

Gateway
*

Genmask
255.0.0.0

flags
U

Metric
0

Ref
0

Use
0

Iface
lo


Thank you.

Last edited by vasanthraghavan; 03-21-2004 at 09:42 AM.
 
Old 03-21-2004, 10:14 AM   #9
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
Your NIC card doesn't seem to be setup at all.
Try this:
service network restart
You should get a message about shutting down the network, and another message about starting the network. You should see a message about starting interface eth0 and a green [ OK ]
Then try the two commands again.
ifconfig
route
If you get any error messages post them here. Also post the contents of these two files:
/etc/sysconfig/network
/etc/sysconfig/network-scripts/ifcfg.eth0

<edit> This is the correct file.
/etc/sysconfig/network-scripts/ifcfg-eth0

Last edited by /bin/bash; 03-21-2004 at 10:28 AM.
 
Old 03-21-2004, 11:29 AM   #10
vasanthraghavan
Member
 
Registered: Mar 2004
Location: USA
Distribution: Redhat Linux 9
Posts: 98

Original Poster
Rep: Reputation: 15
isuuing "service network restart" gave me the following lines:
Shutting down loopback interface: [OK]
Setting network parameters: [OK]
Bringing up network parameters: [OK]
(No other message about starting interface eth0.)

ifconfig and route commands gave the same output, except the numbers in TX and RX lines:
RX packets:1229
TX packets:1229

RX bytes:83522 (81.5 kb)
TX bytes:83522 (81.5 kb)

The contents of /etc/sysconfig/network file:

NETWORKING=yes
HOSTNAME=Vasanth
GATEWAY=192.168.0.1
GATEWAYDEV=""
FORWARD_IPV4="no"

There was no file with this name at all!:
/etc/sysconfig/network-scripts/ifcfg-eth0

Thank you again.
 
Old 03-21-2004, 03:56 PM   #11
camelrider
Member
 
Registered: Apr 2003
Location: Juneau, Alaska
Posts: 244

Rep: Reputation: 31
Tru (as root) ifup eth0. Then run ifconfig again.
 
Old 03-21-2004, 05:07 PM   #12
/bin/bash
Senior Member
 
Registered: Jul 2003
Location: Indiana
Distribution: Mandrake Slackware-current QNX4.25
Posts: 1,802

Rep: Reputation: 46
Try this as as /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=dhcp
ONBOOT=yes

And try this for /etc/sysconfig/network
NETWORKING=yes
HOSTNAME=Vasanth
GATEWAY=192.168.0.1
GATEWAYDEV="eth0"
FORWARD_IPV4="no"




Then run service network restart

Those 2 files are key to setting up your network. Any time you modify one just restart the network to see if the changes worked. There should be some GUI tool you could use, but I don't know what that would be in RedHat.

If the above doesn't work you could try this as /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.0.2
NETMASK=255.255.255.0
NETWORK=192.168.0.0
BROADCAST=192.168.0.255
ONBOOT=yes
 
Old 03-22-2004, 12:55 AM   #13
Iridesce
Member
 
Registered: Jun 2003
Location: Olympia, WA
Distribution: Mepis 3.3 Rocks / Mandrake 10.0 Official / Windows 98SE / Windows XP
Posts: 48

Rep: Reputation: 15
Thanks for the work /b/b
 
Old 03-22-2004, 08:50 AM   #14
vasanthraghavan
Member
 
Registered: Mar 2004
Location: USA
Distribution: Redhat Linux 9
Posts: 98

Original Poster
Rep: Reputation: 15
Thank you all for replying and helping me out. After my last email, my system was reinstalled with Redhat Linux 9. This time with DHCP. now it connects to the internet.
Once again, my thanks for this forum and members, for very helpful and timely replies.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
connecting to the internet in Mandrake/Mandriva 10 through an adsl router serverjunkie Linux - Networking 6 08-16-2005 05:25 PM
problems connecting to router/internet xuloChavez Linux - Newbie 1 04-26-2005 06:36 PM
Connecting to Internet using Router oacikgoz Debian 1 10-04-2004 05:02 PM
mandrake 9.2 cannot get on internet using pppoe internent connection and dlink router shedrik Linux - Networking 0 03-28-2004 01:36 AM
Mandrake 9.1 Connecting to Internet Through Router Chryzmo Linux - Networking 2 01-20-2004 09:20 PM


All times are GMT -5. The time now is 02:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration