LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Connected, but can't see router, internet (http://www.linuxquestions.org/questions/linux-networking-3/connected-but-cant-see-router-internet-218180/)

dudboi 08-16-2004 05:03 AM

Connected, but can't see router, internet
 
Basically, I have a fedora core 2 connected via an integrated intel NIC to my Linksys befsr41 router. It used to work on Mandrake. I've already disabled IPv6 and uninstalled iptables. Pinging anything except for localhost is useless. Tried DHCP and it doesnt work. Tried static ip with dhcpc and nutthin.

Im providing the following information based on questions asked regarding similar situations, but have found the solutions to not have worked for me. I've been brooding over this issue for 2 whole days already. Please assist, thanks in advance.

mii-tool -v:
Code:

  product info: vendor 00:aa:00, model 51 rev 0
  basic mode:  autonegotiation enabled
  basic status: autonegotiation complete, link ok
  capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control
  link partner: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD

lsmod:
Code:

Module                  Size  Used by
snd_mixer_oss          13824  1
snd_intel8x0          26280  1
snd_ac97_codec        50436  1 snd_intel8x0
snd_pcm                68872  1 snd_intel8x0
snd_timer              17156  1 snd_pcm
snd_page_alloc          7940  2 snd_intel8x0,snd_pcm
gameport                3328  1 snd_intel8x0
snd_mpu401_uart        4864  1 snd_intel8x0
snd_rawmidi            17184  1 snd_mpu401_uart
snd_seq_device          6152  1 snd_rawmidi
snd                    38372  8 snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              6112  2 snd
autofs4                10624  0
e100                  25348  0
mii                    3584  1 e100
floppy                47440  0
sg                    27552  0
scsi_mod              91344  1 sg
microcode              4768  0
dm_mod                33184  0
joydev                  6976  0
uhci_hcd              23708  0
button                  4504  0
battery                6924  0
asus_acpi              8472  0
ac                      3340  0
ext3                  102376  6
jbd                    40216  1 ext3

/etc/sysconfig/network-scripts/ifcfg-eth0:
Code:

IPV6INIT=no
ONBOOT=yes
USERCTL=no
GATEWAY=192.168.1.1
TYPE=Ethernet
DEVICE=eth0
HWADDR=xx:xx:xx:xx:xx:xx
BOOTPROTO=static
NETMASK=255.255.255.0
IPADDR=192.168.1.100

/etc/sysconfig/network
Code:

NETWORKING=yes
HOSTNAME=chaos.co.nr
FORWARD_IPV4=yes
GATEWAYDEV=0
GATEWAY=192.168.1.1

ifconfig -a:
Code:

eth0      Link encap:Ethernet  HWaddr xx:xx:xx:xx:xx:xx
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
 
lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:1291 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1291 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1255746 (1.1 Mb)  TX bytes:1255746 (1.1 Mb)

route:
Code:

Kernel IP routing table
Destination    Gateway        Genmask        Flags Metric Ref    Use Iface
192.168.1.0    *              255.255.255.0  U    0      0        0 eth0
169.254.0.0    *              255.255.0.0    U    0      0        0 eth0
127.0.0.0      *              255.0.0.0      U    0      0        0 lo


ppuru 08-16-2004 06:00 AM

Does your system's IP match the subnet the LinkSys Router's LAN port is on?

arno 08-16-2004 06:47 AM

I read something about problem with auto negotiation

add this to /etc/modules.conf
options e100 Duplex=full Speed=100 FlowControl=3

dudboi 08-17-2004 02:12 AM

Quote:

Does your system's IP match the subnet the LinkSys Router's LAN port is on?
Yes, 255.255.255.0

Quote:

I read something about problem with auto negotiation

add this to /etc/modules.conf
options e100 Duplex=full Speed=100 FlowControl=3
I presume /etc/modprobe.conf, because dont have a modules.conf
When I do that, it doesn't even recognise the presence of the card and doesn't load the module at all.

dudboi 08-17-2004 03:02 AM

I figured it could be my NIC so i added a linksys pci one and it works. Thanks for all the help! Lousy intel...


All times are GMT -5. The time now is 02:12 PM.