LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-07-2008, 01:21 PM   #1
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,568
Blog Entries: 1

Rep: Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026
connect to smb share on NAS


I've got a NAS drive which has an ftp and samba server.
There's not much to configure when I enter the admin page of my NAS. I specified some folders as smb shares on it.

When I'm trying to connect to the share I get an error

Code:
[xtd8865@localhost ~]$ smbclient -L 192.168.1.102
Enter xtd8865's password:
Domain=[ȇ] OS=[] Server=[�]
Server requested LANMAN password (share-level security) but 'client lanman auth' is disabled
tree connect failed: SUCCESS - 0
Then I tried
Code:
[xtd8865@localhost ~]$ findsmb

                                *=DMB
                                +=LMB
IP ADDR         NETBIOS NAME     WORKGROUP/OS/VERSION
---------------------------------------------------------------------
[xtd8865@localhost ~]$
Does it seem that no samba-share is available?

As I said there's not much to configure on the NAS SMB server. There's a tab 'smb server'. There are only 2 things there - a folder list and a sharing list so I added 2 of main NAS folders to the sharing list and that's it.


any hints
thanks
 
Old 07-08-2008, 10:19 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Do you know what type of share authentication is being used? Choices are Windows for Workgroups, NT Lan Manager, and Active Directory. Hopefully such as simple configuration would use W4WG share level security.

If that is the case then does your NAS provide a way to associate a password with any/all shares or overall access to the NAS? If it does then set some password. Any password will do.

You are using SMB utilities that I've never heard of much less ever used. Your NAS almost certainly has an IP address. Try mounting a share to a mount point on your computer.
Code:
mkdir /mnt/nas.public
mount -t cifs //192.168.1.5/public /mnt/nas.public -o password=<password>
If your NAS has a user account then add that to the mount command as follows:
Code:
mount -t cifs //192.168.1.5/public /mnt/nas.public -o username=<username>,password=<password>
If that works but your normal users cannot access the share then add the uid and gid parameters to the mount command as follows:
Code:
mount -t cifs //192.168.1.5/public /mnt/nas.public -o username=<username>,password=<password>,uid=1000,gid=100
 
Old 07-09-2008, 04:09 PM   #3
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,568
Blog Entries: 1

Original Poster
Rep: Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026Reputation: 1026
thanks for your reply

It uses windows workgroup. I got a notebook with XP to check it and the only thing I had to do is to specify the workgroup and it connected without any problems.
There are 2 passwords on my NAS. One is the admin password to change its settings through its website, the other one
I set on the samba folder. The file structure of my NAS is as follows:
/data
/public

When I put some other password I got 'permission denied', however when I put the smb folder password:

Code:
[root@localhost xtd8865]# mount -t cifs //192.168.1.102/data /mnt/nas -o password=blahblahblah
mount error 20 = Not a directory
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

[root@localhost xtd8865]# mount -t cifs //192.168.1.102/data/ /mnt/nas -o password=blahblah
mount error 20 = Not a directory
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
The other thing is that I have not modified any smb.conf file as I assume it needs modifying only in case of configuring a smb server not a client (am I right?)

It doesn't have any samba user, the only user I had to set is the admin user to access its web control panel. I tried the command including the user but the outcome it exactly the same ie. not a directory.

Apart from specifying a workgroup and smb shared folders, there's really nothing more to configure on my NAS

thanks
 
Old 07-30-2008, 11:09 AM   #4
navigat0
LQ Newbie
 
Registered: Jul 2008
Posts: 5

Rep: Reputation: 0
Issues with CIFS on CentOS 5.2 (but not 5.0)

I have been installing CentOS 5 for many months now. I have been adding the u/mount.cifs(v1.8) files and using them to connect to Netgear/ Infrant ReadyNAS NV+ devices. Having a need to ghost these machines I needed to start installing CentOS 5.2 which allows ghost to work with the selinux partition information.

Following the same procedure I always do on a freshly installed OS (copying the u/mount.cifs (v1.8)) and the scripts I use to mount the NAS shares. I ran the scripts only to come up with:

mount error 13 = Permission denied
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

I have tried all forms to mount the share to no avail. Meanwhile the same script and u/mount.cifs files work fine on the CentOS 5 boxes.

script entry:
mount -t cifs //nas1.domain.internal/vm-base /mnt/NAS1/vm-base -o credentials=/root/VMbkp.cred

Other attempts:
mount -t cifs //nas1.domain.internal/vm-base /mnt/NAS1/vm-base -o credentials=/root/VMbkp.cred :: where password was enclosed with quotes. -> mount error 13 = Permission denied Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

mount.cifs -t cifs //nas1.domain.internal/vm-base /mnt/NAS1/vm-base -o credentials=/root/VMbkp.cred -> Mounting the DFS root for domain not implemented yetNo ip address specified and hostname not found

mount -t cifs //nas1.domain.internal/vm-base /mnt/NAS1/vm-base -ousername=domain\vmbackup,password=[R#M)T#D@T@] -> mount error 13 = Permission denied Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

mount -t cifs //nas1.domain.internal/vm-base /mnt/NAS1/vm-base -o[SPACE]username=domain\vmbackup,password=[R#M)T#D@T@] -> mount error 13 = Permission denied Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

mount -t cifs //nas1.domain.internal/vm-base /mnt/NAS1/vm-base -o username=domain/vmbackup,password=[R#M)T#D@T@] -> mount error 13 = Permission denied Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

mount -t cifs //nas1.domain.internal/vm-base /mnt/NAS1/vm-base -o user=domain\vmbackup,pass=[R#M)T#D@T@] -> mount error 13 = Permission denied Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

mount.cifs //nas1.domain.internal/vm-base /mnt/NAS1/vm-base -o user=domain\vmbackup,pass=[R#M)T#D@T@] -> mount error 13 = Permission denied Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

mount.cifs //nas1.domain.internal/vm-base /mnt/NAS1/vm-base -o user=vmbackup,pass=[R#M)T#D@T@],dom=domain -> -bash: !,dom=domain: event not found

mount.cifs //nas1.domain.internal/vm-base /mnt/NAS1/vm-base -o dom=domain,user=vmbackup,pass=[R#M)T#D@T@] -> mount error 13 = Permission denied Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

mount.cifs //nas1.domain.internal/vm-base /mnt/NAS1/vm-base -o domain=domain,user=vmbackup,pass=[R#M)T#D@T@] -> mount error 13 = Permission denied Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

Please can anyone help explain why I can mount from CentOS 5 systems but not CentOS 5.2?

UPDATE: Using --verbose for 5.0 and 5.2 systems shows that CIFS appears to be mis-parsing options. Notice the quotes in the verbose output on the 5.2 system.
5.0:
# ./mountNAS1.sh
parsing options: rw,credentials=/root/VMbkp.cred

mount.cifs kernel mount options unc=//nas1.domain.internal\vm-base,ip=10.1.129.16,user=vmbackup,,,,,,,,,,domain=domain,pass=[R#M)T#D@T@],ver=1,rw,credentials=/root/VMbkp.cred
parsing options: rw,credentials=/root/VMbkp.cred

mount.cifs kernel mount options unc=//nas1.domain.internal\backup,ip=10.1.129.16,user=vmbackup,,,,,,,,,,domain=domain,pass=[R#M)T#D@T@],ver=1,rw,credentials=/root/VMbkp.cred

5.2:
# ./mountNAS1.sh
parsing options: rw,credentials=/root/VMbkp.cred

mount.cifs kernel mount options unc=//nas1.domain.internal\vm-base,ip=10.1.129.16,user=vmbackup",,,,,,,,,,,domain="domain,pass="[R#M)T#D@T@]",ver=1,rw,credentials=/root/VMbkp.cred
mount error 13 = Permission denied
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)
parsing options: rw,credentials=/root/VMbkp.cred

mount.cifs kernel mount options unc=//nas1.domain.internal\backup,ip=10.1.129.16,user=vmbackup",,,,,,,,,,,domain="domain,pass="[R#M)T#D@T@]",ver=1,rw,credentials=/root/VMbkp.cred
mount error 13 = Permission denied
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

Last edited by navigat0; 07-30-2008 at 01:02 PM. Reason: UPDATE
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Placing a SMB share inside an NFS share grittyminder Linux - Networking 0 05-14-2008 03:49 AM
NAS share with NFS xhimi Linux - Server 0 02-21-2008 09:51 AM
Domain users can't log on to NAS share smithd3 Linux - Server 0 09-27-2007 11:31 AM
NAS or SMB server antivirus6613 Linux - Server 1 03-25-2007 01:29 PM
connect to windows share through smb://works great in gnome explorer,lousy in KDE? zeltak Linux - Software 0 01-09-2007 01:46 PM


All times are GMT -5. The time now is 06:24 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration