LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 01-05-2003, 02:11 PM   #1
WindowsHater
LQ Newbie
 
Registered: Jan 2003
Distribution: RedHat Linux 7.3
Posts: 7

Rep: Reputation: 0
Configuring verizon DSL on RH 7.3


Hello everyone,
I have problems in making RH 7.3 work with verizon DSL.
I have setup the PPPOE package from Roaring Penguine , but not sure where I went wrong during the setup. I'm getting the following error when I try to run /sbin/ifup ppp0

/sbin/adsl-start : line 217: 1805 Terminate $ CONNECT "$@" > /dev/null 2>&1

On my machine, I have setup Linux and also Windows ME (dual boot). Verizon DSL is working fine on ME.

I'm a newbie to the Linux world so please bear with me if I ask anything silly

PS: I setup Roaring penguine PPPoE pkg through the following command

rpm -Uvh rp-pppoe-3.5-1.i386.rpm

Rgds
Sat
 
Old 01-06-2003, 10:26 PM   #2
barstowkid
LQ Newbie
 
Registered: Jan 2003
Posts: 11

Rep: Reputation: 0
You are makeing this much harder than you need.. You do not need any ppp anything . It has been a while since I worked with Red Hat but I use SuSE 8.1 and have tried them all. All you need to do is tell red hat that you are using your ethernet net card as your network connection, during install you can tell the system to use ether0. I use verizon with a bual boot as well. During install the os should look for any connections and see the card and your connection. Sorry I do not have a red hat system to be able to walk you through this any better. I hope this helps , but remember I am new as you.
I am trying to give back some of the help I have recieved from the linux community, it has been great.

Good Luck Enjoy Your Linux
Gary Walton PhD

If you need further help

gary.walton@verizon.net
 
Old 01-07-2003, 02:43 PM   #3
WindowsHater
LQ Newbie
 
Registered: Jan 2003
Distribution: RedHat Linux 7.3
Posts: 7

Original Poster
Rep: Reputation: 0
Thank you Gary for the response. But I have tried what you said, by just setting up the Ethernet adapter but it is not working.

My understanding is that for DSL to work you need user id and password to dial out, and only PPOE has a provision for us to setup a DSL connection with uid and password .
I also searched in many linux forums including this one, and everyone is suggesting to go for PPOE for DSL connection (if you don't have a router).

Are you using a router by any chance? As you said, it might be so easy but there is a good chance that I got carried away by the discussion in many forums, so please let me know how you configured the connection.
 
Old 01-07-2003, 07:20 PM   #4
barstowkid
LQ Newbie
 
Registered: Jan 2003
Posts: 11

Rep: Reputation: 0
:) Hello

I will do my best. Like I said it has been a while since I have used 7.1 I think you said, however.

1. When you go to install red hat make sure you have your dls modem out pluged into your ethernet card, no you do not need a router or anything if this is the only connection you are going to need, if not you will need a hub or a router the router is a little better in that it usually has a built in firewall and it has the ability to assign ip addresses to each connection so you are a little safer , "they say" but regardless just make sure your hooked to the dls modem,. You do not need any dial up as your connection is constant, this is where your getting confused I think because windows has software that Verizon gives you you are under the asumption that it needs this to make connection, wrong! this is just a little eye candy toy that is typical of windows, all windows needs in a connection using your local area net, thats it it will do the rest, as linux will, now trust me Forget everything you know and just hook to the modem via the ethercard and your cat 5 cabel.

2.Boot the system and during install watch closely for the network stuff, and tell it you want to use DHCP the key here is telling the system to use DHCP. It will then use the eth0 to look for the incomeing connection and you do not have to give a user name and pass word to the dsl connection as it is a 24/7 always on connectrion. What I have found with Verizon is that my ip does not change except for about once a month, semi static I would like to say..

OK it is that simple but if you have further needs you have my email
gary.walton@verizon and if you would like I will even give you my phone number ..
God Luck and let me know.
Gary
 
Old 01-07-2003, 07:33 PM   #5
barstowkid
LQ Newbie
 
Registered: Jan 2003
Posts: 11

Rep: Reputation: 0
Even better here is the info from red hat them selfs.. See where it says configure using DHCP check that box and forgeet the rest that is all there is to it, do not enter anything else it is not necessary for a single desktop non server..
Let me here how your doing

Gary Walton PhD
 
Old 01-07-2003, 07:34 PM   #6
barstowkid
LQ Newbie
 
Registered: Jan 2003
Posts: 11

Rep: Reputation: 0
http://www.redhat.com/docs/manuals/l...netconfig.html

sorry the url did not post..
 
Old 01-11-2003, 02:10 PM   #7
WindowsHater
LQ Newbie
 
Registered: Jan 2003
Distribution: RedHat Linux 7.3
Posts: 7

Original Poster
Rep: Reputation: 0
Can you point me to some other source (other than re-installation instruction as mentioned above). The URL you mentioned above does not help me. I have already setup Linux and I want a step-by-step instruction to setup my DSL connection (pls remember i'm a newbie!!). My hunch is Verizon DSL needs PPPOE. I'm saying it because on Windows ME, Verizon uses PPP to connect.

Can anyone help?
 
Old 01-11-2003, 02:56 PM   #8
barstowkid
LQ Newbie
 
Registered: Jan 2003
Posts: 11

Rep: Reputation: 0
I have red hat 8.0 on a box here let me check.. Okay, on Red Hat8.0, here's what you have to do. First, start KDE for your desktop. Open the START MENU, go to SYSTEM SETTINGS, and then select NETWORK from the list. You will then be presented with NETWORK CONFIGURATION and now you should see DEVICES, HARDWARE, HOSTS and DNS tabs in the window. Under DEVICES, you want to select ADD. after selecting ADD,
you will be presented with a Select Device TYPE. Select Ethernet Connection ... forget all the other options offered. Just Ethernet
connection. Now select NEXT or
 
Old 01-11-2003, 03:04 PM   #9
barstowkid
LQ Newbie
 
Registered: Jan 2003
Posts: 11

Rep: Reputation: 0
sorry about that (my wife is doing the typing and she accidentally hit submit reply).
NOW select NEXT or FORWARD and you will be presented with a list of ethernet cards on your system. Select the one that applies. Now select FORWARD and you will get a configure network settings box. Select automatically obtain IP addresses settings with DHCP. Also select Automatically obtain DNS information from provider. Now select FORWARD AND HIT APPLY.
THAT'S IT. YOU'RE DONE. REBOOT YOUR MACHINE AND IF YOU are connected directly to your DSL modem, you will be online. You DO NOT require any PPP anything while you are using Verizon. As I told you, I am also on Verizon and it requires nothing more than what I have given you above. This is all I can do to help you as I do not have a copy of 7.1 to even load so if you need further help, contact me via e-mail and I will give you my phone # and maybe I can verbally get you through this. Yours truly, GARY
 
Old 01-11-2003, 03:17 PM   #10
WindowsHater
LQ Newbie
 
Registered: Jan 2003
Distribution: RedHat Linux 7.3
Posts: 7

Original Poster
Rep: Reputation: 0
Thank you so much Gary for trying to answer my questions. I will try what you have said here and let you know the results.
 
Old 01-11-2003, 03:33 PM   #11
WindowsHater
LQ Newbie
 
Registered: Jan 2003
Distribution: RedHat Linux 7.3
Posts: 7

Original Poster
Rep: Reputation: 0
I tried what you suggested through GNOME. But when I tried to boot RH, I'm getting Bringing up interface Eth0 [failed]
 
Old 01-11-2003, 04:06 PM   #12
barstowkid
LQ Newbie
 
Registered: Jan 2003
Posts: 11

Rep: Reputation: 0
when you selected network device your net card was there correct ? The system does find your card I hope, you might want to check to make sure your card is being found and a driver is loaded for it. This is the only reason I can think of for the net not to work . It makes good sence if it doesn't see the card it can not use it for the connection. Net cards are cheep now less than 20 bucks ev en at wal mart..let me know where yo go from here..
Gary

during boot if you are seeing it pause for a long time then get this result the card is not being identified by the system ,, what type net card is it? Check the hardware compatibly list on red hat
 
Old 01-11-2003, 05:04 PM   #13
WindowsHater
LQ Newbie
 
Registered: Jan 2003
Distribution: RedHat Linux 7.3
Posts: 7

Original Poster
Rep: Reputation: 0
The network card is NETGEAR FA311 Fast Ethernet PCI Adapter.
It works in WinME and I can also see the green light glowing when I boot with Linux. I will also chk the HCL .
 
Old 01-11-2003, 05:22 PM   #14
barstowkid
LQ Newbie
 
Registered: Jan 2003
Posts: 11

Rep: Reputation: 0
same card i am using..have any free airtime I do so send your phone number I will call as I have free week ends maby I can talk yoou throught this..
Gary
 
Old 01-13-2003, 12:20 AM   #15
hatrisc
LQ Newbie
 
Registered: Jan 2003
Distribution: slack
Posts: 21

Rep: Reputation: 15
there is a file in redhat, under /etc/sysconfig/network-scripts, called ifcfg-eth0. there you can specify the use of dhcp by using dhcp=yes i believe, substitute "no" with yes. if for some reason it's not in that file (i could be mistaking i use slack) then try /etc/sysconfig/network then, type as root, "service network restart" and you should be all set to go
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
does anyone have Verizon dsl and linux bosewicht Linux - Newbie 3 07-25-2008 06:43 PM
Verizon DSL AlleyTrotter Slackware 6 11-01-2005 11:59 AM
Verizon DSL with Mandrake 9.2 tpark Mandriva 1 02-07-2004 08:39 PM
help me with my verizon DSL? kayiman74 Linux - General 3 01-13-2003 12:26 AM
Verizon DSL Skidde Linux - General 4 12-30-2002 03:07 PM


All times are GMT -5. The time now is 10:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration