LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 01-12-2005, 09:16 AM   #1
geodo
LQ Newbie
 
Registered: May 2004
Posts: 12

Rep: Reputation: 0
configure network card as gigabit full duplex


I'm having a D-Link DL2000-based Gigabit Ethernet network card, but I'm not able to run it on a gigabit port. (I'm using SuSE 9.1.)

Trying mii-tool -v I receive:
Code:
  eth0: negotiated 100baseTx-FD, link ok
  product info: vendor 00:50:43, model 5 rev 4
  basic mode:   autonegotiation enabled
  basic status: autonegotiation complete, link ok
  capabilities: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
  advertising:  100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD flow-control
  link partner: 100baseTx-FD 100baseTx-HD 10baseT-FD 10baseT-HD
I want to configure it as gigabit full duplex, but just don't know how to do it (beginner...). What command would I have to try to make the network card working on a gigabit port?

Thanks in advance!
 
Old 01-12-2005, 09:54 AM   #2
LinuxGeek
Member
 
Registered: Jun 2002
Posts: 302

Rep: Reputation: 31
Run the following command:

Code:
	ethtool eth0
This should give you detailed information about your connection. Then have a look at:

Code:
	man ethtool
and it's tell you how to try to force the connnection. But it might be that the other machine is not allowing your gigabyte ethernet card to operate at full speed.
 
Old 01-17-2005, 03:08 AM   #3
geodo
LQ Newbie
 
Registered: May 2004
Posts: 12

Original Poster
Rep: Reputation: 0
I tried the command
Code:
ethtool -s eth0 speed 1000
, but ethtool eth0 tells me the following (before and after using ethtool -s...):

Settings for eth0:
Supported ports: [ MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 1
Transceiver: internal
Auto-negotiation: on
Link detected: yes

Did I use the wrong command?
I know definitely thet card and port are able to do gigabit. Could it be that one of it is broken?
 
Old 01-17-2005, 05:20 AM   #4
LinuxGeek
Member
 
Registered: Jun 2002
Posts: 302

Rep: Reputation: 31
Try this:
Code:
 
	ethtool -s eth0 autoneg off duplex full speed 1000
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set Lan card to 10Mb full duplex in FC2 rickronn Linux - Networking 11 11-08-2004 03:41 AM
My sound card is not working at full duplex. mir_sheely Linux - Hardware 0 06-19-2004 06:00 AM
how to set half/full duplex on a lan card billy998168 Linux - General 8 03-19-2004 05:33 PM
how to configure network full duplex 100Mb ewlnxnewB Linux - Networking 1 01-28-2004 05:25 PM
Full duplex sound card tommylkc Linux - Hardware 1 06-28-2002 10:49 AM


All times are GMT -5. The time now is 09:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration