LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 05-09-2004, 06:10 PM   #1
HKDude
LQ Newbie
 
Registered: Jan 2002
Location: Illinois
Distribution: Slackware 9 (VectorLinux)
Posts: 16

Rep: Reputation: 0
Client (windows) can't ping hostnames


I've been fighting and losing with dynamic DNS for two weeks. I give up. It wins. For now I'm just trying to get DNS to work. It is vexing me sorely.

Problem --> My windows 98 client will not ping the server's hostname or FQDN. I can ping IP addresses but no names.

Environment --> To rule out wierdness, I have the server and windows 98 client isolated on their own segment. There isn't even an internet connection. Just the server, a hub, and the client. So the good news this is not a samba or firewall problem.

Configuration --> I believe the DNS server is working correctly. I have 4 zones, root.hints, internal-zone, internal-zone.in-addr.arpa, and localhost.in-addr.arpa. I can ping the client's hostname and FQDN from the server with no problem. It just won't work from the client machine. Dig also seems to be working correctly from the server end.

As for the client, The client's IP and gateway are hardcoded. I have the IP address of the server set for the DNS server, along with the search domain, in the TCP/IP setting section of network setup dialog box. I don't have a dig utility on the client and when I run tracert server.mydomain.com it gives me the helpful response of "unable to resolve target system name".

Pupose --> All I'm looking for here is to have my internal network clients be able to communicate with each other via the internal DNS and if its not on my network, forward the request to the ISP DNS server. Nothing more complicated than this right now.

At this point, it seems like the client isn't utilizing the DNS server. I'm not sure what else to do and would appreciate some suggestions.

Thanks...
 
Old 05-09-2004, 07:23 PM   #2
NetAX
Member
 
Registered: Mar 2004
Location: Boston, MA
Distribution: SuSE Linux Open/Enterprise, Red Hat, Ubuntu
Posts: 146

Rep: Reputation: 16
sounds like your DNS server isn't configured correctly. try:

nslookup: FQDN(server name)

on the server itself and see if it comes up properly as such:

----------------------------------
root@cosmos:~> nslookup cosmos.net
Note: nslookup is deprecated and may be removed from future releases.
Consider using the `dig' or `host' programs instead. Run nslookup with
the `-sil[ent]' option to prevent this message from appearing.
Server: 172.16.4.253
Address: 172.16.4.253#53

Name: cosmos.net
Address: 172.16.4.253
-----------------------------------

if the name doesnt come up like it does in the second section of nslookup you may have to redo your DNS configuration.

From your post i couldnt tell if you had reverse-lookup for each zone. Please post more, or maybe your "named.conf" file to better analyze the problem.
 
Old 05-09-2004, 09:13 PM   #3
HKDude
LQ Newbie
 
Registered: Jan 2002
Location: Illinois
Distribution: Slackware 9 (VectorLinux)
Posts: 16

Original Poster
Rep: Reputation: 0
running the command: nslookup server.trinity-internal.com returns:

Note: blah, blah, blah...
Server: 127.0.0.1
Address: 127.0.0.1#53

Name: server.trinity-internal.com
Address: 192.168.0.10

Here is a copy of my named.conf. If you want to see any zone files, please let me know.

***********************
# Specify where the zone files are stored
options {
directory "/var/named";

# Setup fowarders to InsightBB DNS

forwarders {
63.240.76.4;
204.127.198.4;
};
};

# Setup rndc running on localhost to send commands
controls {
inet 127.0.0.1
allow { 127.0.0.1; }
keys { rndc; };
};

# Setup rndc secret - same as rndc.conf
key rndc {
algorithm HMAC-MD5;
secret "xxxxxxxxxxxxxxxxxxxxxxxxxxxxx";
};

# Setup the root zone
zone "." {
type hint;
file "root.hints";
};

# Setup the trinity-interal zone
zone "trinity-internal.com" {
type master;
file "trinity-internal.com";
};

# Setup 0.168.192.in-addr.arpa zone
zone "0.168.192.in-addr.arpa" {
type master;
file "rev/192.168.0";
};

# Setup 0.0.127.in-addr.arpa zone
zone "0.0.127.in-addr.arpa" {
type master;
file "rev/127.0.0";
};
 
Old 05-10-2004, 07:57 AM   #4
NetAX
Member
 
Registered: Mar 2004
Location: Boston, MA
Distribution: SuSE Linux Open/Enterprise, Red Hat, Ubuntu
Posts: 146

Rep: Reputation: 16
The named file looks alright. The loopback zone files should be alright if you haven't altered them.

Post the files:

-file "trinity-internal.com";
-file "rev/192.168.0";

Please note: I dont know too much about forwarding. Just trying to help you get your server resolving hostname/FQDN for right now.
 
Old 05-10-2004, 10:02 AM   #5
HKDude
LQ Newbie
 
Registered: Jan 2002
Location: Illinois
Distribution: Slackware 9 (VectorLinux)
Posts: 16

Original Poster
Rep: Reputation: 0
Thanks for any help you can provide. At this point I'm worried I'm so irriated/frustrated that I'm missing something oblivious.

Here are my files. \rev\192.168.0 followed by trinity-internal.com:

**************
$TTL 2D
@ IN SOA server.trinity-internal.com. sysadmin.trinity-internal.com. (

050820041 ; Serial
10800 ; Refresh (3 hours)
3600 ; Retry (1 hour )
604800 ; Expire (7 days )
86400) ; Min TTL (1 day )

IN NS server.trinity-internal.com.

; Setup static server PTR records

1 IN PTR router.trinity-internal.com.
10 IN PTR server.trinity-internal.com.
10 IN PTR www.trinity-internal.com.
10 IN PTR ftp.trinity-internal.com.

; Setup static client PTR records

50 IN PTR laptop.trinity-internal.com.
51 IN PTR office.trinity-internal.com.
52 IN PTR pastor.trinity-internal.com.
53 IN PTR craptop.trinity-internal.com.

***********
$TTL 2D
@ IN SOA server.trinity-internal.com. sysadmin.trinity-internal.com. (
050820041 ; Serial
10800 ; Refesh (3 hours)
3600 ; Retry (1 hour )
604800 ; Expire (7 days )
86400) ; Min TTL (1 day )

IN NS server.trinity-internal.com.

; Setup static server A records
router IN A 192.168.0.1
server IN A 192.168.0.10
www IN A 192.168.0.10
ftp IN A 192.168.0.10
localhost IN A 127.0.0.1

; Setup static client A records
laptop IN A 192.168.0.50
office IN A 192.168.0.51
pastor IN A 192.168.0.52
craptop IN A 192.168.0.53
 
Old 05-12-2004, 06:14 PM   #6
HKDude
LQ Newbie
 
Registered: Jan 2002
Location: Illinois
Distribution: Slackware 9 (VectorLinux)
Posts: 16

Original Poster
Rep: Reputation: 0
The beast is still not working but I have an update. I downloaded some network tools to my client and it appears as if the client is not seeing my DNS server. Named is running on the server and showing 5 zones. My logs aren't showing any errors but the client utilities says "no DNS server found". If anybody has any ideas, please chime in. Back to searching the WWW for an answer...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cannot ping outside hostnames PeterLarsson Linux - Networking 1 08-05-2005 12:37 AM
Can't ping hostnames Nox UK Linux - Networking 3 04-19-2005 03:07 PM
Can ping MyDNS1.FQDN and IPs but no other hostnames? leecason Linux - Networking 3 10-06-2003 03:01 PM
cannot ping hostnames joadoor Linux - Networking 21 06-10-2003 10:12 AM
Ping ok Samba ok Windows client NO prdprd Linux - Networking 4 04-11-2002 09:43 PM


All times are GMT -5. The time now is 05:09 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration