LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 06-30-2008, 12:33 PM   #1
metallica1973
Senior Member
 
Registered: Feb 2003
Location: Washington D.C
Posts: 2,113

Rep: Reputation: 57
Cisco 831 Cisco Router and Cable Modem


A friend just purchased a Cisco 831 router and wants to configure his router to grab a ip address from his cable modem and set his lan ports on his router to DHCP. Can someone give me a config file that can do that. thanks
 
Old 07-01-2008, 09:03 PM   #2
grejon04
Member
 
Registered: Jun 2008
Posts: 43

Rep: Reputation: 15
Give this a try,

http://articles.techrepublic.com.com...1-6102399.html

and let me know what stumps you from there...

don't forget to post your configs. Also, if your IOS is not 'advipservicesk9' or something along those lines, your vlan support may be limited...you should still be able to pull the dhcp configs from this.
 
Old 07-01-2008, 09:14 PM   #3
grejon04
Member
 
Registered: Jun 2008
Posts: 43

Rep: Reputation: 15
here, looks like you've helped plenty of other people...

this router has a bunch of stuff configured, inc port-forwarding to vncserver and http server (the ip nat source static lines), a vpn in (vpdn lines), the interfaces bridged together, etc., let me know if this is too much...

Code:
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname yourhost
!
boot-start-marker
boot-end-marker
!
enable secret 5 md5encryptedpassword
!
aaa new-model
!
!
aaa authentication ppp default local
!
!
aaa session-id common
ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 172.17.5.170 172.17.5.174
!
ip dhcp pool yourpool
   import all
   network networkaddressofdhcppool masktothispool
   default-router defaultgateway
!
!
ip domain name yourdomain.com
ip ssh authentication-retries 2
!
multilink bundle-name authenticated
vpdn enable
!
vpdn-group vpngroupname
! Default L2TP VPDN group
! Default PPTP VPDN group
 accept-dialin
  protocol any
  virtual-template 1
 l2tp tunnel password 7
!
!
!
!
!
username username privilege 15 password 7 cisco7encryptedpassword
username username2 privilege 15 password 7 cisco7encryptedpassword
username vpnuser password 7 7encpassword
!
!
!
bridge irb
!
!
!
interface FastEthernet0
 switchport access vlan 10
 spanning-tree portfast
!
interface FastEthernet1
 switchport access vlan 10
 spanning-tree portfast
!
interface FastEthernet2
 switchport access vlan 10
 spanning-tree portfast
!
interface FastEthernet3
 switchport access vlan 10
 spanning-tree portfast
!
interface FastEthernet4
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 ip tcp adjust-mss 1460
 duplex auto
 speed auto
!
interface Virtual-Template1
 ip unnumbered BVI10
 peer default ip address dhcp-pool poolforvpn
 ppp encrypt mppe auto required
 ppp authentication ms-chap ms-chap-v2 eap chap pap
!
interface Dot11Radio0
 no ip address
 !
 encryption vlan 10 mode ciphers tkip
 !
 ssid SuperCoffee
    vlan 10
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 7 cisco7encpasswordforwireless
 !
 speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
 station-role root
 no dot11 extension aironet
 no cdp enable
!
interface Dot11Radio0.10
 encapsulation dot1Q 10
 no cdp enable
 bridge-group 10
 bridge-group 10 subscriber-loop-control
 bridge-group 10 spanning-disabled
 bridge-group 10 block-unknown-source
 no bridge-group 10 source-learning
 no bridge-group 10 unicast-flooding
!
interface Vlan1
 no ip address
!
interface Vlan10
 no ip address
 ip nat inside
 ip virtual-reassembly
 bridge-group 10
 bridge-group 10 spanning-disabled
!
interface BVI10
 ip address bridgegroupSVIaddress mask
 ip nat inside
 ip virtual-reassembly
!
ip local pool vpnpool 192.168.1.1 192.168.1.10
ip route 0.0.0.0 0.0.0.0 dhcp
!
!
no ip http server
no ip http secure-server
ip nat inside source list 1 interface FastEthernet4 overload
ip nat inside source static tcp serverip 5901 interface FastEthernet4 5901
ip nat inside source static udp serverip 5901 interface FastEthernet4 5901
ip nat inside source static tcp serverip 80 interface FastEthernet4 80
!
access-list 1 permit networkaddress wildcard(inverse)masktoyournetworkaddr
no cdp run
!
!
!
!
control-plane
!
bridge 10 route ip
!
line con 0
 exec-timeout 5 0
 logging synchronous
 no modem enable
line aux 0
line vty 0 4
 exec-timeout 5 0
 password 7 cisco7encpasswd
 logging synchronous
 transport input ssh
!
scheduler max-task-time 5000
end

host#
 
Old 07-14-2008, 08:00 PM   #4
metallica1973
Senior Member
 
Registered: Feb 2003
Location: Washington D.C
Posts: 2,113

Original Poster
Rep: Reputation: 57
thanks for you help but I was able to figure it out.

Here is my friends layout:

PHP Code:
Internet
   
|
   |
   |
Cable Modem
   
|
   |
   |
  (
E1)
Cisco 831 
  
(FA2-4)
   |
   | 
   |
CentOS(Firewall/Proxy) ------------------RADIUS-------Wireless
   
|
   |
   |
  
LAN
   
|
   |
   |
Office PCs 
Here is the running-config of the Cisco 831

PHP Code:
Current configuration 1375 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password
-encryption
!
hostname DTMFP
!
enable secret 5 $1$UZQ2$901W0XeF2xN/yuWa6lkvr0
enable password mindyourdamnbizz
!
username DTMFP password 0 mindyourdamnbizz
username CRWS_Shashi privilege 15 password 0 
$1$W1fA$o1oSEpa23380795
ip subnet
-zero
ip name
-server 4.2.2.5
ip name
-server 4.2.2.6
!
ip dhcp pool DTMFP
   import all
   network 192.168.1.0 255.255.255.0
   
default-router 192.168.1.1 
   dns
-server 4.2.2.5 
   lease infinite
!
ip urlfilter alert
ip audit notify log
ip audit po max
-events 100
!

!
!
!
!
interface 
Ethernet0
 description CRWS Generated text
Please do not delete this:192.168.1.1-255.255.255.0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 no cdp enable
 hold
-queue 32 in
 hold
-queue 100 out
!
interface 
Ethernet1
 description Internet
 ip address dhcp client
-id Ethernet1
 no ip redirects
 no ip unreachables
 no ip proxy
-arp
 ip nat outside
 no ip mroute
-cache
 duplex auto
 no cdp enable
!
ip nat inside source list interface Ethernet1 overload
ip classless
ip http server
no ip http secure
-server
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
no cdp run
!
line con 0
 no modem enable
 stopbits 1
line aux 0
 stopbits 1
line vty 0 4
 exec
-timeout 120 0
 password mindyourdamnbizz
 login local
 length 0
!
scheduler max-task-time 5000
end 
Works like a champ. I this help.

Last edited by metallica1973; 07-14-2008 at 08:02 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to connect to Cisco devices via console/USB cable Nevski Linux - Wireless Networking 5 08-30-2007 02:22 PM
LXer: Will an open source router replace your Cisco router? LXer Syndicated Linux News 1 03-21-2007 09:04 AM
cisco aironet on windows and trying to share internet though crossover cable cyberwizard Linux - Networking 0 03-21-2006 05:03 PM
Hooking a Cisco 2501 router to a cable modem tangle Linux - Hardware 1 02-09-2005 08:55 PM
Cisco 678 modem/router and Linux server Q xmutex Linux - Networking 1 09-03-2001 04:27 AM


All times are GMT -5. The time now is 12:55 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration