LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Cifs "mount error 5 = Input/output error" but smbfs works! (http://www.linuxquestions.org/questions/linux-networking-3/cifs-mount-error-5-%3D-input-output-error-but-smbfs-works-456897/)

humbletech99 06-21-2006 07:36 AM

Cifs "mount error 5 = Input/output error" but smbfs works!
 
I can't mount cifs share, but smbfs works fine with same credentials.
Code:

mount -t cifs //hostname/backup /mnt/hostname/backup/
Password:
mount error 5 = Input/output error
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

The username and password I'm using are correct since I can mount via smbfs this way.

I haven't had much luck on the web, saw some things about matching hostname/ip resolution but my resolution is fine and matching.

Any ideas?

Lenard 06-21-2006 09:13 AM

I normally do something along the lines of;

Code:

mount -t cifs //<IP_address_here>/<Share_here> /the/mountpoint -o,user=myusername%mypassword
Example;
mount -t cifs //192.168.1.100/Laserfiche /mnt/Desktop -o,user=lenard%letmein

or (keeping the same example in mind);

Code:

mount -t cifs //192.168.1.100/Laserfiche /mnt/Desktop -o credentials=/path/to/the/credentials.txt_file -rw
Example (cifs) credentials.txt_file;

username=myusername
password=mypassword

Which a little different from the smbfs credentials file format, notice the no spaces for cifs vs smbfs;

Example (smbfs) credentials.txt_file;

username = myusername
password = mypassword

humbletech99 06-21-2006 10:21 AM

this isn't the problem, it's a cifs thing, the parameters are correctly done in the same fashion as smbfs, which I do all the time. If I use the same line with smbfs it mounts fine, but smbfs misses file listings, that's why I'm using the more reliable cifs, it I can get the dang thing to mount in the first place...

alanrr 03-23-2007 09:34 PM

Server Name vs Server IP
 
I got the same error:
mount error 5 = Input/output error
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

if I use a host name. In my case, if I use a one defined by DNS.

If I use the IP address of the server, I got no problem and mount command succeeds

trebek 12-04-2007 08:00 PM

Quote:

Originally Posted by alanrr (Post 2682368)
I got the same error:
mount error 5 = Input/output error
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

if I use a host name. In my case, if I use a one defined by DNS.

If I use the IP address of the server, I got no problem and mount command succeeds

Hi there. I solved this problem by checking my cifspw file, and making sure the domain name was correct. I haven't tried doing it with the server's name, only with the ip, but regardless, i think this problem is more an access denied problem instead of a network name problem.

Hope this helps. I'll reply when i try it with the name, the same way.

BioHak 04-16-2008 01:25 PM

Had the same problem for a while... Check syntax on your cifs connection, I had a colon stuck in the string which gave the same error reported here

//<SERVER IP HERE>/<Share>
not
//<SERVER IP HERE>:/<Share>

humbletech99 04-17-2008 03:08 AM

oh this is old now, I can't remember what is was, but I think it may have been caused by some older samba servers (2.x series) that didn't support the newer cifs protocol...

The error message could have been a bit more helpful I have to say...

serodores 10-09-2008 03:29 PM

DNS is definitely it
 
I had the same issue when trying to mount over a ssh tunnel, and used 'localhost'. Using the IP address (or 127.0.0.1) over the DNS name worked fine for me.

humbletech99 10-09-2008 03:51 PM

Ok, glad you solved it, my issue was to due with the protocol not being supported instead on older 2.x samba servers. Like I said, the error message could have been more helpful...

djbon2112 12-25-2008 09:58 AM

I'm now getting this problem as well, if anyone can help. Everything was working fine until 3 days ago, then all of a sudden I started getting this error. I had fixed it two nights ago, but I have no idea how, and now it's returned. Everything is configured right on the server end but I still get the I/O error.

Code:

joshua@zeus-001:~$ sudo mount -t cifs -o username=nobody //192.168.0.200/raid /mnt/fileserver
[sudo] password for joshua:
Password:
mount error 5 = Input/output error
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)

This is what worked perfectly fine the other day. It's the same with either cifs or smbfs.

abhay.asingh 01-19-2010 01:49 AM

Cifs "mount error 5 = Input/output error
 
Hi All,

I am facing problem on mounting windows shared directory in my Suse Linux Server-10.
I have been through lots of threads in forum but all nothing worked for me.
This is my command to mount
mount --verbose -t cifs -o username=userid%passwd //192.168.0.103/Domestic/results /data/results/domestic
And the error is

mount error 5 = Input/output error
Refer to the mount.cifs(8) manual page (e.g.man mount.cifs)


here is some more info
cat /etc/SuSE-release
SUSE Linux Enterprise Server 10 (x86_64)
VERSION = 10
Error while fire smbclient command
smbclient //192.168.0.103/Domestic/results -U results
Password:
Domain=[RD-GROUP] OS=[Windows Server 2003 3790 Service Pack 2] Server=[Windows Server 2003 5.2]
tree connect failed: NT_STATUS_BAD_NETWORK_NAME


Result of
cat /proc/fs/cifs/ExtendedSecurity
0
cat /proc/fs/cifs/LinuxExtensionsEnabled
0

Pastorino 03-11-2012 12:05 PM

Hi everyone,

I know this is a very old thread, but I just had the same problem today, and I found out the reason.

I was trying to mount with CIFS and the result was:

Code:

~]# mount /mnt/backup/
mount error(5): Input/output error
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

and the fstab was:

Code:

//bkpsrv/share    /mnt/backup  cifs    credentials=XXX,uid=YYY 0 0
The whole problem was with the "bkpsrv", because the real hostname is "backupserver", but to shorten commands, I created the entry at /etc/hosts as "bkpsrv".

When I changed /etc/hosts and /etc/fstab to "backupserver", it mounted just fine.

Cheers,

Juliano

thewinelake 10-08-2013 10:55 AM

I also had this problem when trying to connect from an Ubuntu 12.04 to an old BreezyBadger server.

The solution in my case was to add an option of "sec=ntlm"

eg: mount -t cifs -o username=user,password=opensesame,sec=ntlm //myserver.com/myshare /mnt/myserver

Just adding it here, as this thread seems to have a high Google weighting!

NeroTux 10-14-2013 05:40 AM

Thanx, the sec=ntlm parameter solved my problem:hattip:

tgorman22 11-02-2013 07:29 PM

Quote:

Originally Posted by NeroTux (Post 5045328)
Thanx, the sec=ntlm parameter solved my problem:hattip:

Hallelujah!

This fixed my problem as well!!!!


All times are GMT -5. The time now is 10:51 PM.