LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 02-05-2012, 11:59 PM   #1
achoos13
LQ Newbie
 
Registered: Jan 2012
Posts: 18

Rep: Reputation: Disabled
Channel bonding in RHEL6


We have 2 NIC cards and we need to configure channel bonding. We have configured etho,eth1 and bond0 as mentioned in Deployment guide. Issue is after restarting "Network" only bond0 is comming up. eth0 and eth1 remains down.
I think the issue is with the bonding driver. But not able to find the error
Attached Images
File Type: jpg bonding.jpg (110.6 KB, 13 views)
 
Old 02-06-2012, 02:19 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,378

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
can you show us the config files please? We can't help without some useful information to work on.
 
Old 02-06-2012, 02:56 AM   #3
achoos13
LQ Newbie
 
Registered: Jan 2012
Posts: 18

Original Poster
Rep: Reputation: Disabled
Have configured bonding.conf in the /etc/modprobe.d/ directory with entry

alias bond0 bonding

Other files are ifcfg-eth0,ifcfg-eth1,ifcfg-bond0
Attached Images
File Type: jpg conf.JPG (45.0 KB, 21 views)
 
Old 02-06-2012, 03:18 AM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,378

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
Well I'd wipe NetworkManager from the server, removing the NM_MANAGED options for a start. TBH, I've no idea if they will stop the NIC's loading, but it would think it likely.
 
Old 02-06-2012, 05:17 AM   #5
achoos13
LQ Newbie
 
Registered: Jan 2012
Posts: 18

Original Poster
Rep: Reputation: Disabled
I have tried that but its not working.
 
Old 02-06-2012, 07:40 PM   #6
grim76
Member
 
Registered: Jun 2007
Distribution: Debian, SLES, Ubuntu
Posts: 266

Rep: Reputation: 43
Do the nics actually come up and work if you don't bond them?
 
Old 02-06-2012, 10:10 PM   #7
achoos13
LQ Newbie
 
Registered: Jan 2012
Posts: 18

Original Poster
Rep: Reputation: Disabled
grim76 i configured the ifcfg-bond0...what else to be done?
 
Old 02-07-2012, 05:58 AM   #8
tsumaru
LQ Newbie
 
Registered: Jan 2012
Distribution: Ubuntu
Posts: 18

Rep: Reputation: Disabled
From my experience with bonding (albeit on ubuntu) the interfaces that are being bonded dont nessecerily need to be up.

Do your eth0 and eth1 interfaces _NEED_ an IP address or do you want them to share the same "virtual" one?
 
Old 02-07-2012, 06:04 AM   #9
achoos13
LQ Newbie
 
Registered: Jan 2012
Posts: 18

Original Poster
Rep: Reputation: Disabled
IN RHEL we need both NIC cards up but not assigning any ip address individually. IP is assigned to bond0 alone. Now the scenario is like when is use the commands

ifconfig bond0 ipaddr
ifenslave bond0 eth0 eth1

it works fine but its a temporary solution. because when we restart the network service only bond0 is coming up
 
Old 02-07-2012, 06:08 AM   #10
tsumaru
LQ Newbie
 
Registered: Jan 2012
Distribution: Ubuntu
Posts: 18

Rep: Reputation: Disabled
it might be a long shot but is your network manager not expecting the two interfaces to have an IP address? Maybe assign them an IP in a different subnet each?

Also check permissions on the script files.
 
Old 02-07-2012, 07:15 AM   #11
grim76
Member
 
Registered: Jun 2007
Distribution: Debian, SLES, Ubuntu
Posts: 266

Rep: Reputation: 43
Your config files look right the only thing that I see is a nitpick is BONDING_opts should be BONDING_OPTS for sake of uniformity. Unless there is something else that is keeping things from working.

Typically we either do mode 4, or mode 1 for our bonds here so I am not as familiar with mode 0.
 
Old 02-08-2012, 02:20 AM   #12
achoos13
LQ Newbie
 
Registered: Jan 2012
Posts: 18

Original Poster
Rep: Reputation: Disabled
Everything working fine when i removed th HWADDR entry from eth0 and eth1 config file...thank you for the support.
 
Old 02-09-2012, 02:57 PM   #13
rhbegin
Member
 
Registered: Oct 2003
Location: Arkansas, NWA
Distribution: Fedora/CentOS/SL6
Posts: 381

Rep: Reputation: 23
Quote:
Originally Posted by achoos13 View Post
Everything working fine when i removed th HWADDR entry from eth0 and eth1 config file...thank you for the support.
Yip, since it is bonded it will not work with this entry.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
FC4 channel bonding dretzloff Linux - Networking 6 01-13-2011 12:54 PM
Help with channel bonding jaraju Linux - Networking 11 05-05-2005 07:38 PM
Ethernet channel bonding satimis Linux - Networking 3 05-19-2004 10:16 AM
Channel bonding with 2 IPs dark_luder Linux - Networking 0 02-25-2004 09:55 AM
ISDN Channel Bonding??? ricey Linux - Newbie 4 07-29-2002 04:43 PM


All times are GMT -5. The time now is 09:07 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration