LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices



Reply
 
Search this Thread
Old 10-28-2012, 11:21 AM   #1
seighalani
Member
 
Registered: Aug 2007
Posts: 102

Rep: Reputation: 15
channel bonding


hi everyone

i configured channel bonding on centos6.3 64bit. but i have some problem . for test i unplug eth0 and see the ping output . everything was good but after plug eth0 after 8 request timeout or delay network connected. i dont know why. please note to my configuration:


[root@localhost ~]# cat /etc/sysconfig/network-scripts/ifcfg-bond0
DEVICE=bond0
USERCTL=no
BOOTPROTO=none
ONBOOT=yes
NM_CONTROLLED=no
IPADDR=10.1.30.53
NETMASK=255.255.255.0
GATEWAY=10.1.30.3
DNS1=10.1.10.11
DNS2=10.1.10.12
IPV6INIT=no
BONDING_OPTS="mode=5 miimon=50"


________
[root@localhost ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE="eth0"
BOOTPROTO="none"
HWADDR="10:ee:74:3:"
NM_CONTROLLED="no"
ONBOOT="yes"
#TYPE="Ethernet"
#UUID="01111-a27e-4cd6-qqqq-b908eb"
USERCTL=no
MASTER=bond0
SLAVE=yes


_________
[root@localhost ~]# cat /etc/sysconfig/network-scripts/ifcfg-eth1
DEVICE="eth1"
BOOTPROTO="none"
HWADDR="10:1F:74:ddd"
NM_CONTROLLED="no"
ONBOOT="yes"
#TYPE="Ethernet"
#UUID="83eeee7084a-8f08-40dd-9a1a-69e6c9cccccc"
USERCTL=no
MASTER=bond0
SLAVE=yes

_________
[root@localhost ~]# cat /etc/modprobe.d/bonding.conf
alias bond0 bonding
________
[root@localhost ~]# cat /etc/modprobe.d/bonding.conf
alias bond0 bonding
[root@localhost ~]# modprobe --list |grep bonding
kernel/drivers/net/bonding/bonding.ko
[root@localhost ~]# modprobe --list |grep mii
kernel/drivers/net/mii.ko

___________
[root@localhost ~]# cat /proc/net/bonding/bond0
Ethernet Channel Bonding Driver: v3.6.0 (September 26, 2009)

Bonding Mode: transmit load balancing
Primary Slave: None
Currently Active Slave: eth0
MII Status: up
MII Polling Interval (ms): 50
Up Delay (ms): 0
Down Delay (ms): 0

Slave Interface: eth0
MII Status: up
Speed: 1000 Mbps
Duplex: full
Link Failure Count: 0
Permanent HW addr: 10:1f:74:
Slave queue ID: 0

Slave Interface: eth1
MII Status: up
Speed: 1000 Mbps
Duplex: full
Link Failure Count: 0
Permanent HW addr: 10:1f:745
Slave queue ID: 0
____________
[root@localhost ~]# cat /sys/class/net/bond0/bonding/miimon
50
[root@localhost ~]# cat /sys/class/net/bond0/bonding/arp_validate
none 0
[root@localhost ~]# cat /sys/class/net/bond0/bonding/arp_interval
0
[root@localhost ~]# cat /sys/class/net/bond0/bonding/primary
[root@localhost ~]# cat /sys/class/net/bond0/bonding/slaves
eth0 eth1
[root@localhost ~]# cat /sys/class/net/bond0/bonding/updelay
0
[root@localhost ~]# cat /sys/class/net/bond0/bonding/mode
balance-tlb 5
[root@localhost ~]# cat /sys/class/net/bond0/bonding/active_slave
eth0
[root@localhost ~]# cat /sys/class/net/bond0/bonding/ad_aggregator
[root@localhost ~]# cat /sys/class/net/bond0/bonding/arp_ip_target
[root@localhost ~]# cat /sys/class/net/bond0/bonding/mii_status
up

Last edited by seighalani; 10-29-2012 at 06:45 AM. Reason: dmesg showed my server specification.
 
Old 10-28-2012, 08:21 PM   #2
grim76
Member
 
Registered: Jun 2007
Distribution: Debian, SLES, Ubuntu
Posts: 283

Rep: Reputation: 47
You might want to try adding an updelay to your configuration. That way you can delay the activation of the failed device until it is completely up. Keep in mind that updelay should be a multiple of your miimon value.
 
1 members found this post helpful.
Old 10-29-2012, 12:54 AM   #3
seighalani
Member
 
Registered: Aug 2007
Posts: 102

Original Poster
Rep: Reputation: 15
thanks for your reply. but how can i find updelay number? what number is better?
may be this problem related to switch? what parameter should set on switch ports?
 
Old 10-29-2012, 05:57 AM   #4
grim76
Member
 
Registered: Jun 2007
Distribution: Debian, SLES, Ubuntu
Posts: 283

Rep: Reputation: 47
http://www.kernel.org/doc/Documentat...ng/bonding.txt

Updelay is documented at the above location.
 
Old 10-29-2012, 06:44 AM   #5
seighalani
Member
 
Registered: Aug 2007
Posts: 102

Original Poster
Rep: Reputation: 15
hi again
my problem solved
after enabling portfast on switch ports my problem solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Channel bonding in RHEL6 achoos13 Linux - Networking 12 02-09-2012 03:57 PM
FC4 channel bonding dretzloff Linux - Networking 6 01-13-2011 01:54 PM
Help with channel bonding jaraju Linux - Networking 11 05-05-2005 08:38 PM
Ethernet channel bonding satimis Linux - Networking 3 05-19-2004 11:16 AM
ISDN Channel Bonding??? ricey Linux - Newbie 4 07-29-2002 05:43 PM


All times are GMT -5. The time now is 04:37 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration