LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 08-10-2008, 01:48 PM   #1
metallica1973
Senior Member
 
Registered: Feb 2003
Location: Washington D.C
Posts: 2,116

Rep: Reputation: 58
CentOS 5/ Apache2 and Virtual hosts


I have setup CentOS 5, Apache, and am trying to host several website via vhosts. I am using
one static ip address and vhosts to allow access to all multiple website on this server. I
have the web server on the DMZ, created a rule using IPTABLES to allow access to the web server
on the DMZ via tcp 80. I have also done this as well on the web server to allow access to tcp
port 80. I have changed the DNS entry on my domain registrar to point to my static ip address at
the office. It is not working and I am trying to figure this out and need help from the Gurus. I used this tutorial:

http://www.linux-noob.com/forums/ind...?showtopic=659

I place my web pages in /var/www/html/Test.com/

PHP Code:

ls 
-/var/www/html/test.com/
Images/                                Test.com.html          Test_Under_Construction.html 
here is my /etc/httpd

PHP Code:
NameVirtualHost 192.168.2.24:80

<VirtualHost 192.168.2.24:80>
    
ServerAdmin test@yahoo.com
    DocumentRoot 
/var/www/html/Test.com/
    
ServerName Test.com
#    ErrorLog logs/dummy-host.example.com-error_log
#    CustomLog logs/dummy-host.example.com-access_log common
</VirtualHost>

<
VirtualHost 192.168.2.24:80>
    
ServerAdmin test2@yahoo.com
    DocumentRoot 
/var/www/html/Test2.com/
    
ServerName Test2.com
#    ErrorLog logs/dummy-host.example.com-error_log
#    CustomLog logs/dummy-host.example.com-access_log common
</VirtualHost
My iptable rules on the External Firewall\Proxy.

PHP Code:
$IPTABLES -A FORWARD -p tcp -i $EXTIF -o $DMZ_IFACE -d $DMZ_WEB_SERVER --dport 80 -m state --state NEW -j ACCEPT
$IPTABLES 
-t nat -A PREROUTING -p tcp -i $EXTIF --dport 80 -j DNAT --to-destination $DMZ_WEB_SERVER 
On the web server itself I have 80 allowed through the firewall.

PHP Code:
  1    44 ACCEPT     tcp  --  *      *       0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:80 
the Apache access log:

PHP Code:
127.0.0.1 - - [10/Aug/2008:01:05:26 -0400"GET / HTTP/1.1" 403 5043 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"
127.0.0.1 - - [10/Aug/2008:01:05:26 -0400"GET /icons/apache_pb.gif HTTP/1.1" 200 2326 "http://localhost/" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"
127.0.0.1 - - [10/Aug/2008:01:05:26 -0400"GET /icons/powered_by_rh.png HTTP/1.1" 200 1213 "http://localhost/" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"
127.0.0.1 - - [10/Aug/2008:01:05:27 -0400"GET /favicon.ico HTTP/1.1" 404 283 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"127.0.0.1 - - [10/Aug/2008:01:05:30 -0400"GET /favicon.ico HTTP/1.1" 404 283 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1 
I know that the Domain registrar is pointing to the correct public address. I changed the A record to point to our public addess.

PHP Code:
 nslookup test.com
Server
:         4.2.2.5
Address
:        4.2.2.5#53

Non-authoritative answer:
Name:   test.com
Address
XX.XXX.XX.XX 

Could my proxy being the cause of the issue. This is the only rule that I have
on my firewall in regards to the proxy and it is a redirection rule tell all of my client traffic to go through the proxy transparently.

PHP Code:
$IPTABLES -t nat -A PREROUTING -i $INTIF -p tcp -$SQUID_BOX --dport 80 -j REDIRECT --to-ports $DG_PORT 
What am I doing wrong?

Last edited by metallica1973; 08-13-2008 at 10:04 AM.
 
Old 08-11-2008, 06:58 AM   #2
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
That's really hard to read.

What is the problem exactly? What is happening and what isn't?

Edit - what's in /var/www/html/Test2.com/

Last edited by billymayday; 08-11-2008 at 07:01 AM.
 
Old 08-11-2008, 09:59 AM   #3
metallica1973
Senior Member
 
Registered: Feb 2003
Location: Washington D.C
Posts: 2,116

Original Poster
Rep: Reputation: 58
Nobody can see any of the web pages. externally or internally. I have placed all of the web pages under there directories.( test.com and test2.com), added the entries under /etc/httpd.

PHP Code:
NameVirtualHost 192.168.2.24:80

<VirtualHost 192.168.2.24:80>
    
ServerAdmin webadmin@yahoo.com
    DocumentRoot 
/var/www/html/Test.com/
    
ServerName Test.com
#    ErrorLog logs/dummy-host.example.com-error_log
#    CustomLog logs/dummy-host.example.com-access_log common
</VirtualHost>

<
VirtualHost 192.168.2.24:80>
    
ServerAdmin webadmin@yahoo.com
    DocumentRoot 
/var/www/html/Test2.com/
    
ServerName Test2.com
#    ErrorLog logs/dummy-host.example.com-error_log
#    CustomLog logs/dummy-host.example.com-access_log common
</VirtualHost
I ran

PHP Code:
httpd -S
VirtualHost configuration
:
192.168.2.24:*         is a NameVirtualHost
         
default server www.test.com (/etc/httpd/conf/httpd.conf:972)
         
port namevhost www.test.com (/etc/httpd/conf/httpd.conf:972)
         
port namevhost www.test2.com (/etc/httpd/conf/httpd.conf:1022)
192.168.2.24:*         is a NameVirtualHost
         
default server www.test.com (/etc/httpd/conf/httpd.conf:972)
         
port namevhost www.test.com (/etc/httpd/conf/httpd.conf:972)
         
port namevhost www.test2.com (/etc/httpd/conf/httpd.conf:1022)
wildcard NameVirtualHosts and _default_ servers:
_default_:443          localhost (/etc/httpd/conf.d/ssl.conf:81)
Syntax OK 
and also

PHP Code:
httpd -
I cant see a web page from the net or locally. How can I test to see if apache is setup fine? What else can I do?
 
Old 08-11-2008, 10:11 AM   #4
Mr. C.
Senior Member
 
Registered: Jun 2008
Posts: 2,529

Rep: Reputation: 59
Focus first on determining if the traffic is even hitting the server, and then hitting apache.

What do your apache access and error logs show?
 
Old 08-11-2008, 10:38 AM   #5
junpa
Member
 
Registered: Aug 2008
Location: Northern Hemisphere
Distribution: Slackware, OpenVMS, fbsd
Posts: 50

Rep: Reputation: 16
metallica1973,

what are the permissions on the files under /var/www/html/* ?

what exactly happens when you try to visit the site? do you get a 404 or 403 etc ?

does the site work if you connect from the box the webserver is on?
Quote:
Originally Posted by metallica1973 View Post

the Apache access log:

Code:
127.0.0.1 - - [10/Aug/2008:01:05:26 -0400] "GET / HTTP/1.1" 403 5043 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"
127.0.0.1 - - [10/Aug/2008:01:05:26 -0400] "GET /icons/apache_pb.gif HTTP/1.1" 200 2326 "http://localhost/" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"
127.0.0.1 - - [10/Aug/2008:01:05:26 -0400] "GET /icons/powered_by_rh.png HTTP/1.1" 200 1213 "http://localhost/" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"
127.0.0.1 - - [10/Aug/2008:01:05:27 -0400] "GET /favicon.ico HTTP/1.1" 404 283 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"
127.0.0.1 - - [10/Aug/2008:01:05:30 -0400] "GET /favicon.ico HTTP/1.1" 404 283 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1
those logs only show you trying to connect to localhost what about the logs for the vhost connection attempts?
 
Old 08-11-2008, 05:02 PM   #6
metallica1973
Senior Member
 
Registered: Feb 2003
Location: Washington D.C
Posts: 2,116

Original Poster
Rep: Reputation: 58
Here is a snippet of /var/log/https/access_log

PHP Code:
 cat /var/log/httpd/access_log
127.0.0.1 
- - [10/Aug/2008:01:05:26 -0400"GET /icons/apache_pb.gif HTTP/1.1" 200 2326 "http://localhost/" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"
127.0.0.1 - - [10/Aug/2008:01:05:26 -0400"GET /icons/powered_by_rh.png HTTP/1.1" 200 1213 "http://localhost/" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"
127.0.0.1 - - [10/Aug/2008:01:05:27 -0400"GET /favicon.ico HTTP/1.1" 404 283 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"
127.0.0.1 - - [10/Aug/2008:01:05:30 -0400"GET /favicon.ico HTTP/1.1" 404 283 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"
193.239.68.6 - - [10/Aug/2008:16:56:45 -0400"GET http://www-w.bigmir.net/pt.php?ri=1 HTTP/1.0" 404 285 "http://www-w.bigmir.net/" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; KP)"
127.0.0.1 - - [10/Aug/2008:20:43:50 -0400"GET /server-status HTTP/1.1" 404 285 "-" "ELinks/0.11.1 (textmode; Linux; -)"
127.0.0.1 - - [10/Aug/2008:20:44:21 -0400"GET /server-status HTTP/1.1" 404 285 "-" "ELinks/0.11.1 (textmode; Linux; -)"
192.168.2.24 - - [10/Aug/2008:20:58:33 -0400"GET / HTTP/1.1" 403 5043 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"
192.168.2.24 - - [10/Aug/2008:20:58:33 -0400"GET /icons/apache_pb.gif HTTP/1.1" 200 2326 "http://192.168.2.24/" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"
192.168.2.24 - - [10/Aug/2008:20:58:33 -0400"GET /icons/powered_by_rh.png HTTP/1.1" 200 1213 "http://192.168.2.24/" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"
192.168.2.24 - - [10/Aug/2008:20:58:33 -0400"GET /favicon.ico HTTP/1.1" 404 286 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"
192.168.2.24 - - [10/Aug/2008:20:58:36 -0400"GET /favicon.ico HTTP/1.1" 404 286 "-" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.1) Gecko/2008071616 CentOS/3.0.1-1.el5.centos Firefox/3.0.1"
68.50.23.232 - - [11/Aug/2008:00:10:22 -0400"GET / HTTP/1.1" 403 298 "http://search.yahoo.com/search?p=makingpureair.com&fr=yfp-t-501&toggle=1&cop=mss&ei=UTF-8" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; WOW64; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; Media Center PC 5.0; PeoplePal 7.0) w:PACBHO60"
68.50.23.232 - - [11/Aug/2008:00:10:33 -0400"GET / HTTP/1.1" 403 298 "http://search.yahoo.com/search?p=makingpureair.com&fr=yfp-t-501&toggle=1&cop=mss&ei=UTF-8" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; WOW64; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; Media Center PC 5.0; PeoplePal 7.0) w:PACBHO60"
68.50.23.232 - - [11/Aug/2008:00:14:08 -0400"GET / HTTP/1.1" 403 298 "http://search.yahoo.com/search?p=makingpureair.com&fr=yfp-t-501&toggle=1&cop=mss&ei=UTF-8" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; WOW64; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; Media Center PC 5.0; PeoplePal 7.0) w:PACBHO60"
68.50.23.232 - - [11/Aug/2008:00:17:57 -0400"GET / HTTP/1.1" 403 298 "-" "Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.0; WOW64; SLCC1; .NET CLR 2.0.50727; .NET CLR 3.0.04506; Media Center PC 5.0; PeoplePal 7.0) w:PACBHO60"
66.249.6.106 - - [11/Aug/2008:02:34:33 -0400"GET / HTTP/1.1" 200 1768 "-" "websitepulse checker/1.1 (compatible; MSIE 5.5; Netscape 4.75; Linux)"
60.172.219.2 - - [11/Aug/2008:07:10:50 -0400"GET http://scifi.pages.at/myproxies/azenv.php HTTP/1.1" 404 303 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)"
60.172.219.2 - - [11/Aug/2008:11:09:00 -0400"GET http://scifi.pages.at/myproxies/azenv.php HTTP/1.1" 404 303 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)"
60.172.219.2 - - [11/Aug/2008:11:41:05 -0400"GET http://scifi.pages.at/myproxies/azenv.php HTTP/1.1" 404 303 "-" "Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)" 
Here is a snippet of /var/log/httpd/error_log

PHP Code:
[Mon Aug 11 01:31:39 2008] [noticemod_pythonCreating 4 session mutexes based on 150 max processes and 0 max threads.
[
Mon Aug 11 01:31:40 2008] [noticeApache/2.2.3 (CentOSconfigured -- resuming normal operations
[Mon Aug 11 01:31:46 2008] [noticeSIGHUP received.  Attempting to restart
[Mon Aug 11 01:31:46 2008] [noticeDigestgenerating secret for digest authentication ...
[
Mon Aug 11 01:31:46 2008] [noticeDigestdone
[Mon Aug 11 01:31:46 2008] [noticemod_pythonCreating 4 session mutexes based on 150 max processes and 0 max threads.
[
Mon Aug 11 01:31:46 2008] [noticeApache/2.2.3 (CentOSconfigured -- resuming normal operations
[Mon Aug 11 01:49:25 2008] [noticecaught SIGTERMshutting down
[Mon Aug 11 01:49:26 2008] [noticecore dump file size limit raised to 4294967295 bytes
[Mon Aug 11 01:49:26 2008] [noticeSELinux policy enabledhttpd running as context user_u:system_r:httpd_t
[Mon Aug 11 01:49:26 2008] [noticesuEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[
Mon Aug 11 01:49:26 2008] [noticeDigestgenerating secret for digest authentication ...
[
Mon Aug 11 01:49:26 2008] [noticeDigestdone
[Mon Aug 11 01:49:26 2008] [noticemod_pythonCreating 4 session mutexes based on 150 max processes and 0 max threads.
[
Mon Aug 11 01:49:26 2008] [noticeApache/2.2.3 (CentOSconfigured -- resuming normal operations
[Mon Aug 11 01:49:29 2008] [noticeSIGHUP received.  Attempting to restart
[Mon Aug 11 01:49:29 2008] [noticeDigestgenerating secret for digest authentication ...
[
Mon Aug 11 01:49:29 2008] [noticeDigestdone
[Mon Aug 11 01:49:29 2008] [noticemod_pythonCreating 4 session mutexes based on 150 max processes and 0 max threads.
[
Mon Aug 11 01:49:30 2008] [noticeApache/2.2.3 (CentOSconfigured -- resuming normal operations
[Mon Aug 11 07:10:50 2008] [error] [client 60.172.219.2File does not exist: /var/www/html/test.com/myproxies
[Mon Aug 11 11:09:00 2008] [error] [client 60.172.219.2File does not exist: /var/www/html/test.com/myproxies
[Mon Aug 11 11:41:05 2008] [error] [client 60.172.219.2File does not exist: /var/www/html/test.com/myproxies 
I can see that an external client 60.172.219.2 is looking to access the site but what does

PHP Code:
Mon Aug 11 11:41:05 2008] [error] [client 60.172.219.2File does not exist: /var/www/html/test.com/myproxies 
mean? I have the index.html in that directory so what is the problem. Why is it trying to access myproxies?

the permissions of /var/www/html

PHP Code:
drwxr-xr-x 5 apache apache 4096 Aug  9 23:59 /var/www/html 
What should the permissions of the each website directories be? (/var/www/html/test.com)

When I connect to the website I get a 111 connection refused error(Internally).

What do you mean by connecting to the webpage from the box locally?

From reading the error codes from the access_logs 404 and 403 are forbidden and file not found. So I believe that it is apparent that either the

httpd.conf is wrong and possible the permission of the directories and files. Can someone show me a sample httpd.conf with vhost directives enabled?

Last edited by metallica1973; 08-11-2008 at 05:23 PM.
 
Old 08-11-2008, 05:38 PM   #7
metallica1973
Senior Member
 
Registered: Feb 2003
Location: Washington D.C
Posts: 2,116

Original Poster
Rep: Reputation: 58
I can access it locally via the ip address(192.168.2.24) but not by name. I changed the A record on the domain registrar to point to my firewall (Public IP) and through NAT to my web server(Private IP).

Last edited by metallica1973; 08-11-2008 at 05:39 PM.
 
Old 08-11-2008, 06:51 PM   #8
metallica1973
Senior Member
 
Registered: Feb 2003
Location: Washington D.C
Posts: 2,116

Original Poster
Rep: Reputation: 58
I have made progress. The website is able to be seen externally now but it cant be viewed internally so it is a firewall issue. I have to look at my iptables script and figure it out.

Can anyone suggest an iptables rule that will allow traffic externally to hit my web server and also only allow traffic internally to view

the web server and not compromise security?

Last edited by metallica1973; 08-11-2008 at 07:06 PM.
 
Old 08-13-2008, 09:57 AM   #9
metallica1973
Senior Member
 
Registered: Feb 2003
Location: Washington D.C
Posts: 2,116

Original Poster
Rep: Reputation: 58
I resolved the issue. To make a long story short, it turns out that I had it working the whole time
and that that I had two issues that were causing issue. Well actually I had the main site working but
the other websites were not. I used a certain naming convention with my web pages and even though they
ended with html,htm and etc apache didnt like it. I checked the /var/log/httpd/error_log and noticed

PHP Code:
 Directory index forbidden by Options directive: /var/www/html/test.com
I did a google search and found that you had to have at least a empty index.html in the directory in
order for it to work. I did that and still had issues so I just named the start page index.html and bam
it worked. I have more reading to do but at least it is working. Secondly were the permissions of my directories.
That was a bit tricky but somewhat have gotten that straighten out

Here is my httpf.conf for any future user who is having the same issue:

PHP Code:
NameVirtualHost *:80
<VirtualHost  *:80>
        
DocumentRoot /var/www/html/test_site1 
 
        ServerAdmin faeendios
@test_site1.com
        ServerName www
.test_site1.com


        ServerAlias test_site1
.com *.test_site1.com
 
 
        DirectoryIndex index
.html index.htm index.shtml index.php 
        
<Directory "/var/www/html/test_site1">
                
Options all
                AllowOverride none
        
</Directory
       
LogLevel debug
        HostNameLookups off
        
</VirtualHost>
<
VirtualHost *:80>
        
DocumentRoot /var/www/html/test_site2.org

        ServerAdmin Carlos
@test_site2.org
        ServerName www
.test_site2.org

        ServerAlias test_site2
.org *.test_site2.org

        DirectoryIndex index
.html index.htm index.shtml

        
<Directory "/var/www/html/test_site2">
</
Directory>
</
VirtualHost>
<
Directory "/">
        
Options FollowSymLinks
        AllowOverride None
</Directory>

<
Directory "/var/www/html">
        
Options Indexes Includes FollowSymLinks
        AllowOverride None
        Allow from all
       Order allow
,deny
</Directory>
<
Directory "/var/www/icons">
        
Options Indexes MultiViews
       AllowOverride None
        Allow from all
       Order allow
,deny
</Directory>
<
Directory "/var/www/cgi-bin">
        
Options ExecCGI
        AllowOverride None
        Allow from all
       Order allow
,deny
</Directory
As far as the directory permission is concerned, I used 755 on the directories and sub-directories of the websites.
When I finished making my adjustments I used 755 on the main directory of the website and 600 on the sub-directories.
I dont know if that is the correct permissions to use but it workes for me. Any feedback would be greatly appreciated.

Last edited by metallica1973; 08-13-2008 at 10:05 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache2 virtual hosts dave`2005 Ubuntu 1 11-19-2007 08:17 AM
Virtual hosts on apache2 70mas Linux - Server 3 07-16-2007 03:29 AM
Apache2 - need help with virtual hosts bioalchemist Linux - Software 5 08-11-2006 02:24 PM
Apache2, SSL, 2 Virtual Hosts franticbob Linux - Software 0 04-07-2004 10:48 PM
apache2 virtual hosts viniosity Linux - Software 4 02-07-2004 01:15 AM


All times are GMT -5. The time now is 06:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration