LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices

Reply
 
Search this Thread
Old 07-24-2008, 09:37 PM   #1
Sinedie
Member
 
Registered: Nov 2006
Posts: 71

Rep: Reputation: 15
CentOS 5.2: Only one of eth0 (internet) or eth1 (LAN) works


Hello,
I am trying to setup a server with two networks, internet access through eth0 and LAN through eth1. The problem is that only one of them works at a given time.

I tried to specify route through the Network GUI for the corresponding device but it says 'file already exists' in case both devices are simultaneously have route set. I am confused over this and I have been using the same IP and subnet masks that I have been using prior to the installation of CentOS (on SuSE).

Can someone advice me on getting both eth0 and eth1 working simultaneously please?

Thanking in advance,
-S
 
Old 07-24-2008, 10:29 PM   #2
kenoshi
Member
 
Registered: Sep 2007
Location: SF Bay Area, CA
Distribution: CentOS, SLES 10+, RHEL 3+, Debian Sarge
Posts: 159

Rep: Reputation: 32
Its really hard to troubleshoot routing issues without route, or contents of ifcfg-eth0 and 1.

Can you please supply the following information:

- printout of route
- contents of /etc/sysconfig/network-scripts/ifcfg-eth0
- contents of /etc/sysconfig/network-scripts/ifcfg-eth1
- IP/subnet mask of eth0 and eth1
- gateway/router interface IPs

Thanks.

Last edited by kenoshi; 07-24-2008 at 10:30 PM.
 
Old 07-24-2008, 10:42 PM   #3
Sinedie
Member
 
Registered: Nov 2006
Posts: 71

Original Poster
Rep: Reputation: 15
Thanks kenoshi,
Yes, I should have done it. Was experimenting and lost connection with the system altogether. Will post it in an hour.
Thanks,
-S
 
Old 08-20-2008, 05:52 AM   #4
anshuman84
Member
 
Registered: May 2008
Location: Bangalore
Posts: 31

Rep: Reputation: 6
I also need help for that eth0 and eth1 in REDHAT 8

I also want to connect to the internet in eth0 and eth1 for LAN work . How can I use that simultaneously in REDHAT 8 . plz send me reply
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
eth0(WAN) and eth1(LAN) getting mixed with weird results Artanicus Linux - Networking 3 08-12-2005 08:23 AM
Assigning eth0 / eth1 or multi-LAN motherboards? Eastside Linux - Networking 5 06-13-2005 11:34 PM
Swapping cables to eth0 & eth1 on the same machine still works. Why? ses Linux - Networking 2 06-07-2005 02:31 AM
Firewall WAN eth0 LAN eth1 self-bridges, eth0 does all routeing. Nichole_knc Linux - Networking 5 07-29-2004 03:33 PM
It dznt matter wheter eth0 (internet) or eth1(my lan) lelski Linux - General 1 06-07-2003 09:36 PM


All times are GMT -5. The time now is 11:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration