LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (http://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Can't View Website Through Windows (Apache 2.0, RH 9.0) (http://www.linuxquestions.org/questions/linux-networking-3/cant-view-website-through-windows-apache-2-0-rh-9-0-a-84431/)

TastyWheat 08-22-2003 01:48 AM

Can't View Website Through Windows (Apache 2.0, RH 9.0)
 
As far as my linux box is concerned there's no problem with my web server. However, if I try to view the webpage through Internet Explorer on my Windows machine I get a "Cannot find server" error. What makes this even more confusing is that when I run Apache from my Windows machine I can view the web page from both machines. I checked the httpd.conf files and they're practically the same too. Is there something I'm missing here?

TastyWheat 08-22-2003 08:49 AM

I just asked a friend of mine to check the site and she couldn't see it, so obviously it's not working.

registering 08-22-2003 09:02 AM

The "cannot find server" sounds like a DNS issue. Maybe your windows machine has DNS setup properly, but your Linux box doesn't. Since the website is local to Linux, it doesn't need to resolve anything beyond localhost. (just a guess)

If you do a traceroute on the website from Linux, what IP address does it return? What about from the windows machine?

I don't know windows, but check whatever it uses to resolve names, you might not have your website's name being resolved from your windows machine. If it's world-viewable and you use a 3rd-party DNS, maybe their your website domain IP address hasn't propagated the new IP address yet (i.e., the rootzones aren't updated yet so external queries will fail)?

I'm a newb myself so these are just some ideas...

TastyWheat 08-22-2003 10:12 AM

Well, when I perform a traceroute on linux it immediatley returns my IP address on the first hop. On Windows it keeps timing out and never completes a successful hop. What might be more helpful is that when I did a traceroute from http://www.samspade.org/ it stopped on the 16th hop when looking for my linux box. If I do a traceroute for my Windows box it goes to the 17th hop where it finds my ip.

I do have DNS redirection too. When I type in http://www.somename.com/ it successfully redirects to my ip on my Linux box. If I type in the same address in Windows then I get the same error as before.

stir_frey 08-22-2003 11:39 AM

Is your server sitting on the internet or are you port forwarding into it? If you enter in its ip address can you get the web page up then? If so then its for sure a DNS issue. If not check any firewall or nat rules you have.

TastyWheat 08-22-2003 12:10 PM

Well, if I understand your question correctly, if I type in the ip address of the computer running my web server I don't get the web page. I totally turned off my firewall and that didn't seem to help either. I think there's definately a DNS issue here. When I perform a traceroute from SamSpade.org it finds my Windows machine even though I'm not running a web server. It can't even locate the ip address on my Linux box. In fact I receive a DNS Error on the 14th hop, which I don't receive when I trace my Windows pc. My isp lets me have up to 3 ip addresses (I only have two machines connected right now) and I can surf the interent through my Linux box, so the IP must be valid. This is far beyond my networking knowledge.

I'm just gonna bite the bullet for now and use Apache through... I shutter to say... Windows. I know some guys from school who've setup web servers at home and maybe they can help me out. I still welcome any suggestions, but I won't lose anymore sleep over this.


All times are GMT -5. The time now is 12:39 AM.